Re: IBGP Wont come up - Jitter

From: Dale Shaw <dale.shaw_at_gmail.com>
Date: Thu, 16 Apr 2009 15:57:25 +1000

Hi,

You're missing the "neighbor x update-source lo0" command on each
side. Also, since it's iBGP, you don't need the ebgp-multihop command.

R1:
router bgp 64512
 neighbor 200.200.200.200 update-source lo0
 no neighbor 200.200.200.200 ebgp-multihop

R2:
router bgp 64512
 neighbor 100.100.100.100 update-source lo0
 no neighbor 100.100.100.100 ebgp-multihop

Your peer-group configuration doesn't appear to do anything. This
won't affect the peering coming up though.

cheers,
Dale

2009/4/16 WW)W WWWW W <eshedalonie_at_gmail.com>:
> I Am Using 2 2801
>
> With Version c2801-ipbase-mz.124-20.T2.bin
>
> R1
>
> ====
>
> DEBUG IP BGP ALL
>
> I Am Getting BGP 60% Jitter Error - IBGP doesn't come up.
>
> *Apr 16 05:33:57.947: BGP: 200.200.200.200 open active, local address
> 172.16.1.1
>
> *Apr 16 05:33:57.947: BGP: 200.200.200.200 read request no-op
> *Apr 16 05:33:57.947: BGP: 200.200.200.200 open failed: Connection refused
> by re
> mote host, open active delayed 25188ms (35000ms max, 60% jitter)
>
> R2
>
> ====
>
> DEBUG IP BGP ALL
>
> *Apr 16 05:32:23.375: BGP: 100.100.100.100 open active, local address
> 172.16.1.2
>
> *Apr 16 05:32:23.375: BGP: 100.100.100.100 read request no-op
> *Apr 16 05:32:23.375: BGP: 100.100.100.100 open failed: Connection refused
> by re
> mote host, open active delayed 15182ms (35000ms max, 60% jitter)
> *Apr 16 05:32:38.559: BGP: 100.100.100.100 open active, local address
> 172.16.1.2
>
>
>
> B B B B B B B B B IBGP
>
> 172.16.1.1 B B B B B B B 172.16.1.2
>
> R1 Fa0/3/0 <--------> Fa0/3/0 R2
>
>
>
> *Here is the configuration*
>
> R1#show run
> Building configuration...
>
> Current configuration : 1308 bytes
> !
> version 12.4
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R1
> !
> boot-start-marker
> boot-end-marker
> !
> logging message-counter syslog
> !
> no aaa new-model
> ip source-route
> !
> !
> !
> !
> ip cef
> multilink bundle-name authenticated
> !
> !
> !
> archive
> B log config
> B hidekeys
> !
> !
> !
> !
> !
> interface Loopback0
> B ip address 100.100.100.100 255.255.255.255
> !
> interface FastEthernet0/0
> B ip address 192.168.1.1 255.255.255.0
> B duplex auto
> B speed auto
> B no keepalive
> !
> interface FastEthernet0/1
> B no ip address
> B shutdown
> B duplex auto
> B speed auto
> !
> interface FastEthernet0/3/0
> B ip address 172.16.1.1 255.255.255.252
> B duplex auto
> B speed auto
> !
> router bgp 64512
> B bgp router-id 100.100.100.100
> B bgp log-neighbor-changes
> B neighbor second peer-group
> B neighbor 200.200.200.200 remote-as 64512
> B neighbor 200.200.200.200 peer-group second
> B neighbor 200.200.200.200 ebgp-multihop 3
> B !
> B address-family ipv4
> B neighbor 200.200.200.200 activate
> B no auto-summary
> B no synchronization
> B network 192.168.1.0
> B exit-address-family
> !
> ip forward-protocol nd
> ip route 192.168.1.0 255.255.255.0 Null0 254
> ip route 200.200.200.200 255.255.255.255 172.16.1.2
> !
> !
> no ip http server
> !
> !
> !
> control-plane
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> B login
> !
> scheduler allocate 20000 1000
> end
>
>
>
>
> R2#show run
> Building configuration...
>
> Current configuration : 1306 bytes
> !
> version 12.4
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname Internet-2
> !
> boot-start-marker
> boot-end-marker
> !
> logging message-counter syslog
> !
> no aaa new-model
> ip source-route
> !
> !
> !
> !
> ip cef
> multilink bundle-name authenticated
> !
> !
> !
> archive
> B log config
> B hidekeys
> !
> !
> !
> !
> !
> interface Loopback0
> B ip address 200.200.200.200 255.255.255.255
> !
> interface FastEthernet0/0
> B ip address 192.168.2.1 255.255.255.0
> B duplex auto
> B speed auto
> B no keepalive
> !
> interface FastEthernet0/1
> B no ip address
> B shutdown
> B duplex auto
> B speed auto
> !
> interface FastEthernet0/3/0
> B ip address 172.16.1.2 255.255.255.252
> B duplex auto
> B speed auto
> !
> router bgp 64512
> B bgp router-id 200.200.200.200
> B bgp log-neighbor-changes
> B neighbor first peer-group
> B neighbor 100.100.100.100 remote-as 64512
> B neighbor 100.100.100.100 peer-group first
> B neighbor 100.100.100.100 ebgp-multihop 3
> B !
> B address-family ipv4
> B neighbor 100.100.100.100 activate
> B no auto-summary
> B no synchronization
> B network 192.168.2.0
> B exit-address-family
> !
> ip forward-protocol nd
> ip route 100.100.100.100 255.255.255.255 172.16.1.1
> ip route 192.168.2.0 255.255.255.0 Null0 254
> !
> !
> no ip http server
> !
> !
> !
> control-plane
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> B login
> !
> scheduler allocate 20000 1000
> end
> Internet-2#
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Thu Apr 16 2009 - 15:57:25 ART

This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:12 ART