Hi W.
Did some tests late last night still having the same issue. But what i also
tested is running IS-IS over the trunk links but on the physical interface
and it works fine. MTU on the physical interface on the switch are 1500 and
on the vlan it is set to 9000. bellow is all show runs etc...
R1#sh run int fa0/0
Building configuration...
Current configuration : 111 bytes
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip router isis
speed 100
full-duplex
end
R1#sh run int fa0/0.23
Building configuration...
Current configuration : 145 bytes
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 192.168.0.1 255.255.255.0
ip router isis
isis network point-to-point
end
R1#sh clns neighbors
System Id Interface SNPA State Holdtime Type
Protocol
*R2 Fa0/0.23 c251.2e00.0000 Up 253 IS ES-IS*
*R2 Fa0/0 c251.2e00.0000 Up 9 L1L2 IS-IS*
R1#
R1#sh isis neighbors
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa0/0 10.10.10.2 UP 9
R2.01
R2 L2 Fa0/0 10.10.10.2 UP 9
R2.01
R1#
R1#
R1#sh ip rou
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.10.0.0/32 is subnetted, 2 subnets
i L1 172.10.0.2 [115/256] via 10.10.10.2, FastEthernet0/0
C 172.10.0.1 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, FastEthernet0/0
C 192.168.0.0/24 is directly connected, FastEthernet0/0.23
R1#
SW1#sh int fa0/1
FastEthernet0/1 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is 000b.4616.7681 (bia 000b.4616.7681)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
SW1#sh int fa0/2
FastEthernet0/2 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is 000b.4616.7682 (bia 000b.4616.7682)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
SW1#sh run int fa0/1
Building configuration...
Current configuration : 94 bytes
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
end
SW1#sh run int fa0/2
Building configuration...
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
end
SW1#sh vlan id 23
VLAN Name Status Ports
---- -------------------------------- ---------
-------------------------------
23 VLAN_23 active Fa0/1, Fa0/2, Fa0/24
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------
------
23 enet 100023 9000 - - - - - 0 0
SW1#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
SW2 Fas 0/24 166 S I WS-C3550- Fas 0/24
R2 Fas 0/2 160 R S I 3725 Fas 0/0
R1 Fas 0/1 178 R S I 3725 Fas 0/0
SW1#
Regards
Dheven
On Thu, Apr 9, 2009 at 5:43 AM, Ernest Wambari <ewambari_at_gmail.com> wrote:
> Hi Dheven,
>
> You could check these switches system MTU settings.Check if the match.
>
> Regards,
>
> W.
>
>
> On Wed, Apr 8, 2009 at 9:20 PM, Dheven <dheven_at_gmail.com> wrote:
>
>> Hi W.
>>
>> bypassed the 2 3550s and IS-IS works fine.
>>
>> R1 config:
>> interface Loopback0
>> ip address 172.10.10.1 255.255.255.255
>> ip router isis
>> !
>> interface FastEthernet0/0
>> no ip address
>> duplex half
>> !
>> interface FastEthernet0/0.12
>> encapsulation dot1Q 12
>> ip address 10.10.12.1 255.255.255.0
>> ip router isis
>> !
>> router isis
>> net 49.0001.0000.0000.0001.00
>> !
>> R1#sh clns neighbors
>>
>> System Id Interface SNPA State Holdtime Type
>> Protocol
>> R2 Fa0/0.12 ca46.2c19.0000 Up 8 L1L2 IS-IS
>> R1#
>>
>> R1#sh isis neighbors
>>
>> System Id Type Interface IP Address State Holdtime Circuit Id
>> R2 L1 Fa0/0.12 10.10.12.2 UP 8
>> R2.01
>> R2 L2 Fa0/0.12 10.10.12.2 UP 9
>> R2.01
>> R1#
>>
>> R1#sh cdp neighbors
>> Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
>> S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
>>
>> Device ID Local Intrfce Holdtme Capability
>> Platform Port ID
>> R2 Fas 0/0 153 R
>> 7206VXR Fas 0/0
>> R1#
>>
>> Does anyone know why this setup does work across the 3550s?
>>
>> Dheven
>>
>>
>> On Wed, Apr 8, 2009 at 6:24 PM, Ernest Wambari <ewambari_at_gmail.com>wrote:
>>
>>> ES-IS instead of IS-IS adjacencies form in most cases due to IS-IS hellos
>>> not being processed - either due to MTU mismatch somewhere along the link or
>>> invalid authentication.
>>>
>>> I would try and simplify my scenario by eliminating the switches between
>>> the two routers first and then work my way out to the full topology.
>>>
>>> Regards,
>>>
>>> W.
>>>
>>>
>>> On Wed, Apr 8, 2009 at 7:04 PM, Dheven <dheven_at_gmail.com> wrote:
>>>
>>>> Hi GS,
>>>>
>>>> After adding the isis network point-to-point get the clns adj.
>>>>
>>>> R1#sh clns neighbors
>>>>
>>>> System Id Interface SNPA State Holdtime Type
>>>> Protocol
>>>> 0000.0000.0002 Fa0/0.12 c20f.20fb.0000 Up 274 IS *
>>>> ES-IS*
>>>> R1#
>>>>
>>>> It is forming ES-IS instead of IS-IS
>>>>
>>>>
>>>> BUT still cannot get IS-IS to form adj.
>>>>
>>>> R1#sh isis neighbors
>>>>
>>>> System Id Type Interface IP Address State Holdtime Circuit
>>>> Id
>>>> R1#
>>>>
>>>>
>>>> Regards
>>>>
>>>> Dheven
>>>>
>>>>
>>>>
>>>> On Wed, Apr 8, 2009 at 3:33 PM, Dheven <dheven_at_gmail.com> wrote:
>>>>
>>>>> Reza,
>>>>>
>>>>> Ran wireshark but not seeing strange. Can anyone simulate this issue?
>>>>> BTW im running Dynamips 3725 with ios
>>>>> c3725-adventerprisek9-mz.124-15.T5.bin
>>>>>
>>>>> Dheven
>>>>>
>>>>>
>>>>> On Wed, Apr 8, 2009 at 2:55 PM, Reza Toghraee <reza_at_toghraee.com>wrote:
>>>>>
>>>>>> As a debug method I suggest to turn the switch ports which are
>>>>>> connected to
>>>>>> the routers as a span input, and send it to a wireshark and check
>>>>>> what's
>>>>>> going on,
>>>>>>
>>>>>>
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf
>>>>>> Of
>>>>>> Dheven
>>>>>> Sent: Wednesday, April 08, 2009 4:50 PM
>>>>>> To: Dishan Gamage
>>>>>> Cc: Ernest Wambari; ccielab_at_groupstudy.com
>>>>>> Subject: Re: IS-IS issue over ethernet subinterface
>>>>>>
>>>>>> Firstly I assume hardware issue... but its not. configured OSPF over
>>>>>> the
>>>>>> link and adjacencies formed no issue.
>>>>>>
>>>>>> R1#
>>>>>> *Mar 1 00:18:22.567: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on
>>>>>> FastEthernet0/0.12 from LOADING to FULL, Loading Done
>>>>>> R1#
>>>>>>
>>>>>> R1#sh ip ospf neighbor
>>>>>>
>>>>>> Neighbor ID Pri State Dead Time Address
>>>>>> Interface
>>>>>> 2.2.2.2 1 FULL/DR 00:00:35 10.10.10.2
>>>>>> FastEthernet0/0.12
>>>>>> R1#
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Apr 8, 2009 at 2:45 PM, Dishan Gamage <dishanlg_at_gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>> > seems that its sending but not receiving any agj-packets from remote
>>>>>> router
>>>>>> >
>>>>>> >
>>>>>> >
>>>>>> > On Wed, Apr 8, 2009 at 3:40 PM, Dheven <dheven_at_gmail.com> wrote:
>>>>>> >
>>>>>> >> R1#ping 10.10.10.2
>>>>>> >>
>>>>>> >> Type escape sequence to abort.
>>>>>> >> Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
>>>>>> >> !!!!!
>>>>>> >> Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4
>>>>>> ms
>>>>>> >>
>>>>>> >> R1#sh isis neighbors
>>>>>> >>
>>>>>> >> System Id Type Interface IP Address State Holdtime
>>>>>> Circuit Id
>>>>>> >> R1#
>>>>>> >>
>>>>>> >>
>>>>>> >> On Wed, Apr 8, 2009 at 2:29 PM, Ernest Wambari <ewambari_at_gmail.com
>>>>>> >wrote:
>>>>>> >>
>>>>>> >>> Hello Dheven,
>>>>>> >>>
>>>>>> >>> Please provide the following:
>>>>>> >>>
>>>>>> >>> 1.sh clns nei
>>>>>> >>> 2.debug isis adj-packet
>>>>>> >>>
>>>>>> >>> Regards,
>>>>>> >>>
>>>>>> >>> W.
>>>>>> >>>
>>>>>> >>> On Wed, Apr 8, 2009 at 2:57 PM, Dheven <dheven_at_gmail.com> wrote:
>>>>>> >>>
>>>>>> >>>> Hi GS,
>>>>>> >>>> I am having a issue setting up IS-IS over ethernet subinterfaces.
>>>>>> >>>>
>>>>>> >>>> here is my setup:
>>>>>> >>>>
>>>>>> >>>> R1 (trunk) ---(trunk) SW1 (trunk) ----(trunk) SW2 (trunk) -----
>>>>>> (trunk)
>>>>>> >>>> R2
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> R1 Configs:
>>>>>> >>>>
>>>>>> >>>> int fa0/0.12
>>>>>> >>>> encapsulation dot1q 12
>>>>>> >>>> ip address 10.10.10.1 255.255.255.0
>>>>>> >>>> ip router isis
>>>>>> >>>>
>>>>>> >>>> router isis
>>>>>> >>>> net 47.0001.0000.0000.0001.00
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> SW1 configs:
>>>>>> >>>>
>>>>>> >>>> fa0/1
>>>>>> >>>> switchport trunk encap dot1q
>>>>>> >>>> switch port trunk allowed vlan 12
>>>>>> >>>> switch mode trunk
>>>>>> >>>>
>>>>>> >>>> vlan 12 is carried across the trunk link between SW1 and SW2
>>>>>> >>>>
>>>>>> >>>> R2 configs:
>>>>>> >>>>
>>>>>> >>>> Int fa0/0.12
>>>>>> >>>> encapsulation dot1q 12
>>>>>> >>>> ip address 10.10.10.2 255.255.255.0
>>>>>> >>>> ip router isis
>>>>>> >>>>
>>>>>> >>>> router isis
>>>>>> >>>> net 49.0001.0000.0000.0002.00
>>>>>> >>>>
>>>>>> >>>> SW2 configs:
>>>>>> >>>> int fa0/2
>>>>>> >>>> switchport trunk encap dot1q
>>>>>> >>>> switch port trunk allowed vlan 12
>>>>>> >>>> switch mode trunk
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> Please help.
>>>>>> >>>>
>>>>>> >>>> Regards
>>>>>> >>>>
>>>>>> >>>> Dheven
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> Blogs and organic groups at http://www.ccie.net
>>>>>> >>>>
>>>>>> >>>>
>>>>>> _______________________________________________________________________
>>>>>> >>>> Subscription information may be found at:
>>>>>> >>>> http://www.groupstudy.com/list/CCIELab.html
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>
>>>>>> >>
>>>>>> >>
>>>>>> >> --
>>>>>> >> Always forgive your enemies - Nothing annoys them so much.
>>>>>> >>
>>>>>> >>
>>>>>> >>
>>>>>> >
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Always forgive your enemies - Nothing annoys them so much.
>>>>>>
>>>>>>
>>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>>
>>>>>>
>>>>>> _______________________________________________________________________
>>>>>> Subscription information may be found at:
>>>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> __________ Information from ESET NOD32 Antivirus, version of virus
>>>>>> signature
>>>>>> database 3981 (20090401) __________
>>>>>>
>>>>>> The message was checked by ESET NOD32 Antivirus.
>>>>>>
>>>>>> http://www.eset.com
>>>>>>
>>>>>>
>>>>>>
>>>>>> __________ Information from ESET NOD32 Antivirus, version of virus
>>>>>> signature
>>>>>> database 3981 (20090401) __________
>>>>>>
>>>>>> The message was checked by ESET NOD32 Antivirus.
>>>>>>
>>>>>> http://www.eset.com
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Always forgive your enemies - Nothing annoys them so much.
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Always forgive your enemies - Nothing annoys them so much.
>>>>
>>>>
>>>>
>>>
>>
>>
>> --
>> Always forgive your enemies - Nothing annoys them so much.
>>
>>
>>
>
-- Always forgive your enemies - Nothing annoys them so much. Blogs and organic groups at http://www.ccie.netReceived on Thu Apr 09 2009 - 10:51:35 ART
This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:11 ART