Re: RIP summary address

From: Pavel Bykov <slidersv_at_gmail.com>
Date: Mon, 6 Apr 2009 09:07:31 +0200

And if you want to fully emulate the summarization, you would also filter
out advertising of the composite networks, preferably with the prefix list
(only two lines required in this case)

On Wed, Apr 1, 2009 at 7:39 PM, Divin Mathew John <divinjohn_at_gmail.com>wrote:

> R0
>
> > !
> > interface Loopback0
> > ip address 192.168.1.1 255.255.255.0
> > !
> > interface Loopback1
> > ip address 192.168.2.1 255.255.255.0
> > !
> > interface Loopback2
> > ip address 192.168.3.1 255.255.255.0
> > !
> > interface Loopback3
> > ip address 192.168.19.1 255.255.255.0
> > !
> > interface Loopback4
> > ip address 192.168.10.1 255.255.255.0
> > !
> > interface FastEthernet0/0
> > ip address 135.10.23.1 255.255.255.0
> > duplex auto
> > speed auto
> > !
> > interface FastEthernet0/1
> > no ip address
> > shutdown
> > duplex auto
> > speed auto
> > !
> > router rip
> > version 2
> > * redistribute static*
> > network 135.10.0.0
> > no auto-summary
> > !
> > ip classless
> > *ip route 192.168.0.0 255.255.224.0 Null0*
> > ip http server
> > ip pim bidir-enable
> > !
> >
> >
> R1
>
> > !
> > interface FastEthernet0/0
> > ip address 135.10.23.2 255.255.255.0
> > duplex auto
> > speed auto
> > !
> > interface FastEthernet0/1
> > no ip address
> > shutdown
> > duplex auto
> > speed auto
> > !
> > router rip
> > version 2
> > network 135.10.0.0
> > no auto-summary
> > !
> >
>
> R1#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 135.10.0.0/24 is subnetted, 1 subnets
> C 135.10.23.0 is directly connected, FastEthernet0/0
> *R 192.168.0.0/19 [120/1] via 135.10.23.1, 00:00:05, FastEthernet0/0*
>
>
> The "ip summary-address rip" interface command supports summarization only
> up to the class-ful network boundaries.
>
> If you had 10.1.2.0/24 you could summarize this to any summary from /8 to
> /23, but a /7 summary would not work.
>
> EIGRP does permit supernet summaries, including 0.0.0.0 0.0.0.0 to provide
> a
> default route for the neighbor on the interface the summary is configured
> on.
>
> Thats a Cisco Ripv2 Implementation [problem.. RIPv2 by default support
> supernetting but Ripv2 in Cisco boxes dont! so...the way out is create a
> Static route of the desired summary and point it to NULL0 and then
> redistribute static.. that way u get the Summary address to be advertised.
>
> HTH
>
>
> Thanking You
>
> Yours Sincerely
>
> Divin Mathew John
> divinjohn_at_gmail.com
> divin_at_dide3d.com
> +91 9945430983
> +91 9846697191
> +974 5008916
> PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
>
>
> On Wed, Apr 1, 2009 at 9:38 PM, Hattan Bailony <hbailony_at_gmail.com> wrote:
>
> > 135.10.23.x /24
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>

-- 
Pavel Bykov
----------------
Don't forget to help stopping the braindumps, use of which reduces value of
your certifications. Sign the petition at http://www.stopbraindumps.com/
Blogs and organic groups at http://www.ccie.net
Received on Mon Apr 06 2009 - 09:07:31 ART

This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:11 ART