Re: simple question regarding the Routing Table.

From: Divin Mathew John (divinjohn@gmail.com)
Date: Mon Mar 30 2009 - 14:48:32 ART


R0

interface Loopback0
> ip address 5.5.5.5 255.255.255.252
> !
> interface FastEthernet0/0
> ip address 172.16.1.1 255.255.255.252
> duplex auto
> speed auto
> !
> interface FastEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
> !
> router ospf 1
> log-adjacency-changes
> redistribute connected subnets
> network 172.16.1.1 0.0.0.0 area 0
> !
> ip classless
> ip http server
> ip pim bidir-enable
>

R1

interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 172.16.1.2 0.0.0.0 area 0
!
ip classless
ip http server
ip pim bidir-enable
!

r1#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 5.0.0.0/30 is subnetted, 1 subnets
> O E2 5.5.5.4 [110/20] via 172.16.1.1, 00:01:59, FastEthernet0/0
> 172.16.0.0/30 is subnetted, 1 subnets
> C 172.16.1.0 is directly connected, FastEthernet0/0
>

Thanking You

Yours Sincerely

Divin Mathew John
divinjohn@gmail.com
divin@dide3d.com
+91 9945430983
+91 9846697191
+974 5008916
PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt

On Mon, Mar 30, 2009 at 10:24 PM, Raghav Bhargava <
raghavbhargava12@gmail.com> wrote:

> yeah agree with narbik... please show the config on your box....
>
>
> raghav
>
> On Mon, Mar 30, 2009 at 9:24 AM, Narbik Kocharians <narbikk@gmail.com
> >wrote:
>
> > You must be missing something, please show all the configs
> >
> > On Mon, Mar 30, 2009 at 9:15 AM, Cisco Fanatic <
> ebay_products@hotmail.com>wrote:
> >
> >> !
> >> int loop0
> >> ip add 5.5.5.5 255.255.255.252
> >> !
> >> router ospf 1
> >> redistribute connected subnets route-map LOOP0
> >> !
> >> route-map LOOP0 permit 10
> >> match interface Loopback0
> >> !
> >>
> >> still seeing 5.5.5.5/32 instead of 5.5.5.5/30?
> >>
> >>
> >>
> >> > Date: Mon, 30 Mar 2009 17:12:38 +0530
> >> > Subject: Re: simple question regarding the Routing Table.
> >> > From: gauravmadan1177@gmail.com
> >> > To: raghavbhargava12@gmail.com
> >> > CC: ccielab@groupstudy.com
> >> >
> >> > Most questions asked by Raghav are already answered , Just adding my
> >> > specific opinon on this
> >> >
> >> > There are a few ways that u need to keep in mind regarding /24 , /32
> >> funda
> >> > and conversion :
> >> >
> >> > [A] LOOPBACK network type is always adv with /32 .
> >> >
> >> > For converting this to right mask :
> >> >
> >> > [A] Adv it as point to point network type
> >> >
> >> > if this is denied
> >> >
> >> > [B] Adv this as external route .
> >> >
> >> > if this is denied
> >> >
> >> > [C] Adv this in a given area and then summarize this area as /24 (
> area
> >> <>
> >> > range )
> >> >
> >> > if this is denied
> >> >
> >> > [D] Adv this loopback in alltogether diff ospf process and do
> >> redistribution
> >> > in 2 ospf processes created ,
> >> >
> >> > These are things that were there my study notes :)))) Ifsomeone has
> more
> >> > ideas ; please pour in :)
> >> >
> >> > HTH
> >> > Gaurav Madan
> >> > CCIE # 23863
> >> >
> >> >
> >> > On Mon, Mar 30, 2009 at 3:16 AM, Raghav Bhargava
> >> <raghavbhargava12@gmail.com
> >> > > wrote:
> >> >
> >> > > Hi Experts,
> >> > >
> >> > > For example we have a loopback interface 0 with the Ip address
> >> 4.4.4.4/24
> >> > >
> >> > > Now when we have to advertise the network in the routing table,
> which
> >> of
> >> > > the
> >> > > following way is correct:-
> >> > >
> >> > > router ospf 1
> >> > > network 4.4.4.4 0.0.0.0 area 4
> >> > >
> >> > > OR
> >> > >
> >> > > router ospf 1
> >> > > network 4.4.4.0 0.0.0.255 area 4
> >> > >
> >> > > coz if we use any of the way we will see this entry in the routing
> >> table:-
> >> > >
> >> > > *4.0.0.0/32* is subnetted, 1 subnets
> >> > > O 4.4.4.4 [110/2] via 1.1.1.1, 00:00:44, FastEthernet0/0
> >> > >
> >> > > Now another question that I have is if i change the network type of
> >> the
> >> > > loopback from LOOPBACK ( which is default ) to point-to-point then
> the
> >> > > routing table entry changes like this
> >> > >
> >> > > *4.0.0.0/24 *is subnetted, 1 subnets
> >> > > O 4.4.4.4 [110/2] via 1.1.1.1, 00:00:44, FastEthernet0/0
> >> > >
> >> > > Please can some one explain this change in the subnet mask????
> >> > >
> >> > > As far as i know PPP converts the /24 or any other subnet into /32
> >> host
> >> > > routes. Maybe i could be wrong here......:)
> >> > >
> >> > >
> >> > > --
> >> > > Warm Regards
> >> > > Raghav
> >> > >
> >> > >
> >> > > Blogs and organic groups at http://www.ccie.net
> >> > >
> >> > >
> >> _______________________________________________________________________
> >> > > Subscription information may be found at:
> >> > > http://www.groupstudy.com/list/CCIELab.html
> >> >
> >> >
> >> > Blogs and organic groups at http://www.ccie.net
> >> >
> >> >
> _______________________________________________________________________
> >> > Subscription information may be found at:
> >> > http://www.groupstudy.com/list/CCIELab.html
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >>
> >> _________________________________________________________________
> >> Windows Live SkyDrive: Get 25 GB of free online storage.
> >>
> http://windowslive.com/online/skydrive?ocid=TXT_TAGLM_WL_skydrive_032009
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> > Narbik Kocharians
> > CCSI#30832, CCIE# 12410 (R&S, SP, Security)
> > www.MicronicsTraining.com
> > www.Net-Workbooks.com
> > Sr. Technical Instructor
> >
>
>
>
> --
> Warm Regards
> Raghav
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:08 ART