QOS with random-detect on a Tunnel interface

From: olumayokun fowowe (olumayokun@gmail.com)
Date: Wed Mar 25 2009 - 11:59:45 ART


Hello Experts,

My goal is to give certain traffic priority over others without having to
allocate bandwidth or use bandwidth percent on a tunnel interface. The
following solution works if my outbound policy(QOS-POLICY) is applied on a
serial interface but I get an error stating that I can apply random-detect
on a tunnel interface! Is there a way I can meet my requirement with or
without random-detect? Any input will be greatly appreciated.

g0/0 -----R1 -----s0/0-------------------------------s0/0-------(R2,R3.....)

And I have the following Qos configured:

access-list 111 permit ip host 10.10.12.50 any
access-list 111 permit ip host 10.10.50.10 any
access-list 111 permit ip host 10.10.50.13 any
access-list 111 permit icmp any any
access-list 111 permit tcp any any eq telnet
access-list 112 permit ip host 10.10.12.130 any
access-list 112 permit ip host 10.10.12.134 any
access-list 112 permit ip host 10.10.12.142 any
access-list 112 permit ip host 10.10.12.214 any
access-list 113 permit ip host 10.10.254.137 any
access-list 113 permit ip host 10.10.254.145 any
access-list 113 permit ip host 10.10.8.53 any
access-list 113 permit ip host 10.10.12.200 any
access-list 113 permit ip host 10.10.12.201 any
access-list 113 permit ip host 10.10.12.205 any
access-list 113 permit ip host 10.10.12.148 any
access-list 114 permit ip 10.10.12.0 0.0.0.255 any
access-list 114 permit ip 10.10.8.0 0.0.0.255 any

class-map match-any CRITICAL
 match access-group 111

class-map match-any SUB-CRITICAL
 match access-group 112

class-map match-any VOICE
 match access-group 113

class-map match-any OTHER-SERVERS
 match access-group 114

policy-map MARKING
 class CRITICAL
  set ip precedence 7
 class SUB-CRITICAL
  set ip precedence 6
 class VOICE
  set ip precedence 5
 class OTHER-SERVERS
  set ip precedence 4
 class class-default
  set ip precedence 3

policy-map QOS-POLICY
 class class-default
  fair-queue
  random-detect
  random-detect precedence 0 20 40 10
  random-detect precedence 1 22 40 10
  random-detect precedence 2 24 40 10
  random-detect precedence 3 26 40 10
  random-detect precedence 4 28 40 10
  random-detect precedence 5 31 40 10
  random-detect precedence 6 33 40 10
  random-detect precedence 7 35 40 10

int g0/0
service-policy input MARKING

int s0/0
service-policy output QOS-POLICY

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:07 ART