From: nasir.shaikh@bt.com
Date: Tue Mar 24 2009 - 09:42:35 ART
Rich and others,
Thanks for the advices.
I tried a basic test using 3 1841s at it seems to work.
A colleague is trying to copy my actual situation in GNS3 so that we can test.
Will let you know how it works out.
regards
Nasir Shaikh
This email contains information from BT Nederland N.V., which may be privileged or confidential.
It's meant only for the individual(s) or entity named above. If you are not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited.
If you have received this email in error, please let me know immediately on the email address above.
We monitor our systems, and may record your emails.
BT Nederland N.V.
Registered office: Offices Minerva and Mercurius, Herikerbergweg 2, 1101 CM Amsterdam
Registered at the Amsterdam Chamber of Commerce no: 33296214
-----Original Message-----
From: Rich Collins [mailto:nilsi2002@gmail.com]
Sent: 18 March 2009 13:13
To: Shaikh,NM,Nasir,JRS1 R
Cc: service.providersa@gmail.com; comserv@groupstudy.com; ccielab@groupstudy.com
Subject: Re: Redistribution between VRFs
If all vrf interfaces are running eigrp with the spokes then I would suggest doing it this way. You can eliminate any static routes. The eigrp autonomous system number will be the same as the eigrp process number on the spokes (CE routers).
interface Loopback0
ip address 8.8.8.8 255.255.255.255
ip vrf A
rd 10:1
route-target export 10:1
route-target import 10:2
!
ip vrf B
rd 10:2
route-target export 10:2
route-target import 10:1
router eigrp 1
auto-summary
!
address-family ipv4 vrf A
redistribute bgp 11 metric 1 1 1 1 1
network aa1.0.0.0
no auto-summary
autonomous-system 1
exit-address-family
!
router eigrp 2
auto-summary
!
address-family ipv4 vrf B
redistribute bgp 11 metric 1 1 1 1 1
network bb1.0.0.0
network bb2.0.0.0
no auto-summary
autonomous-system 2
exit-address-family
!
router bgp 11
no synchronization
bgp router-id 8.8.8.8
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf B
redistribute eigrp 2 metric 2
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf A
redistribute eigrp 1 metric 2
no auto-summary
no synchronization
exit-address-family
!
On Wed, Mar 18, 2009 at 9:47 AM, <nasir.shaikh@bt.com> wrote:
> Rich,
> Thanks for your response.
> There is no overlap of IP space. Vrf A is using MP-BGP (with IS-IS as
> underlying IGP). The device (6504-E SUP32-10GE-3B) where I am looking
> to do the redist is the boundary between vrf A and vrf B which runs on
> native EIGRP. The static routes are a bit of an issue for me because
> of various interfaces belonging to vrf B. This would lead to
> sub-optimum routing. Can I configure loopbacks in both vrfs and use
> them as next-hops? Would that impact cpu?
>
> My setup is as follows:
> ip vrf A
> rd 10:1
> route-target export 10:1
> route-target import 10:2
> !
> ip vrf B
> rd 10:2
> route-target export 10:2
> route-target import 10:1
> !
>
> interface FastEthernet1/0
> ip vrf forwarding A
> ip address x.x.x.x
> duplex auto
> speed auto
> no clns route-cache
> !
> !
> interface FastEthernet2/0
> ip vrf forwarding B
> ip address x.x.x.x
> duplex auto
> speed auto
> no clns route-cache
> !
> interface FastEthernet3/0
> ip vrf forwarding B
> ip address x.x.x.x
> duplex auto
> speed auto
> no clns route-cache
> !
> interface FastEthernet4/0
> ip vrf forwarding B
> ip address x.x.x.x
> duplex auto
> speed auto
> no clns route-cache
> !
> interface FastEthernet5/0
> ip vrf forwarding B
> ip address x.x.x.x
> duplex auto
> speed auto
> no clns route-cache
> !
>
> router bgp 10
> no synchronization
> bgp log-neighbor-changes
> no auto-summary
> !
> address-family ipv4 vrf A
> redistribute connected
> redistribute static
> no auto-summary
> no synchronization
> exit-address-family
> !
> address-family ipv4 vrf B
> redistribute connected
> redistribute static
> no auto-summary
> no synchronization
> exit-address-family
> !
> !
> Thanks once again
>
>
> Nasir Shaikh
>
> This email contains information from BT Nederland N.V., which may be
> privileged or confidential.
> It's meant only for the individual(s) or entity named above. If you
> are not the intended recipient, note that disclosing, copying,
> distributing or using this information is prohibited.
> If you have received this email in error, please let me know
> immediately on the email address above.
> We monitor our systems, and may record your emails.
>
> BT Nederland N.V.
> Registered office: Offices Minerva and Mercurius, Herikerbergweg 2,
> 1101 CM Amsterdam
> Registered at the Amsterdam Chamber of Commerce no: 33296214
Blogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:06 ART