RE: IPV6 Tunnels...

From: Daniel Kutchin (daniel@kutchin.com)
Date: Sun Mar 08 2009 - 16:22:37 ARST


Was wondering how to demonstrate the diff in packet sizes using ping.

Pinging an IPv6/GRE/IP tunnel used packet lengths of 124:

*Mar 1 01:40:41.202: IP: s=10.10.10.10 (Tunnel12), d=10.20.20.20
(Ethernet0/0.12), len 124, sending, proto=47 <-- GRE
                  ^^^^^^^

Whereas an IPv6/IP tunnel used ping packet sizes of 120:

*Mar 1 02:56:28.296: IP: s=10.10.10.10 (Tunnel12), d=10.20.20.20
(Ethernet0/0.12), len 120, sending, proto=41 <-- IPv6IP
                  ^^^^^^^

I obtained a packet size difference of 4 not 8 ...hmm.. any hint?

Here is the setup:

R1:
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Tunnel12
no ip address
ipv6 address 2001:12:12:12::1/64
tunnel source Loopback0
tunnel destination 10.20.20.20
[tunnel mode gre ip] <- replace later with "tunnel mode ipv6ip"
!

R2:
interface Loopback0
ip address 10.20.20.20 255.255.255.255
!
interface Tunnel12
no ip address
ipv6 address 2001:12:12:12::2/64
tunnel source Loopback0
tunnel destination 10.10.10.10
[tunnel mode gre ip] <- default (therefore won't show)

-
Daniel

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Scott Morris
Sent: Sonntag, 8. Mdrz 2009 14:23
To: 'GAURAV MADAN'; 'Modular'
Cc: 'Cisco certification'
Subject: RE: IPV6 Tunnels...

The pro/con I'd look at is overall packet size.

IPv6IP you have a 40-byte IPv6 header + 20-byte IP header

GRE you have a 40-byte IPv6 header + 8 byte GRE header + 20 byte IP header

Which is smaller?

Scott

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
GAURAV MADAN
Sent: Sunday, March 08, 2009 7:18 AM
To: Modular
Cc: Cisco certification
Subject: Re: IPV6 Tunnels...

No pros / cons as such .. but sometimes language of ques can make us go mad

protocol 47 : GRE
protocol 41 : IPV6IP

I rememebr these 2 numbers always and can be useful in desiging ACLs as well

Gaurav Madan.

On Sun, Mar 8, 2009 at 4:37 AM, Modular <modulartx@gmail.com> wrote:

> So I've learned that if you want to tunnel IPv6 over IPv4, there are two
> easy options you can turn to.
>
> 1. Normal GRE tunnel, using the default tunnel type.
>
> 2. Configuring ipv6ip tunnel type.
>
> What are the pros/cons of using each?
>
> Thanks,
> Mod...
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:04 ART