RE: MPLS send-label

From: Peter Svidler (doubleccie@yahoo.com)
Date: Wed Mar 04 2009 - 15:09:48 ARST


Roman , you are awsome !!..thanks man

--- On Wed, 3/4/09, Roman Rodichev <roman@iementor.com> wrote:

From: Roman Rodichev <roman@iementor.com>
Subject: RE: MPLS send-label
To: "'kevin gannon'" <kevin@gannons.net>
Cc: "'Peter Svidler'" <doubleccie@yahoo.com>, ccielab@groupstudy.com, smorris@internetworkexpert.com
Date: Wednesday, March 4, 2009, 12:05 PM

When forwarding the send-label prefix to an iBGP peer, you need to use
next-hop-self, or otherwise it won't create a new label.

R1-ibgp-R2-ebgp

R1
------------
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Ethernet1/0
 ip address 172.16.0.1 255.255.255.0
!
router ospf 1
 network 10.0.0.1 0.0.0.0 area 0
 network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 10.0.0.2 remote-as 1
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 send-label

R2
-------------------
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface Ethernet1/0
 ip address 172.16.0.2 255.255.255.0
!
interface Ethernet1/1
 ip address 172.16.1.1 255.255.255.0
!
router ospf 1
 network 10.0.0.2 0.0.0.0 area 0
 network 172.16.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 10.0.0.1 remote-as 1
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 next-hop-self <<<< you need
this
 neighbor 10.0.0.1 send-label
 neighbor 172.16.1.2 remote-as 2
 neighbor 172.16.1.2 send-label

R3
---------------------
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
!
interface Ethernet1/0
 ip address 172.16.1.2 255.255.255.0
!
router bgp 2
 network 10.0.0.3 mask 255.255.255.255
 neighbor 172.16.1.1 remote-as 1
 neighbor 172.16.1.1 send-label

R2#show ip bgp labels
   Network Next Hop In label/Out label
   10.0.0.3/32 172.16.1.2 18/imp-null
<<<<
if you don't have next-hop-self, you will see "nolabel" instead
of 18

R1#sh ip bgp labels
   Network Next Hop In label/Out label
   10.0.0.3/32 10.0.0.2 nolabel/18
<<< if
you don't have next-hop-self, you will see "imp-null" instead of
18

If I remove next-hop-self, I see this:

R2#show ip bgp labels
   Network Next Hop In label/Out label
   10.0.0.3/32 172.16.1.2 nolabel/imp-null

R1#show ip bgp labels
   Network Next Hop In label/Out label
   10.0.0.3/32 172.16.1.2 nolabel/imp-null

Even if you advertise 172.16.1.0/24 in IGP, the above output will not
change.

Note, that we are not talking about VPNv4 here at all.

Roman Rodichev
5xCCIE #7927 (R&S, Security, Voice, Storage, Service Provider)
Instructor, Content Developer
ieMentor Corporation http://www.iementor.com
Y!M: roman7927

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
kevin gannon
Sent: Wednesday, March 04, 2009 2:42 AM
To: Roman Rodichev
Cc: Peter Svidler; ccielab@groupstudy.com; smorris@internetworkexpert.com
Subject: Re: MPLS send-label

Roman
Thanks for this however I am still confused. I am only pushing the topic
as it is another way to ensure an end to end label when used with
next-hop-unchanged.

> Yes, if it's the last BGP session in a chain, then you'll need to
> redistribute routes into something. The reason for it is that LFIB will
not
> populate until there's an "IN" label for the prefix created
by the router.
> IOS won't create the IN label until it's either:
>
> 1. Redistributed into some IGP (it doesn't have to be a real IGP in
use, a
> simple "router ospf 1" + "redistribute bgp X subnets"
will do)
> 2. The prefix has to be forwarded on by BGP to another eBGP or iBGP
> send-label peer.
>
> If you do "show ip bgp labels" and you don't see an
"In" label for the
> prefix, the prefix will not appear in the LFIB.
>

I took the previous example and added another router R20 attached it to R19.
Then I peered via iBGP between R19 and R20. This I think meet the second
requirement above. However the same results:

 R19
==============================================
 show ip bgp nei 100.100.100.20 adv
BGP table version is 3, local router ID is 100.100.100.19
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 100.100.100.16/32
                    189.189.189.8 0 17 16 i
*> 100.100.100.19/32
                    0.0.0.0 0 32768 i

show ip bgp 100.100.100.16
BGP routing table entry for 100.100.100.16/32, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
     2
  17 16
    189.189.189.8 from 189.189.189.8 (100.100.100.18)
      Origin IGP, localpref 100, valid, external, best,
      mpls labels in/out nolabel/19

R20
===========================================
show ip bgp 100.100.100.16
BGP routing table entry for 100.100.100.16/32, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  17 16
    189.189.189.8 (metric 2) from 100.100.100.19 (100.100.100.19)
      Origin IGP, metric 0, localpref 100, valid, internal, best,
      mpls labels in/out nolabel/19

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Apr 06 2009 - 06:44:04 ART