Re: Queuing at FastEthernet

From: Pavel Bykov (slidersv@gmail.com)
Date: Sat Jan 24 2009 - 03:29:38 ARST


For the experience, the MQC queues have default sizes, no matter what the
speed/bandwidth/duplex etc, of the interface.
Check out the test on a router with 2xFE and 1x Serial.
1st FE is set to 10/half
2nd FE is set to 100/full
Serial is well... Serial

R4#sh run int fa 0/0
Building configuration...

Current configuration : 124 bytes
!
interface FastEthernet0/0
 bandwidth 100000
 no ip address
 speed 100
 full-duplex
 service-policy output QUEUE-TEST
end

R4#sh run int fa 0/1
Building configuration...

Current configuration : 122 bytes
!
interface FastEthernet0/1
 bandwidth 10000
 no ip address
 speed 10
 half-duplex
 service-policy output QUEUE-TEST
end

R4#sh run int ser 0/0
Building configuration...

Current configuration : 131 bytes
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
 service-policy output QUEUE-TEST
end

Same policy-map is applied:
class-map CLASS1
class-map CLASS2
class-map CLASS3
class-map CLASS4

policy-map QUEUE-TEST
class CLASS1
prio 150
class CLASS2
bandwidth 200
class CLASS3
shape average 300000
class CLASS4
police cir 500000

So all common actions are represented except default and specials.

R4#show policy-map int fa 0/0
 FastEthernet0/0

  Service-policy output: QUEUE-TEST

    Class-map: CLASS1 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 150 (kbps) Burst 3750 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: CLASS2 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Output Queue: Conversation 265
        Bandwidth 200 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: CLASS3 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
           300000/300000 1950 7800 7800 26 975

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

    Class-map: CLASS4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      police:
          cir 500000 bps, bc 15625 bytes
        conformed 0 packets, 0 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 0 bps, exceed 0 bps

    Class-map: class-default (match-any)
      33 packets, 3345 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
R4#show policy-map int fa 0/1
 FastEthernet0/1

  Service-policy output: QUEUE-TEST

    Class-map: CLASS1 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 150 (kbps) Burst 3750 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: CLASS2 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Output Queue: Conversation 265
        Bandwidth 200 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: CLASS3 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
           300000/300000 1950 7800 7800 26 975

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

    Class-map: CLASS4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      police:
          cir 500000 bps, bc 15625 bytes
        conformed 0 packets, 0 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 0 bps, exceed 0 bps

    Class-map: class-default (match-any)
      18 packets, 1899 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
R4#show policy-map int s0/0

 Serial0/0

  Service-policy output: QUEUE-TEST

    Class-map: CLASS1 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 150 (kbps) Burst 3750 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: CLASS2 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Queueing
        Output Queue: Conversation 265
        Bandwidth 200 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: CLASS3 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
           300000/300000 1950 7800 7800 26 975

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

    Class-map: CLASS4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
      police:
          cir 500000 bps, bc 15625 bytes
        conformed 0 packets, 0 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 0 bps, exceed 0 bps

    Class-map: class-default (match-any)
      27 packets, 351 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
R4#

As you can see, all values match.
This can be good or bad, depending on your requirements and traffic types.
I've seen big problems when links are 64K, because then the default queue
size can create queue of over 3 seconds, which lead to insane network
response.
And I've also seen this same queue at 1G interface, which is the other end
of "incorrect"

So always calculate the values that would be appropriate. Base your
calculations on time, i.e. milliseconds and best practices.

On Fri, Jan 23, 2009 at 12:27 AM, Nitro Drops <nitrodrops@hotmail.com>wrote:

> Hi All,
>
> Just want to verify on this.
>
> Say Priority Queuing using MQC is configured on the F0/0 of a router.
>
> My understanding - Output queue calculation for the MQC is based on the
> "configurations B/W value" of the interface & NOT the speed of the
> interface
> is clocked at. Be sure to set the appropriate B/W value when configuring
> MQC
> on an interface.
>
> Since this is a Fastethernet interface. Is it a good practice
>
> - to configure "bandwidth 100000" on F0/1
> - not necessary to lock the speed and duplex
>
>
> Cheers
> Nit
>
> _________________________________________________________________
> It's simple! Sell your car for just $40 at CarPoint.com.au
>
> http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Fsecure%2Dau%2Eimrworldwide%2E
>
> com%2Fcgi%2Dbin%2Fa%2Fci%5F450304%2Fet%5F2%2Fcg%5F801459%2Fpi%5F1004813%2Fai%<http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Fsecure%2Dau%2Eimrworldwide%2Ecom%2Fcgi%2Dbin%2Fa%2Fci%5F450304%2Fet%5F2%2Fcg%5F801459%2Fpi%5F1004813%2Fai%>
> 5F859641&_t=762955845&_r=tig_OCT07&_m=EXT
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>

-- 
Pavel Bykov
----------------
Don't forget to help stopping the braindumps, use of which reduces value of
your certifications. Sign the petition at http://www.stopbraindumps.com/

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sun Mar 01 2009 - 09:43:39 ARST