From: Narbik Kocharians (narbikk@gmail.com)
Date: Mon Jan 12 2009 - 18:17:46 ARST
R1 (AS100) F0/0--------------------------------------F0/0 (AS 200) R2
IP addressing:
R1's F0/0 interface 10.1.1.1 /24
R1's Lo0 1.1.1.1 /8
R2's F0/0 interface 10.1.1.2 /24
R2's Lo0 2.2.2.2 /8
* *
* *
*Task 1*
Configure R1 in AS 100 to establish an EBGP session with R2 in AS 200. R1 &
R2 should advertise their Lo0 in their AS
*On R1*
R1(config)#router bgp 100
R1(config-router)#no auto-summary
R1(config-router)#network 1.0.0.0
R1(config-router)#neighbor 10.1.1.2 remote-as 200
*On R2*
R2(config)#router bgp 200
R2(config-router)#no auto-summary
R2(config-router)#network 2.0.0.0
R2(config-router)#neighbor 10.1.1.1 remote-as 100
*To verify the configuration:*
*On R1*
* *
*R1#Show ip bgp | b Network*
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768
i
*> 2.0.0.0 10.1.1.2 0
0 *200* i
*On R2*
*R2#Show ip bgp | b Network*
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.1.1 0
0 *100* i
*> 2.0.0.0 0.0.0.0 0 32768
i
*Note from R2's perspective prefix 1.0.0.0/8 was originated & advertised by
AS 100, and from R1's perspective, prefix 2.0.0.0/8 was originated and
advertised by AS 200.*
*Task 2*
Configure R1 in AS 111 to establish an EBGP session with R2 in AS 200 such
that the output of the "Show ip bgp" command on these two routers will be
identical to the follows:
*On R1*
* *
*R1#Sh ip bgp*
* *
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768
i
**> 2.0.0.0 10.1.1.2 0
0 100 200 i*
*On R2*
*R2#Show ip bgp*
* *
BGP table version is 5, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Network Next Hop Metric LocPrf Weight Path
**> 1.0.0.0 10.1.1.1 0
0 100 111 i*
*> 2.0.0.0 0.0.0.0 0
32768 i
*On R1*
R1(config)#no router bgp 100
R1(config)#router bgp 111
R1(config-router)#no auto-summary
R1(config-router)#network 1.0.0.0
R1(config-router)#neighbor 10.1.1.2 remote-as 200
R1(config-router)#neighbor 10.1.1.2 local-as 100
*By changing the AS number of R1 to 111, and a "Neighbor 10.1.1.2 local-as
100" R2 will see R1's real AS of 111 originating the route and then AS 100
was the AS that advertised it. Note on R1, it shows that prefix
2.0.0.0/8was originated by AS 200 but the advertising AS to R1 was AS
100. They both
see this invisible AS 100.*
*Task 3*
Configure R1 such that when R2 advertises network 2.0.0.0/8, the output of
the "Show ip bgp" command on R1 is identical to the following:
*On R1*
*R1#Sh ip bgp*
* *
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768
i
*> 2.0.0.0 10.1.1.2 0
0 200 i
* *
*On R1*
R1(config)#router bgp 111
R1(config-router)#neighbor 10.1.1.2 local-as 100 no-prepend
* *
*Note the "no-prepend" option tells the router NOT to prepend AS 100 to the
advertised prefixes. This will ONLY affect R1's BGP table.*
* *
*On R1*
* *
*R1#Show ip bgp*
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768
i
*> 2.0.0.0 10.1.1.2 0
0 200 i
*On R2*
*R2#Show ip bgp*
BGP table version is 7, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.1.1 0
0 100 111 i
*> 2.0.0.0 0.0.0.0 0
32768 i
*Task 4*
Configure R1 such that the output of the "Show ip bgp" command on R2 is
identical to the following:
* *
*On R2*
* *
*R2#Show ip bgp | b Network*
* *
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.1.1 0
0 100 i
*> 2.0.0.0 0.0.0.0 0 32768
i
*On R1*
R1(config)#router bgp 111
R1(config-router)#neighbor 10.1.1.2 local-as 100 no-prepend replace-as
* *
*Note the "replace-as" option instructs the local router NOT to prepend the
real AS number.*
* *
* *
* *
*On R2*
* *
*R2#Show ip bgp | b Network*
* *
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.1.1 0
0 100 i
*> 2.0.0.0 0.0.0.0 0 32768
i
*Task 5*
Configure R1 such that R2 can establish an EBGP peer session with R1 using
AS 111 or 100.
*On R1*
R1(config)#router bgp 111
R1(config-router)#neighbor 10.1.1.2 local-as 100 no-prepend replace-as *
dual-as*
*On R1*
* *
*R1#Show ip bgp*
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768
i
*> 2.0.0.0 10.1.1.2 0
0 200 i
* *
*On R2*
* *
*R2#Show ip bgp*
BGP table version is 13, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
**> 1.0.0.0 10.1.1.1 0
0 100 i*
*> 2.0.0.0 0.0.0.0 0 32768
i
*Note the current configuration of R2 is as follows:*
* *
*On R2*
* *
*R2#Show run | b router bgp 200*
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.0.0.0
neighbor 10.1.1.1 remote-as 100
no auto-summary
*Note its establishing a peer session with R1 using AS 100, the following
verifies that R2 can also establish a peer session with R1 using AS 111:*
*On R2*
R2(config)#router bgp 200
R2(config-router)#no auto-summary
R2(config-router)#netw 2.0.0.0
R2(config-router)#neighbor 10.1.1.1 remote-as 111
*To verify the configuration:*
* *
*On R2*
* *
*R2#Show ip bgp*
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
**> 1.0.0.0 10.1.1.1 0
0 111 i*
*> 2.0.0.0 0.0.0.0 0 32768
i
*Note the ONLY difference here is the AS that originated and advertised
1.0.0.0/8 prefix.*
I hope it helped.
____________
| ^^^^^^^ | / \
| | | Study Hard |
| | | Everybody ! |
| (o)(o) o \ /
@ _) o ~~~~~~~~~~
| ,____| o
| /
/____\
On Mon, Jan 12, 2009 at 8:59 AM, Hobbs <deadheadblues@gmail.com> wrote:
> I wrote a small post about the options here. I didn't cover dual-as but I
> covered the others.
>
> http://ccietobe.blogspot.com/2008/11/bgp-local-as-notes.html
>
> hope it helps...
>
> On Mon, Jan 12, 2009 at 9:36 AM, Lloyd Ardoin <lloyd@thewizkid.biz> wrote:
>
> > Hi Praveen,
> >
> > Narbik has a great lab that really brought this home for me. You might
> ask
> > him to share that with you or you could look on the archives. I believe
> he
> > posted it here a short time back.
> >
> > Lloyd
> >
> > On Jan 12, 2009, at 1:53 AM, Sharma, Praveen wrote:
> >
> > Hi GS,
> >>
> >> Need some help in BGP local-AS parameter?
> >>
> >> I tried it in my lab without any problem but not able to understand the
> >> difference between No-prepend, Replace-as and dual-as parameter.
> >>
> >> Thanks
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> > Lloyd V Ardoin
> > lloyd@thewizkid.biz
> >
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Narbik Kocharians CCSI#30832, CCIE# 12410 (R&S, SP, Security) www.MicronicsTraining.com www.Net-Workbooks.com Sr. Technical InstructorBlogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Sun Mar 01 2009 - 09:43:37 ARST