RE: IPv6 Tunneling - Auto6to4

From: Daniel Kutchin (daniel@kutchin.com)
Date: Sat Jan 03 2009 - 11:01:47 ARST


Nitro Drops ---

If you want to use a single static route...

ipv6 route 2002::/16 Tunnel0

...then implement the 6to4 ipv6 addressing scheme strictly:

R2:
interface Tunnel0
 ipv6 address 2002:9601:202:0000::Y/64
!
interface [Interface-name-and-number]
 ipv6 address 2002:9601:202:XXXX::Y/64 <--- where XXXX ranges from 0001 to
FFFF
!
ipv6 route 2002::/16 Tunnel0

R5:
interface Tunnel0
 ipv6 address 2002:9601:505:0000:Y/64
!
interface [Interface-name-and-number]
 ipv6 address 2002:9601:505:XXXX::Y/64 <--- where XXXX ranges from 0001 to
FFFF
!
ipv6 route 2002::/16 Tunnel0

Any ipv6 addressing outside this norm attracts a static ipv6 route.

---

Daniel

-----Original Message----- From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Nitro Drops Sent: Donnerstag, 1. Januar 2009 13:44 To: ccielab@groupstudy.com Subject: IPv6 Tunneling - Auto6to4

Hi All,

Happy New Year!

Task : R2 E0/0 able to access R5 E0/1 using Tunnel (Auto6to4)

E0/0 R2 Tun0 ------ Tun0 R5 E0/1

R2

interface Tunnel0 ipv6 address 2002:9601:202::2/64 >> translated from Loopback IPv4 150.1.4.4 tunnel source Loopback0 tunnel mode ipv6ip 6to4

interface FastEthernet0/0 ip address 142.1.27.2 255.255.255.0 ipv6 address 2002:8E11:3502:27::/64 eui-64 ipv6 address FE80::2 link-local

ipv6 route 2002:8E11:505:5::/64 2002:9601:505::5 ipv6 route 2002::/16 Tunnel0

ipv6 route 2002:8E11:3502:27::/64 2002:9601:202::2 ipv6 route 2002::/16 Tunnel0

R5 interface Tunnel0 ipv6 address 2002:9601:505::5/64 >> translated from Loopback IPv4 150.1.5.5 tunnel source Loopback0 tunnel mode ipv6ip 6to4

interface Ethernet0/0 ip address 142.1.5.5 255.255.255.0 ipv6 address 2002:8E11:505:5::/64 eui-64 ipv6 address FE80::5 link-local

ipv6 route 2002:8E11:3502:27::/64 2002:9601:202::2 ipv6 route 2002::/16 Tunnel0

Qns : Why is there is a need for double static routes? Wouldnt a single 'ipv6 route 2002::/16 Tunnel0 covers the other static route (longer match)? I tried using only one static route 'ipv6 route 2002::/16 Tunnel0 ', it didnt manage to work.

Cheers Nit



This archive was generated by hypermail 2.1.4 : Sun Mar 01 2009 - 09:43:36 ARST