Re: Narbik's Advance tech WB ..BGP Lab 5, Aggregation.

From: Larry (cc13lab@gmail.com)
Date: Fri Dec 26 2008 - 12:37:56 ARST


You would get 0 points for the section because R1 will use the summary
address when its 3.1.11.0/24 is down.

"R1 should NOT use R2 if it's
network 3.1.11.0/24 network is down."

But why are you asking us?? why not ask Narbik these questions????

-larry

On Fri, Dec 26, 2008 at 7:41 AM, Andy Hogard <andyhogard@gmail.com> wrote:

> Hey all,
>
>
> This is what *the task* *5 of bgp lab 5 wants us to do "*R2 should
> aggergate
> all the networks in 3.1.0.0 address space and advertise a single aggregate
> route that only aggregates the specific routes for subnet under the 3.0.0.0
> network in it's BGP table, ensure that the atomic-aggregate attribute is
> not
> attacher to the aggregate route. This aggregation should be done such that
> the R1 in AS 100 is the only AS that recieves the aggregate route, R3 in AS
> 300 should NOT recieve the aggregate route. R1 should NOT use R2 if it's
> network 3.1.11.0/24 network is down. R3 does not need NLRI to network
> 3.1.11.0/24 advertised by R1.*"*
>
> *Network topolgy,*
>
> R1 -----FR-Cloud----- R2 ------Ethernet ------R3
> 10.1.12.0/24 10.1.23.0/24
>
>
> Hmm, *below is my solution* to achieve this task, *which differs from the
> solution mentioned in the w-book..*
>
> *Config on R1,*
>
> version 12.3
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R1
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> !
> resource policy
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> ip cef
> no ip domain lookup
> no ip dhcp use vrf connected
> !
> !
> no ip ips deny-action ips-interface
> !
> no ftp-server write-enable
> !
> no crypto isakmp ccm
> !
> !
> interface Loopback0
> ip address 3.1.11.1 255.255.255.0
> !
> interface Ethernet0/0
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/1
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/2
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/3
> no ip address
> shutdown
> half-duplex
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/0.12 point-to-point
> ip address 10.1.12.1 255.255.255.0
> frame-relay interface-dlci 102
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> router bgp 100
> no synchronization
> bgp log-neighbor-changes
> network 3.1.11.0 mask 255.255.255.0
> neighbor 10.1.12.2 remote-as 200
> neighbor 10.1.12.2 allowas-in 1
> no auto-summary
> !
> ip http server
> no ip http secure-server
> ip classless
> !
> control-plane
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> logging synchronous
> login
> !
> !
> end
>
> *Config on R2,*
>
> version 12.3
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R2
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> !
> resource policy
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> ip cef
> no ip domain lookup
> no ip dhcp use vrf connected
> !
> !
> no ip ips deny-action ips-interface
> !
> no ftp-server write-enable
> !
> no crypto isakmp ccm
> !
> !
> interface Loopback0
> ip address 2.2.2.2 255.0.0.0
> !
> interface Ethernet0/0
> ip address 10.1.23.2 255.255.255.0
> full-duplex
> !
> interface Ethernet0/1
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/2
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/3
> no ip address
> shutdown
> half-duplex
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/0.21 point-to-point
> ip address 10.1.12.2 255.255.255.0
> frame-relay interface-dlci 201
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> router bgp 200
> no synchronization
> bgp log-neighbor-changes
> network 2.0.0.0
> aggregate-address 3.1.0.0 255.255.240.0 as-set summary-only advertise-map
> IF_NET_3.1.11.0/24
> neighbor 10.1.12.1 remote-as 100
> neighbor 10.1.23.3 remote-as 300
> neighbor 10.1.23.3 unsuppress-map UNSUP_NET3.1.11.0/24
> default-metric 50
> no auto-summary
> !
> ip http server
> no ip http secure-server
> ip classless
> !
> !
> !
> ip prefix-list NET3.1.11.0/24 seq 5 permit 3.1.11.0/24
> !
> route-map IF_NET_3.1.11.0/24 permit 10
> match ip address prefix-list NET3.1.11.0/24
> !
> route-map UNSUP_NET3.1.11.0/24 permit 10
> match ip address prefix-list NET3.1.11.0/24
> !
> !
> !
> control-plane
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> logging synchronous
> login
> !
> !
> end
>
> *Config on R3, *
>
> version 12.3
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname R3
> !
> boot-start-marker
> boot-end-marker
> !
> !
> no aaa new-model
> !
> resource policy
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> ip cef
> no ip domain lookup
> no ip dhcp use vrf connected
> !
> !
> no ip ips deny-action ips-interface
> !
> no ftp-server write-enable
> !
> !
> no crypto isakmp ccm
> !
> !
> interface Loopback0
> ip address 3.1.0.3 255.255.255.0
> !
> interface Loopback1
> ip address 3.1.1.3 255.255.255.0
> !
> interface Loopback2
> ip address 3.1.2.3 255.255.255.0
> !
> interface Loopback3
> ip address 3.1.3.3 255.255.255.0
> !
> interface Loopback4
> ip address 3.1.4.3 255.255.255.0
> !
> interface Loopback5
> ip address 3.1.5.3 255.255.255.0
> !
> interface Loopback6
> ip address 3.1.6.3 255.255.255.0
> !
> interface Loopback7
> ip address 3.1.7.3 255.255.255.0
> !
> interface Loopback8
> ip address 3.1.8.3 255.255.255.0
> !
> interface Loopback9
> ip address 3.1.9.3 255.255.255.0
> !
> interface Loopback10
> ip address 3.1.10.3 255.255.255.0
> !
> interface Loopback12
> ip address 3.1.12.3 255.255.255.0
> !
> interface Loopback13
> ip address 3.1.13.3 255.255.255.0
> !
> interface Loopback14
> ip address 3.1.14.3 255.255.255.0
> !
> interface Loopback15
> ip address 3.1.15.3 255.255.255.0
> !
> interface Ethernet0/0
> ip address 10.1.23.3 255.255.255.0
> full-duplex
> !
> interface Ethernet0/1
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/2
> no ip address
> shutdown
> half-duplex
> !
> interface Ethernet0/3
> no ip address
> shutdown
> half-duplex
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/0.34 point-to-point
> ip address 10.1.34.3 255.255.255.0
> frame-relay interface-dlci 304
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> no dce-terminal-timing-enable
> !
> router bgp 300
> no synchronization
> bgp log-neighbor-changes
> network 3.1.0.0 mask 255.255.255.0
> network 3.1.1.0 mask 255.255.255.0
> network 3.1.2.0 mask 255.255.255.0
> network 3.1.3.0 mask 255.255.255.0
> network 3.1.4.0 mask 255.255.255.0
> network 3.1.5.0 mask 255.255.255.0
> network 3.1.6.0 mask 255.255.255.0
> network 3.1.7.0 mask 255.255.255.0
> network 3.1.8.0 mask 255.255.255.0
> network 3.1.9.0 mask 255.255.255.0
> network 3.1.10.0 mask 255.255.255.0
> network 3.1.12.0 mask 255.255.255.0
> network 3.1.13.0 mask 255.255.255.0
> network 3.1.14.0 mask 255.255.255.0
> network 3.1.15.0 mask 255.255.255.0
> neighbor 10.1.23.2 remote-as 200
> no auto-summary
> !
> ip http server
> no ip http secure-server
> ip classless
> !
> !
> control-plane
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> logging synchronous
> login
> !
> !
> end
>
> *Now while I know my solution is correct, I want some of you experts to
> tell
> me if this was the task on the ccie lab, would I have scored all the points
> or none.
> *
>
> *Regards,
> Andy.*
>
> --
> My Blog URL: http://ccieno.blogspot.com/
>
>
>
> --
> My Blog URL: http://ccieno.blogspot.com/
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Thu Jan 01 2009 - 12:53:10 ARST