From: Andy Hogard (andyhogard@gmail.com)
Date: Wed Dec 17 2008 - 03:42:15 ARST
Yep, all communtities are useless unless you use the send-community keyword
along. That's how they are designed to work. Also remember that community is
a Optional Transitive attribute, but will transit to any neighbor unless
explicity defined to do so.
Just my two cents.
HTH,
Andy.
On Wed, Dec 17, 2008 at 9:43 AM, Peter Chuba <ptchuba@live.com> wrote:
> I had the neighbor send-community on R5. After your replies I configured
> the
> send-community for R1s neighbor statement on R2. This produced the desired
> effect.
>
>
>
> Thanks Jonny and Hobbs
>
>
>
> Final configs
>
> R5
>
> !
>
> interface Loopback0
>
> ip address 155.1.5.5 255.255.255.0
>
> !
>
> interface Serial1/0
>
> ip address 155.1.0.5 255.255.255.0
>
> encapsulation frame-relay
>
> serial restart-delay 0
>
> no dce-terminal-timing-enable
>
> frame-relay map ip 155.1.0.2 502
>
> no frame-relay inverse-arp
>
> frame-relay lmi-type cisco
>
> !
>
> router bgp 1
>
> no synchronization
>
> bgp log-neighbor-changes
>
> network 155.1.5.0 mask 255.255.255.0
>
> neighbor 155.1.0.2 remote-as 2
>
> neighbor 155.1.0.2 send-community
>
> neighbor 155.1.0.2 route-map COMMUNITY out
>
> no auto-summary
>
> !
>
> route-map COMMUNITY permit 10
>
> set community no-export
>
> !
>
>
>
> R2
>
> interface Serial1/0
>
> ip address 155.1.0.2 255.255.255.0
>
> encapsulation frame-relay
>
> serial restart-delay 0
>
> no dce-terminal-timing-enable
>
> frame-relay map ip 155.1.0.5 205
>
> no frame-relay inverse-arp
>
> frame-relay lmi-type cisco
>
> !
>
> interface Serial1/1
>
> ip address 155.1.23.2 255.255.255.0
>
> serial restart-delay 0
>
> no dce-terminal-timing-enable
>
> !
>
> router eigrp 2
>
> redistribute connected metric 1 1 1 1 1
>
> network 155.1.23.0 0.0.0.255
>
> auto-summary
>
> !
>
> router bgp 2
>
> no synchronization
>
> bgp log-neighbor-changes
>
> neighbor 155.1.0.5 remote-as 1
>
> neighbor 155.1.13.1 remote-as 2
>
> neighbor 155.1.13.1 send-community
>
> neighbor 155.1.23.3 remote-as 2
>
> no auto-summary
>
>
>
> R1
>
> interface FastEthernet0/0
>
> ip address 155.1.146.1 255.255.255.0
>
> duplex auto
>
> speed auto
>
> !
>
> interface Serial1/1
>
> ip address 155.1.13.1 255.255.255.0
>
> serial restart-delay 0
>
> no dce-terminal-timing-enable
>
> !
>
> !
>
> router eigrp 2
>
> redistribute connected metric 1 1 1 1 1
>
> network 155.1.13.0 0.0.0.255
>
> auto-summary
>
> !
>
> router bgp 2
>
> no synchronization
>
> bgp log-neighbor-changes
>
> neighbor 155.1.13.3 remote-as 2
>
> neighbor 155.1.23.2 remote-as 2
>
> neighbor 155.1.146.4 remote-as 3
>
> no auto-summary
>
> !
>
>
>
> From: Jonny English [mailto:redkidneybeans@gmail.com]
> Sent: Wednesday, December 17, 2008 4:51 AM
> To: Peter Chuba
> Cc: ccielab@groupstudy.com
> Subject: Re: BGP community no-export confusion
>
>
>
> Do you have the send-community keyword?
>
> Can we see your configs please.
>
> On Wed, Dec 17, 2008 at 4:40 PM, Peter Chuba <ptchuba@live.com> wrote:
>
> Hi experts, I need a little help. I've got this setup
>
>
>
> R4-----R1-----R3-------R2-----R5
>
>
>
> R4 is in AS3, R1,3,2 are in AS2 and R5 in AS1
>
>
>
> On R5 I set the bgp community no-export for all routes advertised to R2. I
> see the attribute on the routes in R2 but yet the routes get advertised to
> R4 in AS3. I checked R1 and it has the routes without the attribute. I
> thought this attribute was still supposed to be on the routes when
> advertised to iBGP neighbors?
>
>
>
> Thanks
>
> Peter
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- My Blog URL: http://ccieno.blogspot.com/Blogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Thu Jan 01 2009 - 12:53:09 ARST