RE: How do I advertise the true subnet mask of loopbacks?

From: Siddant -- (geekv@hotmail.com)
Date: Mon Nov 24 2008 - 21:32:34 ARST


Hey mate

heres what i did and its working fine.

On R4
=====

!
interface Loopback1
 ip address 200.1.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 10.4.4.2 255.255.255.0
 half-duplex
!

!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map OSPFMASK
 network 10.4.4.0 0.0.0.255 area 0
!

!
access-list 1 permit 200.1.1.0 0.0.0.255
!
route-map OSPFMASK permit 10
 match ip address 1
!

R3
==
!
interface Ethernet0/0
 ip address 10.4.4.1 255.255.255.0
 half-duplex
!

!
router ospf 1
 log-adjacency-changes
 network 10.4.4.0 0.0.0.255 area 0
!

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.1.1.0/24 [110/20] via 10.4.4.2, 00:02:21, Ethernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.4.4.0 is directly connected, Ethernet0/0
R3#

Note that I have specified a proper network instead of using " network 0.0.0.0
0.0.0.0"

HTH
Sidd--
Date: Mon, 24 Nov 2008 18:18:02 -0500
From: usaccie@gmail.com
To: geekv@hotmail.com
Subject: Re: How do I advertise the true subnet mask of loopbacks?
CC: ccielab@groupstudy.com

I got 2 and 3 to work. But 1.) redistribute connected (external) is not
working.

======================================= R3 =========================
interface Loopback200
 ip address 200.1.1.1 255.255.255.0
!

interface Serial1/0
 ip address 199.1.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast

 ip ospf priority 0
 serial restart-delay 0

 frame-relay lmi-type ansi

router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map OSPFMASK
 network 0.0.0.0 255.255.255.255 area 0

!
access-list 1 permit 200.1.1.0 0.0.0.255 log
route-map OSPFMASK permit 10
 match ip address 1

==============================================
r1=================================

r1(config-line)#do sho ip route ospf
     33.0.0.0/24 is subnetted, 1 subnets
O IA 33.1.1.0 [110/65] via 199.1.1.3, 00:03:40, Serial1/0

     200.1.1.0/32 is subnetted, 1 subnets
O 200.1.1.1 [110/65] via 199.1.1.2, 00:03:40, Serial1/0

On Mon, Nov 24, 2008 at 5:05 PM, Siddant -- <geekv@hotmail.com> wrote:

Piotr

Issue the command "ip ospf network point-to-point" under the interface config
mode of the loopback

hth
Sidd--

> Date: Mon, 24 Nov 2008 15:34:21 -0500
> From: usaccie@gmail.com

> To: ccielab@groupstudy.com
> Subject: How do I advertise the true subnet mask of loopbacks?
>
> How do I advertise the true subnet mask of loopbacks.

>
> eg. 100.100.100.1/24 vs a host route 100.100.100.1/32
>
>

> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:

> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Dec 01 2008 - 08:18:32 ARST