Re: bgp peering problems

From: Jason Morris (mcnever@gmail.com)
Date: Wed Oct 29 2008 - 18:24:34 ARST


ok... i think i found the problem... it looks like R2 was advertising
136.10.100.2/32 because the interface type was 'point-to-multipoint
nonbroad'. R5 learned 2 routes back to the /32 route, one via the correct
interface and the other through another path. it came up initially because
OSPF hadn't converged yet. once the other route was learned it was trying
to talk to 136.10.100.2 via another interface, which caused it to source
from another address. moral of the day... always peer to a loopback....

how would i have seen this through debugs? i had 'debug ip bgp event' on
but that appreantly doesn't generate a line when you get a INIT from a host
you dont have configured... i can't find a bgp debug command that does that.

any input?

Routing entry for 136.10.100.2/32
  Known via "ospf 1", distance 110, metric 56, type intra area
  Last update from 136.10.25.1 on Serial0/2/0, 00:01:01 ago
  Routing Descriptor Blocks:
    136.10.100.2, from 136.10.2.2, 00:01:01 ago, via Serial0/1/0
      Route metric is 56, traffic share count is 1
  * 136.10.25.1, from 136.10.2.2, 00:01:01 ago, via Serial0/2/0
      Route metric is 56, traffic share count is 1

R5(config-if)#do sho run int s0/1/0
Building configuration...

Current configuration : 443 bytes
!
interface Serial0/1/0
 ip address 136.10.100.5 255.255.255.224
 encapsulation frame-relay
 ip ospf message-digest-key 1 md5 7 141E020E14142F39301766
 ip ospf message-digest-key 2 md5 7 1047191C1D071719183B7C
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 136.10.100.2 502 broadcast
 frame-relay map ip 136.10.100.5 502
 frame-relay map ip 136.10.100.6 502
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
end

On Wed, Oct 29, 2008 at 2:29 PM, Jason Morris <mcnever@gmail.com> wrote:

> ok, i'm working with two routers, we'll call them R2 and R5... they are
> connected through a frame cloud. i noticed they weren't peering, which they
> were earlier. i checked the config's, nothing jumped out at me. so i did a
> clear ip bgp * on both routers... nothing. so then i reload both routers,
> and they peer up! great! no not great, i do a clear ip bgp * on one of them
> again and again, they wont peer. i've done this 2 or 3 times and it appears
> to be consistant. I've included both config's below, any help would be
> greatly appricated.
>
> _________R2
>
>
> Current configuration : 4692 bytes
> !
> version 12.4
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname R2
> !
> boot-start-marker
> boot-end-marker
> !
> enable password 7 110009000F020E1E10
> !
> no aaa new-model
> !
> resource policy
> !
> memory-size iomem 15
> ip subnet-zero
> ip cef
> !
> !
> !
> !
> !
> frame-relay de-list 1 protocol ip list 100
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> username ccie privilege 15 password 7 121015120A1B09163E
> username R5 password 7 130C0717131C01383F
> !
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 136.10.2.2 255.255.255.0
> !
> interface Loopback5
> ip address 2.2.2.2 255.255.255.0
> !
> interface GigabitEthernet0/0
> no ip address
> shutdown
> duplex auto
> speed auto
> media-type rj45
> negotiation auto
> !
> interface GigabitEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
> media-type rj45
> negotiation auto
> !
> interface Serial0/1/0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0/1/0.24 point-to-point
> ip address 136.10.24.2 255.255.255.248
> ip ospf message-digest-key 1 md5 7 151B1B091C3A2E363C0C61
> ip ospf network non-broadcast
> frame-relay interface-dlci 204
> !
> interface Serial0/1/0.256 multipoint
> ip address 136.10.100.2 255.255.255.224
> ip ospf message-digest-key 1 md5 7 121015120A1B09163E1471
> ip ospf message-digest-key 2 md5 7 0706314956191C17032D5D
> ip ospf network point-to-multipoint non-broadcast
> frame-relay de-group 1 205
> frame-relay de-group 1 206
> frame-relay map ip 136.10.100.2 205
> frame-relay map ip 136.10.100.5 205 broadcast
> frame-relay map ip 136.10.100.6 206 broadcast
> !
> interface Serial0/2/0
> ip address 136.10.25.1 255.255.255.252
> encapsulation ppp
> ip ospf message-digest-key 1 md5 7 130C0717131C01383F1B7D
> clock rate 2000000
> no cdp enable
> ppp authentication chap
> ppp chap hostname R2
> ppp chap password 7 110009000F020E1E10
> ppp ipcp address request ignore
> !
> interface FastEthernet1/0
> no switchport
> ip address 136.10.12.2 255.255.255.0
> !
> interface FastEthernet1/1
> !
> interface FastEthernet1/2
> !
> interface FastEthernet1/3
> !
> interface FastEthernet1/4
> !
> interface FastEthernet1/5
> !
> interface FastEthernet1/6
> !
> interface FastEthernet1/7
> !
> interface FastEthernet1/8
> !
> interface FastEthernet1/9
> !
> interface FastEthernet1/10
> !
> interface FastEthernet1/11
> !
> interface FastEthernet1/12
> !
> interface FastEthernet1/13
> !
> interface FastEthernet1/14
> !
> interface FastEthernet1/15
> !
> interface Vlan1
> no ip address
> !
> router ospf 1
> log-adjacency-changes
> no discard-route external
> area 0 authentication message-digest
> summary-address 100.10.0.0 255.255.248.0
> redistribute rip subnets
> network 136.10.2.0 0.0.0.255 area 0
> network 136.10.24.0 0.0.0.255 area 0
> network 136.10.25.0 0.0.0.3 area 0
> network 136.10.100.0 0.0.0.31 area 0
> neighbor 136.10.100.5
> neighbor 136.10.100.6
> neighbor 136.10.24.4
> !
> router rip
> version 2
> redistribute ospf 1 metric 5 match internal external 1 external 2
> nssa-external 1 nssa-external 2
> passive-interface default
> no passive-interface FastEthernet1/0
> network 136.10.0.0
> distance 255
> distance 120 136.10.12.1 0.0.0.0
> no auto-summary
> !
> router bgp 65251
> template peer-session temp
> ebgp-multihop 255
> update-source Loopback0
> exit-peer-session
> !
> no synchronization
> bgp log-neighbor-changes
> bgp confederation identifier 200
> bgp confederation peers 65402
> bgp dampening 30 750 1500 120
> network 2.2.2.0 mask 255.255.255.0 route-map or-code
> neighbor 136.10.12.1 remote-as 100
> neighbor 136.10.24.4 remote-as 65402
> neighbor 136.10.56.10 remote-as 65251
> neighbor 136.10.100.5 remote-as 65251
> no auto-summary
> !
> ip classless
> !
> !
> ip http server
> no ip http secure-server
> !
> !
> ip prefix-list test seq 5 permit 191.10.0.0/16 ge 24
> !
> map-class frame-relay frag270
> access-list 1 permit 101.10.0.0 0.0.1.0
> access-list 55 permit 191.10.0.0 0.0.255.255
> access-list 55 permit 191.10.1.0 0.0.0.255
> access-list 55 permit 191.10.2.0 0.0.0.255
> access-list 55 permit 191.10.3.0 0.0.0.255
> access-list 55 permit 191.10.4.0 0.0.0.255
> access-list 55 permit 191.10.5.0 0.0.0.255
> access-list 100 permit ip any 136.10.70.0 0.0.0.255 fragments
> snmp-server community ipexpert-rw RW
> snmp-server community ipexpert-ro RO
> !
> route-map test permit 10
> match ip address 55
> !
> route-map or-code permit 10
> set origin incomplete
> !
> route-map or-code permit 20
> !
> route-map 191's permit 10
> match ip address prefix-list test
> set dampening 30 750 1500 120
> !
> route-map 191's permit 20
> !
> !
> !
> !
> control-plane
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> login local
> stopbits 1
> line aux 0
> stopbits 1
> line vty 0 4
> exec-timeout 30 0
> password 7 0257340833365C1378
> logging synchronous
> login
> !
> warm-reboot
> scheduler allocate 20000 1000
> !
> end
>
>
> _________ R5
>
> Current configuration : 2443 bytes
> !
> version 12.4
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname R5
> !
> boot-start-marker
> boot-end-marker
> !
> enable password 7 09455E0C011512001F
> !
> no aaa new-model
> !
> resource policy
> !
> memory-size iomem 15
> ip subnet-zero
> !
> !
> ip cef
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> username ccie privilege 15 password 7 020F145E13160A3358
> username R2 password 7 000D03031C4B0E141B
> !
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 136.10.5.5 255.255.255.0
> !
> interface FastEthernet0/0
> ip address 136.10.56.5 255.255.255.240
> ip ospf dead-interval 15
> ip ospf mtu-ignore
> duplex auto
> speed auto
> !
> interface FastEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
> !
> interface Serial0/1/0
> ip address 136.10.100.5 255.255.255.224
> encapsulation frame-relay
> ip ospf message-digest-key 1 md5 7 141E020E14142F39301766
> ip ospf network point-to-multipoint non-broadcast
> frame-relay map ip 136.10.100.2 502 broadcast
> frame-relay map ip 136.10.100.5 502
> frame-relay map ip 136.10.100.6 502
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0/2/0
> ip address 136.10.25.2 255.255.255.252
> encapsulation ppp
> ip ospf message-digest-key 1 md5 7 130C0717131C01383F1B7D
> no cdp enable
> ppp authentication chap
> ppp chap hostname R5
> ppp chap password 7 030D4B0E1E1F245E5A
> ppp ipcp address request ignore
> !
> router ospf 1
> log-adjacency-changes
> auto-cost reference-bandwidth 87
> area 0 authentication message-digest
> area 3 virtual-link 136.10.11.11 authentication message-digest
> area 3 virtual-link 136.10.11.11 message-digest-key 1 md5 7
> 141E020E14142F39301766
> network 136.10.5.0 0.0.0.255 area 0
> network 136.10.25.0 0.0.0.3 area 0
> network 136.10.56.0 0.0.0.255 area 3
> network 136.10.100.0 0.0.0.31 area 0
> neighbor 136.10.100.6
> neighbor 136.10.100.2
> !
> router bgp 65251
> no synchronization
> bgp log-neighbor-changes
> bgp confederation identifier 200
> bgp confederation peers 65402
> neighbor 136.10.56.10 remote-as 65251
> neighbor 136.10.100.2 remote-as 65251
> no auto-summary
> !
> ip classless
> !
> !
> ip http server
> no ip http secure-server
> !
> snmp-server community ipexpert-rw RW
> snmp-server community ipexpert-ro RO
> !
> !
> !
> !
> control-plane
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> login local
> line aux 0
> line vty 0 4
> exec-timeout 30 0
> password 7 040A3B5537111F7C3D
> logging synchronous
> login
> !
> warm-reboot
> scheduler allocate 20000 1000
> !
> end

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sat Nov 01 2008 - 15:35:23 ARST