Q: BGP with the 0/0 - Internet VRF

From: Victor Cappuccio (vcappuccio@gmail.com)
Date: Tue Oct 07 2008 - 18:11:26 ART


Hi GS:

Is there something on BGP that does not permit to redistribute the default
route learned by one routing protocol and propagate that information to
other vrfs?

Why other information learned via that Routing Protocol in one VRF is passed
over other VRFs but not the default route..

Please see the following

Router 2 is talking with R1 EIGRP 100 in VRF 25

ip vrf 25
 rd 25:25
 route-target export 25:25
 route-target import 25:25
 route-target import 172.2.2.2:28
!
ip vrf INTERNET
 rd 172.2.2.2:28
 route-target export 172.2.2.2:28
 route-target import 172.2.2.2:28

Also R2 has a interface connected to internet with R8 in VRF INTERNET

R2(config-vrf)#do show ip vrf inter
Interface IP-Address VRF
Protocol
Se0/0/0.12 10.1.12.2 25
up
Se0/0/0.25 10.1.25.2 25
up
Se0/0/0.28 10.1.28.2 INTERNET
up
Lo28 66.12.12.2 INTERNET up

R2(config-vrf)#do show ip route vrf INTERNET

Routing Table: INTERNET
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.28.8 to network 0.0.0.0

C 204.12.1.0/24 is directly connected, Loopback28
     172.31.0.0/32 is subnetted, 1 subnets
O 172.31.8.8 [110/65] via 10.1.28.8, 00:00:26, Serial0/0/0.28
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 10.1.1.1/32 [110/65] via 10.1.28.8, 00:00:26, Serial0/0/0.28
C 10.1.28.0/24 is directly connected, Serial0/0/0.28
O*E2 0.0.0.0/0 [110/1] via 10.1.28.8, 00:00:27, Serial0/0/0.28

As you can see R2 is running OSPF with R8, now R8 is annoucing a 0/0 to R2
now the question is why R2 is not propagating that Route into other VRFs?

Here you have the routing configuration between the vrfs are as follows:

R2(config-vrf)#do show run | b router eigrp
router eigrp 1
 auto-summary
 !
 address-family ipv4 vrf 25
 redistribute bgp 100 metric 1 1 1 1 1
 network 0.0.0.0
 no auto-summary
 autonomous-system 100
 exit-address-family

R2(config-vrf)#do show run | b router bgp 100
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 bgp redistribute-internal
 neighbor 172.3.3.3 remote-as 100
 neighbor 172.3.3.3 update-source Loopback0
 neighbor 172.3.3.3 next-hop-self
 no auto-summary
 !
 address-family vpnv4
 neighbor 172.3.3.3 activate
 neighbor 172.3.3.3 send-community both
 neighbor 172.3.3.3 next-hop-self
 bgp redistribute-internal
 exit-address-family
 !
 address-family ipv4 vrf INTERNET
 redistribute ospf 2 vrf INTERNET match internal external 1 external 2
 no synchronization
 bgp redistribute-internal
 exit-address-family
 !
 address-family ipv4 vrf 25
 redistribute connected
 redistribute eigrp 100
 no synchronization
 bgp redistribute-internal
 exit-address-family
!
!
ip nat pool MYPOOL 66.12.12.12 66.12.12.12 netmask 255.255.255.0
ip nat inside source route-map TEST pool MYPOOL vrf 25
!

R2(config-vrf)#do show route-map
route-map name, permit, sequence 10
  Match clauses:
    route-type external
  Set clauses:
    extended community SoO:4:4
  Policy routing matches: 0 packets, 0 bytes
route-map TEST, permit, sequence 10
  Match clauses:
    ip address (access-lists): 101
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
R2(config-vrf)#do show ip access-list 101
Extended IP access list 101
    10 permit ip host 172.1.1.1 any (122 matches)

 R2(config-vrf)#do show ip bgp vpnv4 vrf INTERNET
BGP table version is 54, local router ID is 150.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 150.2.2.2:28 (default for vrf INTERNET)
*> 10.1.1.1/32 10.1.28.8 65 32768 ?
*> 10.1.28.0/24 0.0.0.0 0 32768 ?
   Network Next Hop Metric LocPrf Weight Path
*> 172.31.8.8/32 10.1.28.8 65 32768 ?
*> 204.12.1.0 0.0.0.0 0 32768 ?

 BGP Table does not have that route redistributed, but the route exist int
the INTERNET VRF routing table

R2(config-vrf)#do show ip route vrf INTERNET 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "ospf 2", distance 110, metric 1, candidate default path
  Tag 1, type extern 2, forward metric 64
  Redistributing via bgp 100
  Last update from 10.1.28.8 on Serial0/0/0.28, 00:19:20 ago
  Routing Descriptor Blocks:
  * 10.1.28.8, from 172.31.8.8, 00:19:20 ago, via Serial0/0/0.28
      Route metric is 1, traffic share count is 1
      Route tag 1
and I am redistributing that Externals 2 into BGP using the " redistribute
ospf 2 vrf INTERNET match internal external 1 external 2"

MPLS_4#1
[Resuming connection 1 to 1.1.1.1 ... ]

*Oct 7 21:42
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 204.12.1.0/24 [170/2560512256] via 10.1.12.2, 00:00:42, Serial0/0/0.12
     172.31.0.0/32 is subnetted, 1 subnets
D EX 172.31.8.8 [170/2560512256] via 10.1.12.2, 00:00:57, Serial0/0/0.12
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.1.12.0/24 is directly connected, Serial0/0/0.12
D EX 10.1.1.1/32 [170/2560512256] via 10.1.12.2, 00:00:57, Serial0/0/0.12
D 10.1.25.0/24 [90/2681856] via 10.1.12.2, 00:01:19, Serial0/0/0.12
D EX 10.1.28.0/24 [170/2560512256] via 10.1.12.2, 00:00:43,
Serial0/0/0.12
D 10.1.34.0/24 [90/2681856] via 10.1.12.2, 00:01:20, Serial0/0/0.12
D 10.1.36.0/24 [90/2681856] via 10.1.12.2, 00:01:20, Serial0/0/0.12
D 10.1.56.0/24 [90/14336000] via 10.1.12.2, 00:01:20, Serial0/0/0.12
     172.1.0.0/24 is subnetted, 1 subnets
C 172.1.1.0 is directly connected, Loopback0
     172.4.0.0/24 is subnetted, 1 subnets
D EX 172.4.4.0 [170/2809856] via 10.1.12.2, 00:01:21, Serial0/0/0.12
     172.5.0.0/24 is subnetted, 1 subnets
D 172.5.5.0 [90/2809856] via 10.1.12.2, 00:01:21, Serial0/0/0.12
     172.6.0.0/24 is subnetted, 1 subnets
D 172.6.6.0 [90/2809856] via 10.1.12.2, 00:01:21, Serial0/0/0.12
R1#
MPLS_4#1
[Resuming connection 1 to 1.1.1.1 ... ]

Here is the R14s routing table, as you can see there is no 0/0 Route, do I
am missing something?

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 66.12.12.0/24 [170/2560512256] via 10.1.12.2, 00:01:05, Serial0/0/0.12
     172.31.0.0/32 is subnetted, 1 subnets
D EX 172.31.8.8 [170/2560512256] via 10.1.12.2, 00:01:21, Serial0/0/0.12
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.1.12.0/24 is directly connected, Serial0/0/0.12
D EX 10.1.1.1/32 [170/2560512256] via 10.1.12.2, 00:01:21, Serial0/0/0.12
D 10.1.25.0/24 [90/2681856] via 10.1.12.2, 00:01:43, Serial0/0/0.12
D EX 10.1.28.0/24 [170/2560512256] via 10.1.12.2, 00:01:06,
Serial0/0/0.12
D 10.1.34.0/24 [90/2681856] via 10.1.12.2, 00:01:44, Serial0/0/0.12
D 10.1.36.0/24 [90/2681856] via 10.1.12.2, 00:01:44, Serial0/0/0.12
D 10.1.56.0/24 [90/14336000] via 10.1.12.2, 00:01:44, Serial0/0/0.12
     172.1.0.0/24 is subnetted, 1 subnets
C 172.1.1.0 is directly connected, Loopback0
     172.4.0.0/24 is subnetted, 1 subnets
D EX 172.4.4.0 [170/2809856] via 10.1.12.2, 00:01:45, Serial0/0/0.12
     172.5.0.0/24 is subnetted, 1 subnets
D 172.5.5.0 [90/2809856] via 10.1.12.2, 00:01:45, Serial0/0/0.12
     172.6.0.0/24 is subnetted, 1 subnets
D 172.6.6.0 [90/2809856] via 10.1.12.2, 00:01:45, Serial0/0/0.12

R1#ping 172.31.8.8 so lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.31.8.8, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms
R1#

R8#
MPLS_4#1
[Resuming connection 1 to 1.1.1.1 ... ]

R1#ping 172.31.8.8 so lo0 rep 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.31.8.8, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.1
!!!!!!!!
MPLS_4#8
[Resuming connection 8 to 1.1.1.1 ... ]

*Oct 7 21:00P: tableid=0, s=66.12.12.12 (Serial0/0/0.28),
d=172.31.8.8(Loopback0), routed via RIB
*Oct 7 21:00:11.129: IP: s=66.12.12.12 (Serial0/0/0.28), d=172.31.8.8, len
100, rcvd 4
*Oct 7 21:00:11.129: IP: tableid=0, s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), routed via FIB
*Oct 7 21:00:11.129: IP: s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), len 100, sending
*Oct 7 21:00:11.189: IP: tableid=0, s=66.12.12.12 (Serial0/0/0.28), d=
172.31.8.8 (Loopback0), routed via RIB
*Oct 7 21:00:11.189: IP: s=66.12.12.12 (Serial0/0/0.28), d=172.31.8.8, len
100, rcvd 4
*Oct 7 21:00:11.189: IP: tableid=0, s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), routed via FIB
*Oct 7 21:00:11.189: IP: s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), len 100, sending
*Oct 7 21:00:11.249: IP: tableid=0, s=66.12.12.12 (Serial0/0/0.28), d=
172.31.8.8 (Loopback0), routed via RIB
*Oct 7 21:00:11.249: IP: s=66.12.12.12 (Serial0/0/0.28), d=172.31.8.8, len
100, rcvd 4
*Oct 7 21:00:11.249: IP: tableid=0, s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), routed via FIB
*Oct 7 21:00:11.249: IP: s=172.31.8.8 (local),
d=66.12.12.12(Serial0/0/0.28), len 100, sending
*Oct 7 21:00:11.305: IP: tableid=0, s=66.12.12.12 (Serial0/0/0.28), d=
172.31.8.8 (Loopback0), routed via RIB
*Oct 7 21:00:11.305: IP: s=66.12.12.12 (Serial0/0/0.28), d=172.31.8.8, len
100, rcvd 4
MPLS_4#2
[Resuming connection 2 to 1.1.1.1 ... ]

*Oct 7 20:53:11.681: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2964]
*Oct 7 20:53:11.709: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2965]
*Oct 7 20:53:11.737: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2965]
*Oct 7 20:53:11.769: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2966]
*Oct 7 20:53:11.797: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2966]
*Oct 7 20:53:11.829: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2967]
*Oct 7 20:53:11.857: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2967]
*Oct 7 20:53:11.885: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2968]
*Oct 7 20:53:11.917: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2968]
*Oct 7 20:53:11.945: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2969]
*Oct 7 20:53:11.977: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2969]
*Oct 7 20:53:12.005: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2970]
*Oct 7 20:53:12.037: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2970]
*Oct 7 20:53:12.065: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2971]
*Oct 7 20:53:12.093: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2971]
*Oct 7 20:53:12.125: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2972]
*Oct 7 20:53:12.153: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2972]
*Oct 7 20:53:12.185: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2973]
*Oct 7 20:53:12.213: NAT*: s=172.31.8.8, d=66.12.12.12->172.1.1.1 [2973]
*Oct 7 20:53:12.241: NAT*: s=172.1.1.1->66.12.12.12, d=172.31.8.8 [2974]

Thanks a lot for your help in advance
Victor.-

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Sat Nov 01 2008 - 15:35:19 ARST