From: Luan Nguyen (luan@netcraftsmen.net)
Date: Tue Oct 07 2008 - 17:45:44 ART
Stand alone BGP. A very cool trick.
A while back, I needed to redistribute routes between 2 VRF-Lites running
EIGRP, and this worked great.
You can't have 2 VRFs under one EIGRP process, hence redistribution.
Back to your problem, you need to create a loopback interface so that BGP
can use as a router-ID on PE and you are good.
Thanks for all the dynamips stuffs by the way :)
----------------------------------------------------------------------------
-------------------------------------------------------------------------
Luan Nguyen
Chesapeake NetCraftsmen, LLC.
www.NetCraftsmen.net
----------------------------------------------------------------------------
-------------------------------------------------------------------------
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Antonio Soares
Sent: Tuesday, October 07, 2008 4:09 PM
To: 'Cisco certification'; comserv@groupstudy.com
Subject: Route Leaking Between Different VRFs
Hello group,
I found an example of how to configure route leaking between VRF's on just
one router, something i thought it was not possible to achieve:
http://www.cisco.com/en/US/tech/tk436/tk832/technologies_configuration_examp
le09186a0080231a3e.shtml#diffvrfs
The configuration is quite simple:
PE-4
+++++++++++++++
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
route-target import 200:1
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
route-target import 100:1
!
interface Serial1/0
ip vrf forwarding vpn1
ip address 10.1.2.5 255.255.255.252
no ip directed-broadcast
!
interface Serial2/0
ip vrf forwarding vpn2
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
!
router bgp 1
!
address-family ipv4 vrf vpn2
redistribute connected
!
address-family ipv4 vrf vpn1
redistribute connected
!
+++++++++++++++
But it doesn't work for me. You can test this with dynamips:
http://pwp.netcabo.pt/amsoares/dynamips/dynamips.htm#route-leaking-vrfs
Here's what i get in router PE:
+++++++++++++++++++++++++
PE#sh ip bgp vpnv4 all
BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf CE1)
* 1.1.1.1/32 10.10.10.1 0 32768 ?
* 10.10.10.0/24 0.0.0.0 0 32768 ?
Route Distinguisher: 2:2 (default for vrf CE2)
* 2.2.2.2/32 20.20.20.1 0 32768 ?
* 20.20.20.0/24 0.0.0.0 0 32768 ?
PE#
+++++++++++++++++++++++++
For some reason, the router does not mark any route as best. This is a weird
BGP configuration since we don't have any BGP peers. But we can see in the
Cisco document that it seemed to be working:
+++++++++++++++++++++++++
PE-4# show ip bgp vpnv4 all
BGP table version is 13, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid,
> best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?
Route Distinguisher: 200:1 (default for vrf vpn2)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?
+++++++++++++++++++++++++
Thanks.
Regards,
Antonio Soares, CCIE #18473 (R&S)
amsoares@netcabo.pt
Blogs and organic groups at http://www.ccie.net
This archive was generated by hypermail 2.1.4 : Sat Nov 01 2008 - 15:35:19 ARST