Re: Shaping : FE sub-int

From: akyccie (akyccie@gmail.com)
Date: Sun Aug 24 2008 - 03:40:33 ART


Yes, CBWFQ : Not supported on subinterfaces. You need to use parent policy and
child policy when applying to sub-interface.

R1(config)#access-list 10 permit any
R1(config)#class-map C1
R1(config-cmap)#match access-group 10
R1(config-cmap)#exit
R1(config)#
R1(config)#policy-map P1
R1(config-pmap)#class C1
R1(config-pmap-c)#bandwidth 1000
R1(config-pmap-c)#exit
R1(config-pmap)#exit
R1(config)#
R1(config)#int fa0/0.11
R1(config-subif)#service-policy input P1
CBWFQ : Can be enabled as an output feature only
R1(config-subif)#service-policy output P1
CBWFQ : Not supported on subinterfaces
R1(config-subif)#exit

Use parent policy and a child policy when applying to an Ethernet
sub-interface

class-map match-all C1
 match access-group 10
!
!
policy-map P1
 class C1
  bandwidth 1000
policy-map Parent
 class class-default
  shape average 1000000
  service-policy P1
!
interface FastEthernet0/0.11
 encapsulation dot1Q 11
 ip address 11.1.1.1 255.255.255.0
 service-policy output Parent

R1#sh policy-map interface fa0/0.11
 FastEthernet0/0.11

  Service-policy output: Parent

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
          1000000/1000000 6250 25000 25000 25 3125

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

      Service-policy : P1

        Class-map: C1 (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 10
          Queueing
            Output Queue: Conversation 73
            Bandwidth 1000 (kbps)Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any

-aky

----- Original Message -----
From: "Lloyd Ardoin" <Lloyd@TheWizKid.biz>
To: "GAURAV MADAN" <gauravmadan1177@gmail.com>; "Cisco certification"
<ccielab@groupstudy.com>
Sent: Sunday, August 24, 2008 3:35 AM
Subject: RE: Shaping : FE sub-int

> This can be found in the archives but the bottom line is that this will
> take a parent policy and a child policy when applying to an Ethernet
> sub-interface.
>
> Try this link for more detail.
>
> http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a
> 0080114326.shtml
>
> HTH,
>
> Lloyd V Ardoin
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> GAURAV MADAN
> Sent: Friday, August 22, 2008 8:59 AM
> To: Cisco certification
> Subject: Shaping : FE sub-int
>
> hi all
>
> i know this was discusse some time back ..... but asking again for
> clearifications
>
> I am confused regarding the application of serive policies at FE
> sub-interfaces :
>
>
> R2 R3
> |------------------------| |--------------------------------|
> R1
>
> R1 f0/0.1 connects tp R2
> R1 f0/0.2 connects to R3
>
> Simple requirement : Send not more than 1 Mbps to R2 and not more than
> 2 Mbps to R3
>
> policy-map R2
> class class-default
> shape average 1000000
> !
>
> int f0/0.1
> service-pol out R2
> Class Based Weighted Fair Queueing will be applied only to the
> Virtual-Access interfaces associated with an MLP bundle.
>
> How to rectify this error ?
> I already went through :
> http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a
> 0080114326.shtml
>
> But couldnt get much out of it .
> Thnx
> Gaurav Madan
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Sep 01 2008 - 08:15:32 ART