BGP Qos-Policy

From: Thor Kopp (thorkopp@googlemail.com)
Date: Wed Jul 30 2008 - 10:50:19 ART


Hi,

Just playing around with BGP qos policy and I am trying to test that it is
working and can't verify it. R1 (as1) is ebgp peering with R4 (as4) directly
over an ethernet segment. R4 is advertising 3 prefix's
3.1.6.0/3.1.7.0/3.1.8.0 & setting the community on each of these as 4.316,
4.317 & 4.318 respectively. I have configured R1 to set IPP based on the
communities and when I look in the cef table on R1 it shows the correct
precedence but when I turn on precedence accounting on R4 I can't see that
the
R1
interface FastEthernet0/0
 ip address 155.34.146.1 255.255.255.0
 bgp-policy destination ip-prec-map
!
router bgp 1
 no synchronization
 table-map BGP_QOS_POLICY
 network 150.34.1.0 mask 255.255.255.0
 neighbor 155.34.146.4 remote-as 4
 neighbor 155.34.146.4 send-community
 no auto-summary
!
ip bgp-community new-format
ip community-list 1 permit 4:316
ip community-list 2 permit 4:317
ip community-list 3 permit 4:318
!
route-map BGP_QOS_POLICY permit 10
 match community 1
 set ip precedence flash
!
route-map BGP_QOS_POLICY permit 20
 match community 2
 set ip precedence flash-override
!
route-map BGP_QOS_POLICY permit 30
 match community 3
 set ip precedence critical

R4 Config

interface FastEthernet0/1
 ip address 155.34.146.4 255.255.255.0
 ip accounting precedence input
!
router bgp 4
 no synchronization
 network 3.1.6.0 mask 255.255.255.0
 network 3.1.7.0 mask 255.255.255.0
 network 3.1.8.0 mask 255.255.255.0
 neighbor 155.34.146.1 remote-as 1
 neighbor 155.34.146.1 send-community
 neighbor 155.34.146.1 route-map BGP_R1_OUT out
 no auto-summary
!
ip bgp-community new-format
!
ip prefix-list 3-1-6-0 seq 5 permit 3.1.6.0/24
ip prefix-list 3-1-7-0 seq 5 permit 3.1.7.0/24
ip prefix-list 3-1-8-0 seq 5 permit 3.1.8.0/24
!
route-map BGP_R1_OUT permit 10
 match ip address prefix-list 3-1-6-0
 set community 4:316
!
route-map BGP_R1_OUT permit 20
 match ip address prefix-list 3-1-7-0
 set community 4:317
!
route-map BGP_R1_OUT permit 30
 match ip address prefix-list 3-1-8-0
 set community 4:318
!
route-map BGP_R1_OUT permit 90

R1 sees the communites on the routes as below & also sees the correct prec
in the cef table on R1:

Rack34R1(config-route-map)#do show ip bgp 3.1.6.0
BGP routing table entry for 3.1.6.0/24, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  4
    155.34.146.4 from 155.34.146.4 (150.34.4.4)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 4:316

Rack34R1(config-route-map)#do show ip bgp 3.1.7.0
BGP routing table entry for 3.1.7.0/24, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  4
    155.34.146.4 from 155.34.146.4 (150.34.4.4)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 4:317

Rack34R1(config-route-map)#do show ip cef 3.1.6.0
3.1.6.0/24, version 34, epoch 0, cached adjacency 155.34.146.4
0 packets, 0 bytes, Precedence flash (3)
  via 155.34.146.4, 0 dependencies, recursive
    next hop 155.34.146.4, FastEthernet0/0 via 155.34.146.4/32
    valid cached adjacency

Rack34R1(config-route-map)#do show ip cef 3.1.7.0
3.1.7.0/24, version 35, epoch 0, cached adjacency 155.34.146.4
0 packets, 0 bytes, Precedence flash-override (4)
  via 155.34.146.4, 0 dependencies, recursive
    next hop 155.34.146.4, FastEthernet0/0 via 155.34.146.4/32
    valid cached adjacency

When I ping from R1 or a router downstream I just see prec 0 packets from
ICMP received on R4. If I telnet from there to R4 on 3.1.6.3 then i see prec
6 (telnet default). I've disabled qos on the intermediate switches. Any
ideas?

Rack34R4#show int fas0/1 prec
FastEthernet0/1
  Input
    Precedence 0: 15 packets, 1710 bytes
    Precedence 6: 22 packets, 1331 bytes

-- 
Thanks,
Thor

Blogs and organic groups at http://www.ccie.net



This archive was generated by hypermail 2.1.4 : Mon Aug 04 2008 - 06:11:58 ART