3560 Per-Port Per- Vlan QoS

From: Eduardo Rossettini (Eduardo.Rossettini@telecom.co.nz)
Date: Fri Jul 04 2008 - 06:53:58 ART


Hi experts,
 
I was doing a lab about Per-Port Per-Vlan Classification on the 3550 from IEWB and was trying to do the same lab using a 3560. Since I noticed there is no "match vlan" under the class-map configuration, I tried to achieve the solution using the following config.
 
The lab was asking to classify and mark ip packets in a trunk interface, giving precedence 5 for VLAN 201 and precedence 4 for VLAN202.
 
############################################
mls qos
 
access-list 100 permit ip any any
 
class-map match-any IP_TRAFFIC
  match access-group 100
 
class-map match-all VLAN201
  match input-interface Fast0/1
class-map match-all VLAN201_IP
  match access-group 100
 
class-map match-all VLAN202
  match input-interface Fast0/1
class-map match-all VLAN202_IP
  match access-group 100
 
policy-map MARK201A
  class VLAN201
  
policy-map MARK202A
  class VLAN202
 
policy-map MARK201
 class VLAN201_IP
  set precedence 5
  service-policy MARK201A

policy-map MARK202
 class VLAN202_IP
  set precedence 4
  service-policy MARK202A
 
interface Vlan201
 service-policy input MARK201
 
interface Vlan202
 service-policy input MARK202
 
interface FastEthernet0/1
 switchport mode dynamic desirable
 mls qos vlan-based
############################################
 
I can't figure out why it's not working...
 
Thanks
 
Eduardo



This archive was generated by hypermail 2.1.4 : Mon Aug 04 2008 - 06:11:53 ART