From: Usama Pervaiz (chaudri@gmail.com)
Date: Sun Jun 01 2008 - 13:29:19 ART
The reason I asked the question was because I was doing one of IE labs
(lab 1 actually). Even though mutual redistribution was being done on
two routers, no route tags were defined and nothing was being blocked.
This is what I did:
ON R3:
router eigrp 100
redistribute ospf 1 metric 1500 1 255 1 1500 route-map RED-OSPF
network 183.5.123.0 0.0.0.255
no auto-summary
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute eigrp 100 subnets route-map RED-EIGRP
network 150.5.3.3 0.0.0.0 area 0
network 183.5.0.3 0.0.0.0 area 0
route-map RED-EIGRP deny 10
match tag 110
!
route-map RED-EIGRP permit 20
set tag 170
!
route-map RED-OSPF deny 10
match tag 170
!
route-map RED-OSPF permit 20
set tag 110
ON R5:
router eigrp 100
redistribute ospf 1 metric 1500 1 255 1 1500 route-map RED-OSPF
network 183.5.105.0 0.0.0.255
distance eigrp 120 170
no auto-summary
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
redistribute eigrp 100 subnets route-map RED-EIGRP
network 150.5.5.5 0.0.0.0 area 0
network 183.5.0.5 0.0.0.0 area 0
network 183.5.45.5 0.0.0.0 area 45
neighbor 183.5.45.4
route-map RED-EIGRP deny 10
match tag 110
!
route-map RED-EIGRP permit 20
set tag 170
!
route-map RED-OSPF deny 10
match tag 170
!
route-map RED-OSPF permit 20
set tag 110
Is this the proper way of blocking the routes from redistributing into
their original routing domain? Is this a "best practice"? Is this what
is expected in the lab?
Any and all help will be appreciated!
Thanks,
Usama
On Sun, Jun 1, 2008 at 2:19 AM, attia mohamed <ahmattia78@yahoo.com> wrote:
> hi
> i asked that question to a ccie certified person so he told me that there is a differnce between loop prevention and mutual redistibution as redistribution on one router donot make loop but on two routers may make loop .
> so making tag on the same router that mean mutal redistribution making tagging with two routers is loop prevention ( same routing protocol)
>
>
>
> --- On Sat, 5/31/08, John <jgarrison1@austin.rr.com> wrote:
>
>> From: John <jgarrison1@austin.rr.com>
>> Subject: Re: Route redistribution question
>> To: "Usama Pervaiz" <chaudri@gmail.com>, "Cisco certification" <ccielab@groupstudy.com>
>> Date: Saturday, May 31, 2008, 5:35 PM
>> This is a good article on the subject
>>
>> http://blog.internetworkexpert.com/category/ccie-routing-switching/interior-gateway-routing/
>> ----- Original Message -----
>> From: "Usama Pervaiz" <chaudri@gmail.com>
>> To: "Cisco certification"
>> <ccielab@groupstudy.com>
>> Sent: Saturday, May 31, 2008 2:49 PM
>> Subject: Route redistribution question
>>
>>
>> > Hello all,
>> >
>> > I have a quick question on redistribution. I apologize
>> if this has
>> > been asked already.
>> >
>> > I have two routers lets say R1 and R2 both with two
>> interface fa0/0
>> > and fa0/1 (for simplicity). R1 fa0/0 and R2 fa0/0 are
>> both in OSPF and
>> > are in area 0 (there are other routers in the middle)
>> that would make
>> > both R1 and R2 ASBR's. R1 fa0/1 and R2 fa0/1 are
>> both in EIGRP AS 100.
>> > At this point all connectivity is there and everything
>> is well within
>> > the area and AS.
>> >
>> > Now if I do mutual redistribution on both R1 and R2 do
>> I have to tag
>> > the routes and block them on the other router? i.e. I
>> redistributed
>> > EIGRP into OSPF on R2 do I tag these routes with 90
>> (for simplicity)
>> > and on R1 block these routes from re-redistributing
>> into EIGRP on R1?
>> > Will it even redistribute these routes into EIGRP
>> again even if I
>> > don't?
>> >
>> > Any and all help would be appreciated and sorry for
>> being so long winded!
>> >
>> > Thanks,
>> > Usama
>> >
>> >
>> >
>> _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
-- ----------------------------------------------------- You're the only one who can hold your head up high, Shake your fist at the gates saying, "I have come home now!"Fetch me the spirit, the son and the father, Tell them their pillar of faith has ascended.
"It's time now! My time now! Give me my Give me my own wings!"... -------------------------------------------------------
This archive was generated by hypermail 2.1.4 : Tue Jul 01 2008 - 06:23:20 ART