From: Thomas Fowles (tfowles@gmail.com)
Date: Sun Jun 01 2008 - 00:17:22 ART
Let's say you have the following config:
!!!!!!!!
!! R1 !!
!!!!!!!!
router bgp 100
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 10.1.12.2 remote-as 200 !!!-R2
neighbor 10.1.12.2 advertise-map LOOPBACK non-exist-map NON-EXIST
neighbor 10.1.13.3 remote-as 200 !!!-R3
no auto-summary
!
ip prefix-list LOOPBACK seq 5 permit 1.1.1.0/24
!
ip prefix-list NON-EXIST seq 5 permit 10.1.13.0/24
!
route-map LOOPBACK permit 10
match ip address prefix-list LOOPBACK
!
route-map NON-EXIST permit 10
match ip address prefix-list NON-EXIST
!!!!!!!!!
!! END !!
!!!!!!!!!
As long as the link to R3 is up, 1.1.1.0/24 will not be advertised to R2.
If you shut the interface, it will then be advertised to R2. If you then
turn the interface back up, the route will be withdrawn from R2.
Try experimenting with this while running "debug ip bgp updates out" to
watch as R1 evaluates its route advertisements in response to the interface
bouncing (it takes a few seconds ... don't expect an instant response).
HTH
-Tom
CCIE#18762
http://www.linkedin.com/in/thomasfowles
On Sat, May 31, 2008 at 9:02 AM, Peter Grewal <peter@avient.ca> wrote:
> Guys,
>
>
>
> I just need to make a clarification regarding exist and non exist maps.
> Suppose I have two AS, we have router 1 that is in AS 100, and routers 2,3
> in AS 200, with R1 connecting to both routers. AS 100 is advertising a
> network 1.1.1.0/24, which R1 receives and passes onto R2,R3 as an eBGP
> route. Now if I want to only send this router to R3, but in the event R3 is
> not available I send it to R2, can an non-exist map be used
>
>
>
> The reason I ask is that the network is propagated already by AS 100, so if
> I use the non-exist map to only advertise network 1.1.1.0/24, when the
> link
> to R3 is down, will this actually prevent the 1.1.1.0/24 network from
> being
> advertised to R2 when the link between R1 and R3 is up ?
>
>
>
> Thank you.
>
>
>
> Peter.
>
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Tue Jul 01 2008 - 06:23:20 ART