IE Lab7 Task 8.1

From: Matt Bentley (mattdbentley@gmail.com)
Date: Fri May 23 2008 - 22:40:11 ART


Hi GS:

*Having Trouble understanding the reasoning on this one.* *WB and SG are as
follows:*
* The first step in your end-to-end QoS policy is to ensure that all traffic
is
properly categorized. To do so configure all VoIP signaling and payload
traffic coming from VLANs 4 and 5 to be marked with a DSCP value of
CS5 for critical. All non VoIP traffic should be marked with a DSCP value
of CS1 for routine.
 In order to ensure that all other data traffic does not get expedited
service,
configure the voice domain so that packets received on the network edge
are rewritten with the appropriate DSCP value.

*
7 - 53
8. QoS
Task 8.1
R4:
interface Ethernet0/1
service-policy input MARK_VOIP
!
interface Ethernet0/0

!service-policy input SET_DSCP_CS1
ip access-list extended VOIP
permit tcp any any eq 1720
permit udp any any range 16384 32767
!
class-map match-all VOIP
match access-group name VOIP
!
policy-map MARK_VOIP
class VOIP
set dscp cs5
class class-default
set dscp cs1
policy-map SET_DSCP_CS1
class class-default
set dscp cs1
R5:
interface Ethernet0/0
service-policy input MARK_VOIP
!
interface Ethernet0/1
service-policy input SET_DSCP_CS1
!
interface serial1/0.35 point-to-point
service-policy input SET_DSCP_CS1
!
ip access-list extended VOIP
permit tcp any any eq 1720
permit udp any any range 16384 32767
!
class-map match-all VOIP
match access-group name VOIP
!
policy-map MARK_VOIP
class VOIP
set dscp cs5
class class-default
set dscp cs1
policy-map SET_DSCP_CS1
class class-default
set dscp cs1*

My three questions are (1) Why is R5's e0/1 interface considered a network
edge (2) Why is R5's s1/0.35 interface have any service policy applied to it
at all (I don't see any reference to inbound traffic anywhere in the
question), and (3) Does NBAR protocol RTP match both H.323 signaling and UDP
payload ports? Thanks in advance. My proposed config is as follows:

*R4:
class-map VOIP
match access-group name VOIP

ip access-list extended VOIP
permit tcp any any eq 1720
permit udp any any eq range 16384 32767

policy-map VOIP2
class VOIP
set dscp cs5

policy-map EDGE
class class-default
set dscp cs1

int e0/0
service-policy input EDGE

int e0/1
service-policy input VOIP2

R5:

class-map VOIP
match access-group name VOIP

ip access-list extended VOIP
permit tcp any any eq 1720
permit udp any any eq range 16384 32767

policy-map VOIP2
class VOIP
set dscp cs5
class class-default
set dscp cs1

policy-map EDGE
class class-default
set dscp cs1

int e0/0
service-policy input VOIP2



This archive was generated by hypermail 2.1.4 : Mon Jun 02 2008 - 06:59:18 ART