Re: bgp to ospf redistribution question

From: Chris McGuire (cmcguire@firstdigital.com)
Date: Wed Apr 23 2008 - 13:11:29 ART


Lastly, I tried the following:

ip route 222.222.222.0 255.255.255.0 Null0
ip route 222.222.223.0 255.255.255.0 Null0
ip route 222.222.224.0 255.255.255.0 204.12.1.254
!
Router ospf 1
redistribute static subnets route-map STATIC-OSPF
!
route-map STATIC-OSPF permit 10
 match ip address 1
!
access-list 1 permit 222.222.224.0

On the OSPF router:

Rack1R5#show ip route | i 222
O E2 222.222.224.0/24 [110/20] via 164.1.45.4, 00:03:43, Serial1/1:0

Now I only see the 222.222.224.0/24 route. So it basically broke the
implicit redistribution of "connected static" routes...

Fix:

route-map STATIC-OSPF permit 10
 match ip address 1
!
route-map STATIC-OSPF permit 20
 match interface Null0
!

Back to OSPF Only router:

Rack1R5#show ip route | i 222.222.22
O E2 222.222.222.0/24 [110/20] via 164.1.45.4, 00:03:47, Serial1/1:0
O E2 222.222.223.0/24 [110/20] via 164.1.45.4, 00:03:47, Serial1/1:0
O E2 222.222.224.0/24 [110/20] via 164.1.45.4, 00:05:22, Serial1/1:0

This fixes the implicit connected route redistribution. This is not the fix,
just shows that BGP routes are not redistributed into another protocol if
they are not at least connected or "static connected".

Thanks,
Chris

> After labbing it up, I have come up with this:
>
> ip route 100.100.100.0 255.255.255.0 null 0
> ip route 101.101.101.0 255.255.255.0 10.10.10.1
>
> Both are static routes.
>
> They are both added to the bgp table with the network statement.
>
> However, the first route is a "connected static" route and can be considered
> connected.
>
> The 2nd route is not connected so it is just static.
>
> When redistributing BGP into OSPF it will grab all BGP routes (show ip orute
> bgp) and all "Connected BGP" routes.
>
> I am assuming that the first route is considered a "connected bgp" route and
> the 2nd is not. Therefore only the 1st route is eligible to be redistributed
> from BGP to OSPF. The only way to get the other route in ospf is by
> redsistributing it from static to ospf.
>
> Any input greatly appreciated..
>
> Chris
>
> On 4/23/08 9:09 AM, "Huan Pham" <huan.pham@valuenet.com.au> wrote:
>
>> Hi Chris,
>>
>> BTW, I do not think that router checks if the next hop (for static route)
>> reachable or not before the static route is installed in the routing table,
>> unless you configure object tracking! I believe you meant the next hop is
>> not on directly connected subnet.
>>
>> Cheers,
>>
>> Huan
>>
>> -----Original Message-----
>> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
>> Chris McGuire
>> Sent: Thursday, 24 April 2008 12:22 AM
>> To: Andy Cole; Noor.Yousuf@shell.com; ccielab@groupstudy.com
>> Subject: Re: bgp to ospf redistribution question
>>
>> Also, does the other route show up in the route table doing the
>> redistribution?
>>
>> Show ip route static?
>>
>> If the next hop address is not reachable, it will not show up in the route
>> table as a static and will therefore not be a candidate for the network
>> statement under BGP.
>>
>> Thanks
>> Chris
>>
>>
>> On 4/23/08 8:11 AM, "Andy Cole" <Andy.Cole@foremostfarms.com> wrote:
>>
>>> gp redistribute-
>>
>> Chris S. McGuire
>> Network Engineer
>> Phone: 801-456-1028
>> Fax: 801-456-1010
>> Email: cmcguire@firstdigital.com
>>
>>
>> Pass the CCIE in six weeks, Guaranteed!
>> http://www.certscience.com/CCIE
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Pass the CCIE in six weeks, Guaranteed!
>> http://www.certscience.com/CCIE
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>
> Chris S. McGuire
> Network Engineer
> Phone: 801-456-1028
> Fax: 801-456-1010
> Email: cmcguire@firstdigital.com
>
>
> Pass the CCIE in six weeks, Guaranteed!
> http://www.certscience.com/CCIE
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>

Chris S. McGuire
Network Engineer
Phone: 801-456-1028
Fax: 801-456-1010
Email: cmcguire@firstdigital.com

Pass the CCIE in six weeks, Guaranteed!
http://www.certscience.com/CCIE



This archive was generated by hypermail 2.1.4 : Thu May 01 2008 - 08:25:51 ART