From: Colm O'Leary (co.oleary@gmail.com) ((co.oleary@gmail.com))
Date: Thu Mar 27 2008 - 14:15:18 ART
Hi Group,
I am having a design problem that I am hoping someone has stumbled across
in a previous life. I have two headend routers configured as access servers
for branch sites. The branch sites have a ADSL into MPLS as their primary
path and isdn bra as their secondary path. The secondary path is only ever
used if the primary is unavailable for all traffic.
At the headend my telco is load balancing the isdn call in a 50:50 ratio
across both headend routers. The routing at the headend uses a static route
for the remote LAN which points to the ip address of the dialer interface of
the branch router. A problem arises when the branch site dials in in a
failover scenario. The first packet sent from the branch hits the back
office server which immediately replies, when the packet arrives back to the
the headend router, the router is unable to route the packet because the
route to its destination is referencing the remote branch dialers ip address
which does not appear in the routing table as a directly connected network.
For the second a thirds packets all works ok as the ppp host route is now in
the routing table.
An application running at the branch has brought around this requirement.
The application session times out if the first packet sent is not
acknowledged. The application is udp based. Is there any way that I can
speed up the injection of the host route into the routing table?
Thanks
Colm
CCIE#17471
[SERVER]
_______________________________
[HEADEND 1] [HEADEND 2]
. .
. .
. .
[ISDN]
.
.
.
.
[BRANCH]
*BRANCH CONFIG*
!
ip cef
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
no ip mroute-cache
shutdown
dialer pool-member 1
isdn switch-type basic-net3
isdn point-to-point-setup
isdn static-tei 0
no cdp enable
ppp authentication chap
!
interface Vlan501
description L3 Connection to Integrated 8 Port Switch
ip address 10.80.0.1 255.255.255.0
ip access-group 100 in
no autostate
!
interface Dialer1
bandwidth 64
ip address 10.84.0.1 255.255.255.254
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer string removed
dialer hold-queue 100
dialer-group 1
no cdp enable
ppp authentication chap
ppp chap hostname removed
ppp chap password removed
!
!
ip route 0.0.0.0 0.0.0.0 Dialer1 250
!
!
dialer-list 1 protocol ip list 100
*HEADEND CONFIG*
controller E1 7/0
framing NO-CRC4
pri-group timeslots 1-31
!
interface Serial7/0:15
no ip address
encapsulation ppp
ip mroute-cache
dialer rotary-group 2
dialer-group 2
isdn switch-type primary-net5
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface Dialer2
ip address 10.110.2.1 255.255.255.0
encapsulation ppp
dialer in-band
dialer idle-timeout 4
dialer fast-idle 5
dialer-group 2
no peer default ip address
no fair-queue
no cdp enable
ppp authentication pap chap callin radius-auth-ppp
!
interface BVI1
ip address 10.67.35.1 255.255.255.0
!
ip route 10.80.0.0 255.255.255.0 10.84.0.1
!
dialer-list 2 protocol ip permit
This archive was generated by hypermail 2.1.4 : Tue Apr 01 2008 - 07:53:54 ART