From: Sean Gavitt (seangavitt@hotmail.com)
Date: Mon Mar 24 2008 - 17:27:42 ART
Do offset list on upstream router (R1):
router eigrp 1
offset-list 1 out 2147483647
access-list 1 permit 0.0.0.0 0.0.0.0
This will make that route unreachable on R2
--------------------------------------------------
From: "Victor Cappuccio" <vcappuccio@gmail.com>
Sent: Monday, March 24, 2008 3:59 PM
To: "Ina&Laurean" <ina.laurean@gmail.com>
Cc: "Ed Lui" <edwlui@gmail.com>; "Timothy Chin" <Tim@1c-solutions.com>;
"Cisco certification" <ccielab@groupstudy.com>
Subject: Re: distance command EIGRP
> Because the route is external "D*EX 0.0.0.0/0 [170/2565120] via
> 192.168.254.1, 00:00:45, Vlan1"
> http://www.groupstudy.com/archives/ccielab/200307/msg01356.html
>
>
>
> On Mon, Mar 24, 2008 at 8:35 PM, Ina&Laurean <ina.laurean@gmail.com>
> wrote:
>
>> Hi Guys,
>>
>>
>> the command distance eigrp 90 255 would actually filter all EIGRP
>> external
>> routes which will break the full connectivity.
>>
>> The task solution is using the "distance 255 192.168.254.1 0.0.0.0 1"
>> command but in my test lab doesn't work so I though I am missing
>> something.
>>
>>
>>
>> Thanks,
>>
>> Laurean
>>
>>
>>
>>
>>
>>
>> On Mon, Mar 24, 2008 at 3:03 PM, Victor Cappuccio <vcappuccio@gmail.com>
>> wrote:
>>
>> > That works for candidate routes in the routing table, subnets flagged
>> > as a candidate default route on the hub router by virtue of the "ip
>> > default-network" command.
>> >
>> > R1(config-router)#do show ip route
>> > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> > E1 - OSPF external type 1, E2 - OSPF external type 2
>> > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> > level-2
>> > ia - IS-IS inter area, * - candidate default, U - per-user
>> > static
>> > route
>> > o - ODR, P - periodic downloaded static route
>> >
>> > Gateway of last resort is not set
>> >
>> > 1.0.0.0/24 is subnetted, 1 subnets
>> > C 1.1.13.0 is directly connected, Serial1/1
>> > S 172.16.0.0/16 is directly connected, Null0
>> > C* 192.168.1.0/24 is directly connected, Loopback0
>> >
>> > R3(config-router)#
>> > *Mar 24 20:01:34.091: RT: default path is now 192.168.1.0 via 1.1.13.1
>> > *Mar 24 20:01:34.091: RT: new default network 192.168.1.0
>> > *Mar 24 20:01:34.091: RT: NET-RED 192.168.1.0/24
>> > do show ip route #
>> > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> > E1 - OSPF external type 1, E2 - OSPF external type 2
>> > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> > level-2
>> > ia - IS-IS inter area, * - candidate default, U - per-user
>> > static
>> > route
>> > o - ODR, P - periodic downloaded static route
>> >
>> > Gateway of last resort is 1.1.13.1 to network 192.168.1.0
>> >
>> > 1.0.0.0/24 is subnetted, 1 subnets
>> > C 1.1.13.0 is directly connected, Serial1/2
>> > D* 192.168.1.0/24 [90/2297856] via 1.1.13.1, 00:00:13, Serial1/2
>> > R3(config-router)#
>> > R3(config-router)#router eigrp 100
>> > R3(config-router)#no default-inf in
>> > R3(config-router)#do clear ip eigrp neigh
>> > R3(config-router)#
>> > *Mar 24 20:02:05.595: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor
>> > 1.1.13.1 (Ser
>> > ial1/2) is down: manually cleared
>> > R3(config-router)#
>> > *Mar 24 20:02:05.599: RT: delete route to 192.168.1.0 via 1.1.13.1,
>> > eigrp metric
>> > [90/2297856]
>> > *Mar 24 20:02:05.599: RT: SET_LAST_RDB for 192.168.1.0/24
>> > OLD rdb: via 1.1.13.1, Serial1/2
>> >
>> > *Mar 24 20:02:05.603: RT: no routes to 192.168.1.0
>> > *Mar 24 20:02:05.603: RT: NET-RED 192.168.1.0/24
>> > *Mar 24 20:02:05.603: RT: NET-RED 192.168.1.0/24
>> > *Mar 24 20:02:05.607: RT: delete network route to 192.168.1.0
>> > *Mar 24 20:02:05.607: RT: NET-RED 192.168.1.0/24
>> > R3(config-router)#
>> > *Mar 24 20:02:07.807: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor
>> > 1.1.13.1 (Ser
>> > ial1/2) is up: new adjacency
>> > R3(config-router)#do
>> > *Mar 24 20:02:08.047: RT: SET_LAST_RDB for 192.168.1.0/24
>> > NEW rdb: via 1.1.13.1
>> >
>> > *Mar 24 20:02:08.047: RT: add 192.168.1.0/24 via 1.1.13.1, eigrp metric
>> > [90/2297
>> > 856]
>> > *Mar 24 20:02:08.051: RT: NET-RED 192.168.1.0/24
>> > R3(config-router)#do show ip route
>> > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> > E1 - OSPF external type 1, E2 - OSPF external type 2
>> > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> > level-2
>> > ia - IS-IS inter area, * - candidate default, U - per-user
>> > static
>> > route
>> > o - ODR, P - periodic downloaded static route
>> >
>> > Gateway of last resort is not set
>> >
>> > 1.0.0.0/24 is subnetted, 1 subnets
>> > C 1.1.13.0 is directly connected, Serial1/2
>> > D 192.168.1.0/24 [90/2297856] via 1.1.13.1, 00:00:04, Serial1/2
>> > R3(config-router)#
>> >
>> > Try distance 90 255
>> > like TIm Said
>> >
>> > Thanks
>> > Victor.-
>> >
>> >
>> > On Mon, Mar 24, 2008 at 7:43 PM, Ed Lui <edwlui@gmail.com> wrote:
>> >
>> > > Try........
>> > >
>> > > Under router eigrp xxx
>> > > no default-information in
>> > >
>> > >
>> > > On Mon, Mar 24, 2008 at 11:27 AM, Timothy Chin <Tim@1c-solutions.com>
>> > > wrote:
>> > > > Try
>> > > >
>> > > > distance eigrp 90 255
>> > > >
>> > > >
>> > > >
>> > > >
>> > > >
>> > > > -----Original Message-----
>> > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
>> > > Behalf Of
>> > > > Ina&Laurean
>> > > > Sent: Monday, March 24, 2008 2:20 PM
>> > > > To: Victor Cappuccio
>> > > > Cc: Cisco certification
>> > > > Subject: Re: distance command EIGRP
>> > > >
>> > > > Hi Victor,
>> > > > Yes a do have a default route on R1 this is the way that I
>> > > > injected
>> > > the
>> > > > default route into the EIGRP domain.
>> > > > This route is actualy injected there as by DHCP client running on
>> > > one of
>> > > > the
>> > > > R1 interfaces.
>> > > > But just to make things clear where I want to filter the route is
>> > > on R2.
>> > > >
>> > > > On more note I am not allowed to use the distribute-list command.
>> > > >
>> > > > As an alternate solution I tried to use
>> > > > default-information allowed in under the router eigrp, but I
>> > > couldn't
>> > > > make
>> > > > this one work either.
>> > > >
>> > > > As per description on the command references it should work but I
>> > > wasn't
>> > > > able to filter the default route this way.
>> > > >
>> > > >
>> > > > Thanks,
>> > > > Laurean
>> > > >
>> > > >
>> > > >
>> > > >
>> > > >
>> > > > On Mon, Mar 24, 2008 at 1:55 PM, Victor Cappuccio <
>> > > vcappuccio@gmail.com>
>> > > > wrote:
>> > > >
>> > > > > Ina&Laurean,
>> > > > >
>> > > > > can you show us the output of the show run | in ip route
>> > > > > It seems to me that you have something like "ip route 0.0.0.0
>> > > 0.0.0.0
>> > > > > 10.1.9.254 254" in your R1 configuration
>> > > > >
>> > > > > Can you please check this out
>> > > > >
>> > > > > Thanks,
>> > > > > Victor Cappuccio
>> > > > > www.vcappuccio.wordpress.com
>> > > > >
>> > > > > ---------
>> > > > >
>> > > > > R1(config-router)#do show ip route 0.0.0.0
>> > > > > Routing entry for 0.0.0.0/0, supernet
>> > > > > Known via "eigrp 100", distance 170, metric 2169856, candidate
>> > > > default
>> > > > > path, type external
>> > > > > Redistributing via eigrp 100
>> > > > > Last update from 1.1.13.3 on Serial1/1, 00:00:04 ago
>> > > > > Routing Descriptor Blocks:
>> > > > > * 1.1.13.3, from 1.1.13.3, 00:00:04 ago, via Serial1/1
>> > > > > Route metric is 2169856, traffic share count is 1
>> > > > > Total delay is 20000 microseconds, minimum bandwidth is
>> > > 1544
>> > > > Kbit
>> > > > > Reliability 255/255, minimum MTU 1500 bytes
>> > > > > Loading 1/255, Hops 1
>> > > > >
>> > > > > R1(config-router)#do show ip route eigrp
>> > > > > 3.0.0.0/32 is subnetted, 1 subnets
>> > > > > D 3.3.3.3 [90/2297856] via 1.1.13.3, 00:00:04, Serial1/1
>> > > > > D*EX 0.0.0.0/0 [170/2169856] via 1.1.13.3, 00:01:28, Serial1/1
>> > > > >
>> > > > >
>> > > > > R1(config-router)#do show ip route eigrp
>> > > > > 3.0.0.0/32 is subnetted, 1 subnets
>> > > > > D 3.3.3.3 [90/2297856] via 1.1.13.3, 00:00:04, Serial1/1
>> > > > > D*EX 0.0.0.0/0 [170/2169856] via 1.1.13.3, 00:01:28, Serial1/1
>> > > > > R1(config-router)#exit
>> > > > > R1(config)#ip prefix-list X deny 0.0.0.0/0
>> > > > > R1(config)#ip prefix-list X permit 0.0.0.0/0 le 32
>> > > > > R1(config)#router eigrp 100
>> > > > > R1(config-router)#distribute-list prefix X in S1/1
>> > > > > R1(config-router)#do clear ip eigrp neigh
>> > > > > R1(config-router)#
>> > > > > *Mar 24 18:52:59.555: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100:
>> > > Neighbor
>> > > > > 1.1.13.3 (Ser
>> > > > > ial1/1) is down: manually cleared
>> > > > > R1(config-router)#
>> > > > > *Mar 24 18:53:00.587: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100:
>> > > Neighbor
>> > > > > 1.1.13.3 (Ser
>> > > > > ial1/1) is up: new adjacency
>> > > > > R1(config-router)#do show ip route
>> > > > > *Mar 24 18:53:02.271: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100:
>> > > Neighbor
>> > > > > 1.1.13.3 (Ser
>> > > > > ial1/1) is resync: route configuration changed
>> > > > > R1(config-router)#do show ip route eigrp
>> > > > > 3.0.0.0/32 is subnetted, 1 subnets
>> > > > > D 3.3.3.3 [90/2297856] via 1.1.13.3, 00:00:04, Serial1/1
>> > > > > R1(config-router)#
>> > > > >
>> > > > >
>> > > > >
>> > > > > On Mon, Mar 24, 2008 at 6:25 PM, Ina&Laurean <
>> > > ina.laurean@gmail.com>
>> > > > > wrote:
>> > > > >
>> > > > > > Hi Group,
>> > > > > >
>> > > > > > I am working on a lab and one of the requirements is to filter
>> > > a
>> > > > default
>> > > > > > route coming from a specific EIGRP neighbor, I tried different
>> > > > solutions
>> > > > > > but
>> > > > > > none of them work seem to work, the solution is using the
>> > > distance
>> > > > > > command
>> > > > > > with neighbor EIGRP address and an access list.
>> > > > > >
>> > > > > > I've created a Lab with just two routers to test this and as
>> > > you can
>> > > > see
>> > > > > > the
>> > > > > > default route is still into the routing table even though
>> > > > under
>> > > the
>> > > > ip
>> > > > > > protocols shows that the distance is 255.
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > Thanks,
>> > > > > >
>> > > > > > Laurean
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > Bellow my configurations:
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R1-LAB#sh run | s eigrp
>> > > > > >
>> > > > > > router eigrp 236
>> > > > > >
>> > > > > > redistribute static metric 1000 10 255 1 1500
>> > > > > >
>> > > > > > network 192.168.253.0
>> > > > > >
>> > > > > > network 192.168.254.0
>> > > > > >
>> > > > > > no auto-summary
>> > > > > >
>> > > > > > deny eigrp any any
>> > > > > >
>> > > > > > R1-LAB#
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R1-LAB#sh ip route
>> > > > > >
>> > > > > > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> > > > > >
>> > > > > > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
>> > > > inter
>> > > area
>> > > > > >
>> > > > > > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
>> > > type 2
>> > > > > >
>> > > > > > E1 - OSPF external type 1, E2 - OSPF external type 2
>> > > > > >
>> > > > > > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 -
>> > > IS-IS
>> > > > > > level-2
>> > > > > >
>> > > > > > ia - IS-IS inter area, * - candidate default, U -
>> > > per-user
>> > > > static
>> > > > > > route
>> > > > > >
>> > > > > > o - ODR, P - periodic downloaded static route
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > Gateway of last resort is 10.1.9.254 to network 0.0.0.0
>> > > > > >
>> > > > > > 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
>> > > > > >
>> > > > > > C 10.1.9.0/24 is directly connected, GigabitEthernet0/0
>> > > > > >
>> > > > > > S 10.1.6.5/32 [254/0] via 10.1.9.254, GigabitEthernet0/0
>> > > > > >
>> > > > > > C 192.168.254.0/24 is directly connected, Vlan1
>> > > > > >
>> > > > > > C 192.168.253.0/24 is directly connected, Loopback0
>> > > > > >
>> > > > > > D 192.168.252.0/24 [90/156160] via 192.168.254.2, 00:11:18,
>> > > Vlan1
>> > > > > >
>> > > > > > S* 0.0.0.0/0 [254/0] via 10.1.9.254
>> > > > > >
>> > > > > > R1-LAB#
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R2-LAB#sh run | s eigrp
>> > > > > >
>> > > > > > router eigrp 236
>> > > > > >
>> > > > > > network 192.168.252.0
>> > > > > >
>> > > > > > network 192.168.254.0
>> > > > > >
>> > > > > > distance 255 192.168.254.1 0.0.0.0 1
>> > > > > >
>> > > > > > no auto-summary
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R2-LAB#sh run | s access-
>> > > > > >
>> > > > > > access-list 1 permit 0.0.0.0
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R2-LAB#sh ip route
>> > > > > >
>> > > > > > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> > > > > >
>> > > > > > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
>> > > > inter
>> > > area
>> > > > > >
>> > > > > > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
>> > > type 2
>> > > > > >
>> > > > > > E1 - OSPF external type 1, E2 - OSPF external type 2
>> > > > > >
>> > > > > > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 -
>> > > IS-IS
>> > > > > > level-2
>> > > > > >
>> > > > > > ia - IS-IS inter area, * - candidate default, U -
>> > > per-user
>> > > > static
>> > > > > > route
>> > > > > >
>> > > > > > o - ODR, P - periodic downloaded static route
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > Gateway of last resort is 192.168.254.1 to network 0.0.0.0
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > 10.0.0.0/32 is subnetted, 1 subnets
>> > > > > >
>> > > > > > D EX 10.1.6.5 [170/2565120] via 192.168.254.1, 00:00:45,
>> > > Vlan1
>> > > > > >
>> > > > > > C 192.168.254.0/24 is directly connected, Vlan1
>> > > > > >
>> > > > > > D 192.168.253.0/24 [90/156160] via 192.168.254.1, 00:00:45,
>> > > Vlan1
>> > > > > >
>> > > > > > C 192.168.252.0/24 is directly connected, Loopback0
>> > > > > >
>> > > > > > D*EX 0.0.0.0/0 [170/2565120] via 192.168.254.1, 00:00:45,
>> > > > Vlan1
>> > > > > >
>> > > > > > R2-LAB#
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R2-LAB#sh ip protocols
>> > > > > >
>> > > > > > Routing Protocol is "eigrp 236"
>> > > > > >
>> > > > > > Outgoing update filter list for all interfaces is not set
>> > > > > >
>> > > > > > Incoming update filter list for all interfaces is not set
>> > > > > >
>> > > > > > Default networks flagged in outgoing updates
>> > > > > >
>> > > > > > Default networks accepted from incoming updates
>> > > > > >
>> > > > > > EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
>> > > > > >
>> > > > > > EIGRP maximum hopcount 100
>> > > > > >
>> > > > > > EIGRP maximum metric variance 1
>> > > > > >
>> > > > > > Redistributing: eigrp 236
>> > > > > >
>> > > > > > EIGRP NSF-aware route hold timer is 240s
>> > > > > >
>> > > > > > Automatic network summarization is not in effect
>> > > > > >
>> > > > > > Maximum path: 4
>> > > > > >
>> > > > > > Routing for Networks:
>> > > > > >
>> > > > > > 192.168.252.0
>> > > > > >
>> > > > > > 192.168.254.0
>> > > > > >
>> > > > > > Routing Information Sources:
>> > > > > >
>> > > > > > Gateway Distance Last Update
>> > > > > >
>> > > > > > 192.168.254.1 255 00:01:03
>> > > > > >
>> > > > > > Distance: internal 90 external 170
>> > > > > >
>> > > > > > Address Wild mask Distance List
>> > > > > >
>> > > > > > 192.168.254.1 0.0.0.0 255 1
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > R2-LAB#
>> > > > > >
>> > > > > >
>> > > >
>> > >
>> > > _______________________________________________________________________
>> > > > > > Subscription information may be found at:
>> > > > > > http://www.groupstudy.com/list/CCIELab.html
>> > > > > >
>> > > > >
>> > > > >
>> > > > >
>> > > > > --
>> > > >
>> > > >
>> > >
>> > > _______________________________________________________________________
>> > > > Subscription information may be found at:
>> > > > http://www.groupstudy.com/list/CCIELab.html
>> > > >
>> > > >
>> > >
>> > > _______________________________________________________________________
>> > > > Subscription information may be found at:
>> > > > http://www.groupstudy.com/list/CCIELab.html
>> > > >
>> > >
>> >
>> >
>> >
>> > --
>> > Victor Cappuccio
>> > www.vcappuccio.wordpress.com
>> >
>>
>>
>
>
> --
> Victor Cappuccio
> www.vcappuccio.wordpress.com
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Tue Apr 01 2008 - 07:53:54 ART