Re: BGP - Connection refused by remote host

From: Rookie Ccie (rookie.ccie@gmail.com)
Date: Sun Feb 17 2008 - 12:35:48 ARST


Hi,

The problem is that the BB router is trying to peer to a different AS
number.

Ex:

R6 AS - 100
BB AS - 254

BB is trying to peer to R6 assuming it has been configured with AS 200

BB#
router bgp 254
*neighbor r6.r6.r6.r6 remote-as 200*

R6
router bgp 100
neighbor bb.bb.bb.bb remote-as 254

You need to use the below command on R6 to solve this

R6
*neighbor bb.bb.bb.bb local-as 200*

The problem is how to find this AS number, I have seen several threads
regarding this but no proper solution. Some say it's the hex number
in "debug ip bgp" but it does not give what we want.

If some one has a solution please let us know.

Regards

On Feb 14, 2008 6:10 PM, Cristian Ionescu <cristian.ionescu@omnilogic.ro>
wrote:

> Hi GS
>
> I have a strange situation with a "simple" BGP peering session.
> I have 2 router connected over FR in different AS-es and i want to
> establish a peering session between them. Let's say i do not know the
> config of BB.
>
> AS100 - - - - - AS54
> R6 <----------> BB
>
> The config of R6 is:
>
> R6#
> interface Loopback0
> ip address 150.1.6.6 255.255.255.0
> !
> interface Serial0/0/0
> ip address 54.1.1.6 255.255.255.0
> !
> router bgp 100
> no synchronization
> bgp log-neighbor-changes
> neighbor 54.1.1.254 remote-as 54
> no auto-summary
> !
>
>
> BB is directly connected and the peer address is 54.1.1.254 (i have ping
> to this address)
>
> I get the following debug output:
>
> *Feb 14 11:33:31.259: BGP: 54.1.1.254 open active, local address 54.1.1.6
> TCB45114344 created
> *Feb 14 11:46:32.839: TCB45114344 setting property TCP_WINDOW_SIZE (0)
> 4511D1C8
> *Feb 14 11:46:32.839: TCB45114344 setting property TCP_MD5KEY (5) 0
> *Feb 14 11:46:32.839: TCB45114344 setting property TCP_TOS (11) 4511D1A8
> *Feb 14 11:46:32.839: TCB45114344 setting property TCP_OUT_TTL (24)
> 46B25A2A
> *Feb 14 11:46:32.839: TCP: Random local port generated 53511
> *Feb 14 11:46:32.839: TCB45114344 bound to 54.1.1.6.53511
> *Feb 14 11:46:32.839: TCP: sending SYN, seq 664141347, ack 0
> *Feb 14 11:46:32.839: TCP0: Connection to 54.1.1.254:179, advertising
> MSS 1460
> *Feb 14 11:46:32.839: TCP0: state was CLOSED -> SYNSENT [53511 ->
> 54.1.1.254(179)]
> *Feb 14 11:46:32.839: TCP0: state was SYNSENT -> CLOSED [53511 ->
> 54.1.1.254(179)]
> *Feb 14 11:46:32.839: TCP0: bad seg from 54.1.1.254 -- closing
> connection: port 53511 seq 0 ack 664141348 rcvnxt 0 rcvwnd 0 len 0
> *Feb 14 11:46:32.843: TCP0: connection closed - remote sent RST
> *Feb 14 11:46:32.843: TCB 0x45114344 destroyed
> *Feb 14 11:33:31.259: BGP: 54.1.1.254 open failed: Connection refused by
> remote host, open active delayed 29499ms (32000ms max, 28% jitter)
>
> Can u please tell me where is the problem? What is the cause of this
> kind of error message?
>
> Regards
> Cristian Ionescu
>
> This message (including any attachments) is intended only for
> the use of the individual or entity to which it is addressed and
> may contain information that is non-public, proprietary,
> privileged, confidential, and exempt from disclosure under
> applicable law or may constitute as attorney work product.
> If you are not the intended recipient, you are hereby notified
> that any use, dissemination, distribution, or copying of this
> communication is strictly prohibited. If you have received this
> communication in error, notify us immediately by telephone and
> (i) destroy this message if a facsimile or (ii) delete this message
> immediately if this is an electronic communication.
>
> Thank you,
> Support Team
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:48 ARST