IE version 4 - BGP Bestpath selection - MED - Help please

From: Ernst Pelser (e.pelser@infosecureltd.com)
Date: Fri Feb 08 2008 - 16:19:29 ARST


Hi
I'm currently working on the IE version 4 advanced Tech workbook. Basically
I have the following setup:
 
R1 and R3 are connected via serial line. Both are in BGP AS2
 
R4 and R5 are connected via a serial link and are both in BGP AS1
 
R1 and R4 are connected via ethernet and are EBGP peers. Likewise R3 and R5
are also EBGP peers. So in short I have AS1 and AS2 dual homed to each
other. R3 is advertising 155.1.37.0/24 into BGP and R5 is advertising
155.1.5.0/24 into BGP.
 
R5 is also sending a MED of 200 to R3. R4 is sending a MED of 100 to R1.

Basically everything works like I want it to i.e. R3 prefers the route
through R1 for 155.1.5.0/24. Here is the bit I don't understand.....
 
Why can I not see, on R1, both routes to 155.1.5.0 when I do a show ip bgp
155.1.5.0? I would expect to see an available route through either R4 or R3.
 
Sorry for the long post. Any help would be appreciated. Please also see the
configs below.
 
Thanks, EP
 
  _____

R1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
interface Ethernet0/0
 ip address 155.1.146.1 255.255.255.0
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 ip address 155.1.13.1 255.255.255.0
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 155.1.13.3 remote-as 2
 neighbor 155.1.13.3 next-hop-self
 neighbor 155.1.146.4 remote-as 1
 no auto-summary
!
ip http server
ip classless
!
!
alias exec c conf t
alias exec inb sh ip int brief
alias exec r show run
alias exec rb sh run | begin
alias exec b sho ip bgp
alias exec bs show ip bgp summ
alias exec bn sho ip bgp nei
alias exec i sho ip route
alias exec o sho ip ospf nei
alias exec e sho ip eigr nei
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
!
end
                   
R3
--output omitted---
interface Ethernet0/0
 ip address 155.1.37.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 155.1.0.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.0.5 305 CISCO
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 clockrate 128000
!
interface Serial1/3
 no ip address
 shutdown
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 155.1.37.0 mask 255.255.255.0
 neighbor 155.1.0.5 remote-as 1
 neighbor 155.1.13.1 remote-as 2
 neighbor 155.1.13.1 next-hop-self
 no auto-summary
!
ip http server
ip classless
!
--output omitted---
 
R4
--output omitted--
interface Ethernet0/1
 ip address 155.1.146.4 255.255.255.0
 half-duplex
!
interface Serial0/1
 ip address 155.1.45.4 255.255.255.0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 155.1.45.5 remote-as 1
 neighbor 155.1.45.5 next-hop-self
 neighbor 155.1.146.1 remote-as 2
 neighbor 155.1.146.1 route-map MED-100 out
 no auto-summary
!
ip http server
ip classless
!
!
!
route-map MED-100 permit 10
 set metric 100
!
--output omitted--
 
R5
--output omitted--
interface Ethernet0/1
 ip address 155.1.5.5 255.255.255.0
 half-duplex
!
interface Serial1/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.0.3 503 CISCO
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1/1
 ip address 155.1.45.5 255.255.255.0
 clockrate 128000
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 155.1.5.0 mask 255.255.255.0
 neighbor 155.1.0.3 remote-as 2
 neighbor 155.1.0.3 route-map MED-100 out
 neighbor 155.1.45.4 remote-as 1
 neighbor 155.1.45.4 next-hop-self
 no auto-summary
!
ip http server
ip classless
!
route-map MED-100 permit 10
 set metric 200
!
 
Also please see the sho ip bgp info:
R1
 
R1#sh ip bgp
BGP table version is 7, local router ID is 155.1.146.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network Next Hop Metric LocPrf Weight Path
*> 155.1.5.0/24 155.1.146.4 100 0 1 i
*>i155.1.37.0/24 155.1.13.3 0 100 0 i
R1#sho ip bgp 155.1.5.0
BGP routing table entry for 155.1.5.0/24, version 7
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:
  155.1.13.3
  1
    155.1.146.4 from 155.1.146.4 (155.1.146.4)
      Origin IGP, metric 100, localpref 100, valid, external, best
 
R3
R3#sho ip bgp 155.1.5.0
BGP routing table entry for 155.1.5.0/24, version 6
Paths: (2 available, best #2, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:
  155.1.0.5
  1
    155.1.0.5 from 155.1.0.5 (155.1.45.5)
      Origin IGP, metric 200, localpref 100, valid, external
  1
    155.1.13.1 from 155.1.13.1 (155.1.146.1)
      Origin IGP, metric 100, localpref 100, valid, internal, best
 
R4
R4#sho ip bgp
BGP table version is 6, local router ID is 155.1.146.4
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network Next Hop Metric LocPrf Weight Path
*>i155.1.5.0/24 155.1.45.5 0 100 0 i
* i155.1.37.0/24 155.1.45.5 0 100 0 2 i
*> 155.1.146.1 0 2 i
R4# sh ip bgp 155.1.5.0
BGP routing table entry for 155.1.5.0/24, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:
  155.1.146.1
  Local
    155.1.45.5 from 155.1.45.5 (155.1.45.5)
      Origin IGP, metric 0, localpref 100, valid, internal, best
R4#
 
 
R5
R5#sh ip bgp
BGP table version is 5, local router ID is 155.1.45.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network Next Hop Metric LocPrf Weight Path
*> 155.1.5.0/24 0.0.0.0 0 32768 i
*> 155.1.37.0/24 155.1.0.3 0 0 2 i
* i 155.1.45.4 0 100 0 2 i
R5#
R5#
R5#
R5#sh ip bgp 155.1.5.0
BGP routing table entry for 155.1.5.0/24, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:
  155.1.0.3 155.1.45.4
  Local
    0.0.0.0 from 0.0.0.0 (155.1.45.5)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced,
local, best



This archive was generated by hypermail 2.1.4 : Sat Mar 01 2008 - 16:54:48 ARST