From: Jian Gu (guxiaojian@gmail.com)
Date: Wed Jan 16 2008 - 17:03:30 ARST
You will only get output of "debug ip mpacket" or "debug ip packet" if the
packets are sent to CPU.
On Jan 15, 2008 3:31 PM, Huan Pham <huan.pham@valuenet.com.au> wrote:
> Hi GS,
>
> I have difficulty understanding the "debug ip mpacket" command. My
> understanding is that it should show all the multicast packets that a
> router
> receives, sends or forwards. It seems that this is not the case! I can
> only
> see the multicast packets when the router run multicast routing AND join a
> multicast group.
>
> - If a router runs unicast and join a multicst group (pretending as a PC
> listening to multicast traffic), the debug ip packets DOES NOT show any
> multicast packets.
>
> - If a router runs multicast and does not join any group (a transit
> multicast router), the debug ip packets DOES NOT show anything either.
>
> - In the transit Multicast router (R2), I can not see the multicast packet
> using "debug ip packet". In the destination host (R4, running only
> Unicast)
> I can see multicast packets using "debug ip packet".
>
>
> I would like to know if this is a normal behavior or I miss something.
>
>
> My config is below. I run PIM Dense mode. The multicast forwarding works
> fine.
>
>
> Thanks,
>
>
>
>
>
> TOPOLOGY
>
> R1 (src) --------- R3 ----------------R2 -------------R4 (dest)
> 13.0.0.0/8 23.0.0.0/8 24.0.0.0/8
>
>
>
>
>
> R1#
> !
>
> ! This is to generate Multicast traffic
> ip sla monitor 1
> type udpEcho dest-ipaddr 224.1.1.1 dest-port 12345 source-ipaddr 13.0.0.1
> control disable
> timeout 0
> frequency 5
> ip sla monitor schedule 1 life forever start-time now
> !
> !
> interface FastEthernet0/0
> ip address 13.0.0.1 255.0.0.0
> !
> router ospf 1
> network 0.0.0.0 255.255.255.255 area 0
>
>
>
>
> R3#
> !
> no ip domain lookup
> ip multicast-routing
> !
> !
> !
> interface FastEthernet0/0
> ip address 13.0.0.3 255.0.0.0
> ip pim dense-mode
> !
> interface Serial1/3
> ip address 23.0.0.3 255.0.0.0
> ip pim dense-mode
> !
> router ospf 1
> network 0.0.0.0 255.255.255.255 area 0
>
>
>
>
> R2#
>
> ip multicast-routing
> !
> interface FastEthernet0/0
> ip address 24.0.0.2 255.0.0.0
> ip pim dense-mode
> !
> interface Serial1/1
> ip address 23.0.0.2 255.0.0.0
> ip pim dense-mode
> !
> router ospf 1
> log-adjacency-changes
> network 0.0.0.0 255.255.255.255 area 0
> !
>
>
>
>
> R4#
> !
> interface Ethernet0/0
> ip address 24.0.0.4 255.0.0.0
> ip igmp join-group 224.1.1.1
> !
> !
> router ospf 1
> network 0.0.0.0 255.255.255.255 area 0
>
>
>
> R3#sh ip mroute 224.1.1.1
> IP Multicast Routing Table
> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
> Connected,
> L - Local, P - Pruned, R - RP-bit set, F - Register flag,
> T - SPT-bit set, J - Join SPT, M - MSDP created entry,
> X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
> U - URD, I - Received Source Specific Host Report, Z - Multicast
> Tunnel
> Y - Joined MDT-data group, y - Sending to MDT-data group
> Outgoing interface flags: H - Hardware switched, A - Assert winner
> Timers: Uptime/Expires
> Interface state: Interface, Next-Hop or VCD, State/Mode
>
> (*, 224.1.1.1), 00:35:28/stopped, RP 0.0.0.0, flags: DCL
> Incoming interface: Null, RPF nbr 0.0.0.0
> Outgoing interface list:
> Serial0/3, Forward/Dense, 00:32:37/00:00:00
> FastEthernet0/0, Forward/Dense, 00:34:02/00:00:00
>
> (13.0.0.1, 224.1.1.1), 00:35:25/00:02:59, flags: LT
> Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
> Outgoing interface list:
> Serial0/3, Forward/Dense, 00:32:37/00:00:00
>
>
>
> R2#sh ip mroute 224.1.1.1
> IP Multicast Routing Table
> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
> Connected,
> L - Local, P - Pruned, R - RP-bit set, F - Register flag,
> T - SPT-bit set, J - Join SPT, M - MSDP created entry,
> X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
> U - URD, I - Received Source Specific Host Report, Z - Multicast
> Tunnel
> Y - Joined MDT-data group, y - Sending to MDT-data group
> Outgoing interface flags: H - Hardware switched, A - Assert winner
> Timers: Uptime/Expires
> Interface state: Interface, Next-Hop or VCD, State/Mode
>
> (*, 224.1.1.1), 00:29:46/stopped, RP 0.0.0.0, flags: DC
> Incoming interface: Null, RPF nbr 0.0.0.0
> Outgoing interface list:
> FastEthernet0/0, Forward/Dense, 00:27:21/00:00:00
> Serial0/1, Forward/Dense, 00:29:46/00:00:00
>
> (13.0.0.1, 224.1.1.1), 00:29:45/00:02:56, flags: T
> Incoming interface: Serial0/1, RPF nbr 23.0.0.3
> Outgoing interface list:
> FastEthernet0/0, Forward/Dense, 00:27:21/00:00:00
>
> R2#debug ip mpacket
> IP multicast packets debugging is on
> R2#
>
> ! NOTHING SHOWS UP
>
>
> R2#
> R2#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> R2(config)#int s0/1
> R2(config-if)#ip igmp join 224.1.1.1
> R2(config-if)#
> R2#
> Jan 16 12:01:48.771: %SYS-5-CONFIG_I: Configured from console by console
> Jan 16 12:01:51.215: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:01:56.215: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:02:01.215: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:02:06.215: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:02:11.211: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:02:16.211: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
> Jan 16 12:02:21.211: IP(0): s=13.0.0.1 (Serial0/1) d=224.1.1.1
> (FastEthernet0/0) id=0, ttl=253, prot=17, len=44(44), mforward
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Fri Feb 01 2008 - 10:38:00 ARST