FW: IP Multicast Question -- IP pim autorp listner

From: Smithson, Brandon K (brandon.k.smithson@citi.com)
Date: Sat Dec 29 2007 - 14:21:52 ART


I labbed up your configs in Dynamips and pinged from R2 to the 224.2.2.2
group on R4 with a repeat count of 5 and 10. It looks like all went
through. The only change I made to your config was to change the
lmi-type on R5 to ansi. It was set to cisco, while the others were
running ansi. I know the different lmi-type was not your original
problem, as the frame cloud was not working period until I changed it.

R2#debug ip mpacket

IP multicast packets debugging is on

R2#ping 224.2.2.2 repeat 5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 5.5.245.4, 192 ms

Reply to request 1 from 5.5.245.4, 220 ms

*Mar 1 00:21:29.355: IP(0): s=5.5.5.5 (Serial0/0.25) d=224.0.1.39
id=389, ttl=254, prot=17, len=58(54), mroute olist null

Reply to request 2 from 5.5.245.4, 208 ms

Reply to request 3 from 5.5.245.4, 176 ms

Reply to request 4 from 5.5.245.4, 176 ms

R2#ping 224.2.2.2 repeat 5

*Mar 1 00:22:06.351: IP(0): s=5.5.5.5 (Serial0/0.25) d=224.0.1.40
(FastEthernet1/0) id=407, ttl=254, prot=17, len=54(54), mforward

R2#ping 224.2.2.2 repeat 5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 5.5.245.4, 116 ms

Reply to request 1 from 5.5.245.4, 180 ms

Reply to request 2 from 5.5.245.4, 172 ms

Reply to request 3 from 5.5.245.4, 156 ms

Reply to request 4 from 5.5.245.4, 156 ms

R2#

R2#un all

All possible debugging has been turned off

R2#ping 224.2.2.2 repeat 10

Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 5.5.245.4, 244 ms

Reply to request 0 from 5.5.245.4, 244 ms

Reply to request 1 from 5.5.245.4, 220 ms

Reply to request 1 from 5.5.245.4, 224 ms

Reply to request 2 from 5.5.245.4, 172 ms

Reply to request 3 from 5.5.245.4, 216 ms

Reply to request 4 from 5.5.245.4, 136 ms

Reply to request 5 from 5.5.245.4, 216 ms

Reply to request 6 from 5.5.245.4, 168 ms

Reply to request 7 from 5.5.245.4, 184 ms

Reply to request 8 from 5.5.245.4, 184 ms

Reply to request 9 from 5.5.245.4, 164 ms

R2#

  _____

From: backbone systems [mailto:backbone.systems@gmail.com]
Sent: Saturday, December 29, 2007 12:28 AM
To: Smithson, Brandon K [CCC-OT_IT]
Cc: Victor Cappuccio; Cisco certification; Ray raphy
Subject: Re: IP Multicast Question -- IP pim autorp listner

Thanks for the replies . it is really nice.
here is my config for all the three routers.
For the source of ip packet , ijust enabled sparse mode on the lo of R2
, just for testing but still the same issue .From R5 there is no prob
with the ping, i can ping contineously.
Please let me know after seeing the config

R2

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 5.5.20.2 255.255.255.0
 ip pim sparse-mode
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.25 multipoint
 ip address 5.5.245.2 255.255.255.0
 ip pim sparse-mode
 no ip mroute-cache
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 frame-relay map ip 5.5.245.4 205
 frame-relay map ip 5.5.245.5 205 broadcast
!
interface Serial0/0.26 multipoint
 ip address 5.5.26.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-point
 frame-relay map ip 5.5.26.6 206 broadcast
!
interface FastEthernet0/1
 ip address 5.5.62.2 255.255.255.0
 ip pim sparse-mode
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 router-id 5.5.2.2
 log-adjacency-changes
 area 41 virtual-link 5.5.6.6 authentication message-digest
 area 41 virtual-link 5.5.6.6 message-digest-key 1 md5 cisco
 network 5.5.2.2 0.0.0.0 area 4
 network 5.5.26.2 0.0.0.0 area 41
 network 5.5.62.2 0.0.0.0 area 41
 network 5.5.245.2 0.0.0.0 area 0
!
!
!
ip http server
no ip http secure-server
ip pim autorp listener
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5

hostname R5
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip multicast-routing
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 5.5.50.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 5.5.245.5 255.255.255.0
 ip pim nbma-mode
 ip pim sparse-mode
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 no ip mroute-cache
 frame-relay map ip 5.5.245.2 502 broadcast
 frame-relay map ip 5.5.245.4 504 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 5.5.50.2 0.0.0.0 area 5
 network 5.5.245.5 0.0.0.0 area 0
 neighbor 5.5.245.2
 neighbor 5.5.245.4
!
ip http server
no ip http secure-server
ip classless
!
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 255 group-list 10
ip pim send-rp-discovery Loopback0 scope 255
!
access-list 10 permit 224.1.1.1
access-list 10 permit 224.2.2.2
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R4

hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 150.2.5.4 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 224.1.1.1
 ip igmp join-group 224.2.2.2
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 5.5.245.4 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 no ip mroute-cache
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 no fair-queue
 frame-relay map ip 5.5.245.2 405
 frame-relay map ip 5.5.245.5 405 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 router-id 5.5.4.4
 log-adjacency-changes
 redistribute connected subnets route-map BB2
 network 5.5.4.4 0.0.0.0 area 0
 network 5.5.245.4 0.0.0.0 area 0
!
!
!
ip http server
no ip http secure-server
ip pim autorp listener
!
!
route-map BB2 permit 10
 match interface FastEthernet0/0
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

On Dec 29, 2007 2:55 AM, Smithson, Brandon K
<brandon.k.smithson@citi.com> wrote:

I've seen something similar like this before. Make sure your R2 fa0/0
is up. If it is shutdown (I would imagine down also), then the router
will show the source as being from loopback 0, which does not have
multicast enabled, and hence, the pings will not work. I've seen this
exact same thing in a lab before (except there was no fa0/0 interface)
and once multicast was enabled on the loopback interface, everything
worked.

The way I rationalized it before was that the pinging router (source)
needs at least two interfaces up/up with PIM enabled. One to source the
pings (or to replicate the interface that would be receiving the source
traffic) and one interface to send it out towards the RP (for SM). I do
not believe it will work with just one interface up/up with PIM enabled.

Brandon

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of

Smithson, Brandon K [CCC-OT_IT]
Sent: Friday, December 28, 2007 5:17 PM
To: backbone systems; Victor Cappuccio
Cc: Cisco certification

Subject: RE: IP Multicast Question -- IP pim autorp listner

On all three routers, can you please do a show run, copy your configs
and reply with them? Interesting how on R2 your source address below is
the loopback 0 address when your original configs do not even show
multicast enabled on loopback 0. I would think the source would be
5.5.245.2, your outgoing Serial 0/0.25 interface. If you post your
configs, we can lab it up to replicate the behavior and see what's
possibly wrong.

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
backbone systems
Sent: Friday, December 28, 2007 2:48 PM
To: Victor Cappuccio
Cc: Cisco certification
Subject: Re: IP Multicast Question -- IP pim autorp listner

i tried no ip mroute-cache,nbma-mode and bi-dir.nothing is working when
i do debug ip mpacket on R2 i get this which shows some kind of mistake.

R2(config-subif)#do ping 224.1.1.1 re 5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

*Mar 2 03:28:44.464: IP(0): s=5.5.2.2 (Loopback0) d= 224.1.1.1
<http://224.1.1.1> id=152,
ttl=254, prot=1, len=100(100), mroute olist null.
*Mar 2 03:28:46.463: IP(0): s=5.5.2.2 (Loopback0) d=224.1.1.1 id=153,
ttl=254, prot=1, len=100(100), mroute olist null.
*Mar 2 03:28:48.467: IP(0): s=5.5.2.2 (Loopback0) d=224.1.1.1 id=154,
ttl=254, prot=1, len=100(100), mroute olist null.
*Mar 2 03:28:50.466: IP(0): s=5.5.2.2 (Loopback0) d=224.1.1.1 id=155,
ttl=254, prot=1, len=100(100), mroute olist null.
*Mar 2 03:28:52.469: IP(0): s=5.5.2.2 (Loopback0) d=224.1.1.1 id=156,
ttl=254, prot=1, len=100(100), mroute olist null

any suggestions?????

BB

On Dec 28, 2007 10:20 PM, Victor Cappuccio <vcappuccio@gmail.com> wrote:

>
> Upssssss ip pim nbma missing there :) for sure that would be needed to

> pass traffic in S0/0 in R5 (like the split-horizon for multicast
> traffic), Now the stange part is that Backbone was able to ping the
> Groups Joined in
> R4
> R2#ping 224.2.2.2 re 5
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
>
> Reply to request 0 from 5.5.245.4, 136 ms Reply to request 0 from
> 5.5.245.4 , 208 ms Reply to request 0 from 5.5.245.4, 176 ms Reply to
> request 1 from 5.5.245.4, 141 ms Reply to request 1 from 5.5.245.4,
> 157 ms...
>
> Now for his output the ip pim sparse must be issued before doing the
> R1#conf ter Enter configuration commands, one per line. End with
> CNTL/Z.
> R1(config)#int
> *Dec 28 19:56:25.083: %SYS-5-CONFIG_I: Configured from console by
> console R1(config)#int lo0 R1(config-if)#ip add 1.1.1.1 255.255.255.0
> R1(config-if)#exit R1(config)#ip pim send-rp-announce Loopback0 scope
> 16 Must first configure PIM mode on the interface: Loopback0
>
> Also I would like to copy this link
> http://groupstudy.com/archives/ccielab/200611/msg01185.html
> is from Mr Caslow on how to debug multicast routing, very nice
> document to read.
> So I would think that Backbone, was not receving an RPF Failure, we
> can see yet that the traffic that he was sourcing the traffic is now
> prunned
>
> (*, 224.2.2.2), 00:03:23/stopped, RP 5.5.5.5, flags: SP Incoming
> interface: Serial0/0.25, RPF nbr 5.5.245.5 Outgoing interface list:
> Null
>
> ( 5.5.245.5, 224.2.2.2), 00:03:23/00:00:03, flags: PT Incoming
> interface: Serial0/0.25, RPF nbr 0.0.0.0 Outgoing interface list:
> Null
>
>
> And for me that reads as an STP Problem, I need to lab this out :D
> Thanks
> Victor.-
>
>
>
> On Dec 28, 2007 7:25 PM, Smithson, Brandon K <
> brandon.k.smithson@citi.com>
> wrote:
>
> > Looks like you might be missing "ip pim nbma-mode" on the hub, and
> > also "ip pim sparse-mode" on your R5 loopback0. Also, I don't know
> > if this applies to yours, but just in the last few days someone
> > posted a similar problem and "no ip mroute-cache" fixed theirs.
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf

> > Of backbone systems
> > Sent: Friday, December 28, 2007 10:44 AM
> > To: Cisco certification
> > Subject: IP Multicast Question -- IP pim autorp listner
> >
> > Hi all,
> >
> > R5 is hub and R2 and R4 are spokes . i have to use ip pim autorp
> > listner
> >
> > command on all the routers. R5 loopback is the the rp .
> > The problem i am having is that when i ping from R2 to R4 igmp group

> > 224.1.1.1 i get first two replies but rest time out ?? why is this
> > happening .
> > i need real help
> >
> > Here is my config ,
> >
> > R2
> >
> > ip multicast-rou
> >
> > int fas0/0
> > ip pim sparse-mode
> >
> > int ser0/0.25
> > ip pim sparse mode
> >
> > ip pim auto-rp listner
> >
> >
> > R5
> >
> > ip multicast-rou
> >
> > int ser0/0
> > ip pim sparse-mo
> >
> > ip pim auto-rp listner
> >
> > ip pim send-rp-announce Loopback0 scope 16 group-list 10 ip pim
> > send-rp-discovery Loopback0 scope 16
> >
> > access-list 10 per 224.1.1.1
> > access-list 10 per 224.2.2.2
> >
> > R4
> >
> > ip multicast-rou
> >
> > int ser0/0
> > ip pim sparse-mo
> >
> > int fas0/0
> > ip pim sparse-mo
> > ip igmp join-g 224.1.1.1
> > ip igmp join-g 224.2.2.2
> >
> > ip pim auto-rp listner
> >
> >
> > ON R2 some outputs
> >
> > R2#sh ip mr
> > IP Multicast Routing Table
> > Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
> > Connected,
> > L - Local, P - Pruned, R - RP-bit set, F - Register flag,
> > T - SPT-bit set, J - Join SPT, M - MSDP created entry,
> > X - Proxy Join Timer Running, A - Candidate for MSDP
> > Advertisement,
> > U - URD, I - Received Source Specific Host Report,
> > Z - Multicast Tunnel, z - MDT-data group sender,
> > Y - Joined MDT-data group, y - Sending to MDT-data group
> > Outgoing interface flags: H - Hardware switched, A - Assert winner
> > Timers: Uptime/Expires
> > Interface state: Interface, Next-Hop or VCD, State/Mode
> >
> > (*, 224.2.2.2), 00:03:23/stopped, RP 5.5.5.5, flags: SP Incoming
> > interface: Serial0/0.25, RPF nbr 5.5.245.5 Outgoing interface list:

> > Null
> >
> > ( 5.5.245.5, 224.2.2.2), 00:03:23/00:00:03, flags: PT Incoming
> > interface: Serial0/0.25, RPF nbr 0.0.0.0 Outgoing interface list:
> > Null
> >
> > (*, 224.0.1.39), 00:29:24/00:02:55, RP 0.0.0.0, flags: DC Incoming
> > interface: Null, RPF nbr 0.0.0.0 Outgoing interface list:
> > Serial0/0.25, Forward/Sparse, 00:29:25/00:00:00
> >
> > (*, 224.0.1.40), 00:29:33/stopped, RP 0.0.0.0, flags: DCL Incoming
> > interface: Null, RPF nbr 0.0.0.0 Outgoing interface list:
> > Serial0/0.25, Forward/Sparse, 00:29:33/00:00:00
> > FastEthernet0/0, Forward/Sparse, 00:29:33/00:00:00
> >
> > ( 5.5.5.5 <http://5.5.5.5> , 224.0.1.40), 00:29:24/00:02:52, flags:
LT Incoming
> > interface: Serial0/0.25, RPF nbr 5.5.245.5 Outgoing interface list:

> > FastEthernet0/0, Forward/Sparse, 00:29:24/00:00:00
> >
> >
> >
> > R2#sh ip pim rp
> > Group: 224.2.2.2, RP: 5.5.5.5, v2, v1, uptime 00:02:47, expires
> > 00:02:10 R2#
> >
> > R2#sh ip pim nei
> > PIM Neighbor Table
> > Mode: B - Bidir Capable, DR - Designated Router, N - Default DR
> > Priority,
> > S - State Refresh Capable
> > Neighbor Interface Uptime/Expires Ver
DR
> > Address
> > Prio/Mode
> > 5.5.245.5 Serial0/0.25 02:32:45/00:01:33 v2 1
/
> > DR S
> > R2#
> >
> > SEE the ping timing out on R2
> >
> > R2#sh ip pim rp
> > Group: 224.2.2.2, RP: 5.5.5.5, v2, v1, uptime 00:02:47, expires
> > 00:02:10
> >
> > R2#ping 224.2.2.2 re 5
> >
> > Type escape sequence to abort.
> > Sending 5, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
> >
> > Reply to request 0 from 5.5.245.4, 136 ms Reply to request 0 from
> > 5.5.245.4, 208 ms Reply to request 0 from 5.5.245.4, 176 ms Reply to

> > request 1 from 5.5.245.4, 141 ms Reply to request 1 from 5.5.245.4,
> > 157 ms...
> >
> >
> >
> > If u need any more outputs please let me know.
> >
> > Thanks to all
> >
> > Regards
> >
> > BB
> >
> > ____________________________________________________________________

> > ___ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > ____________________________________________________________________

> > ___ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
>
>
>
> --
>
> Victor Cappuccio
> www.vcappuccio.wordpress.com



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:32 ARST