RE: IEWB Lab 4 Task 5.3

From: Steven Hodgson (steven.hodgson@inxi.com)
Date: Wed Dec 26 2007 - 21:59:02 ART


Here they are.

----------------R1---------------------------------
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network non-broadcast
 ip ospf hello-interval 10
 duplex auto
 speed auto
 ipv6 address 2001:192:10:1::/64
 ipv6 address 2001:192:10:1::/64 eui-64
 ipv6 ospf 1 area 0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
 ip address 141.1.123.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network non-broadcast
 ip ospf priority 0
 ipv6 address 2001:141:1:12::1/64
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 1
 frame-relay interface-dlci 102
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 150.1.1.1
 log-adjacency-changes
 network 141.1.123.1 0.0.0.0 area 0
 network 150.1.1.1 0.0.0.0 area 0
 network 192.10.1.1 0.0.0.0 area 51
 neighbor 192.10.1.254
!
ip http server
ip forward-protocol nd
!
!
ip pim autorp listener
!
ipv6 router ospf 1
 log-adjacency-changes
 area 1 range 2001:141:1::/59
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

Rack1R1#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR
Priority,
      S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address
Prio/Mode
141.1.123.2 Serial1/0.1 00:53:17/00:01:29 v2 100/
S
Rack1R1#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s) 225.0.0.0/8
  RP 150.1.2.2 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:38:14, expires: 00:02:26
Group(s) 239.0.0.0/8
  RP 150.1.5.5 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:38:14, expires: 00:02:28

--------------------R2--------------------------------
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
 ip pim sparse-mode
!
interface Tunnel0
 ip address 141.1.25.2 255.255.255.0
 tunnel source FastEthernet0/0
 tunnel destination 141.1.0.5
!
interface FastEthernet0/0
 ip address 141.1.0.2 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
 ipv6 address 2001:141:1:25::1/64
 ipv6 ospf 1 area 1
!
interface Serial1/0
 ip address 141.1.123.2 255.255.255.0
 ip pim dr-priority 100
 ip pim nbma-mode
 ip pim sparse-mode
 encapsulation frame-relay
 ipv6 address 2001:141:1:12::2/64
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 1
 serial restart-delay 0
 frame-relay map ipv6 FE80::CE00:12FF:FE6C:0 201
 frame-relay map ip 141.1.123.1 201 broadcast
 frame-relay map ip 141.1.123.3 203 broadcast
 frame-relay map ipv6 2001:141:1:12::1 201 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 1 nssa no-summary
 network 141.1.0.2 0.0.0.0 area 1
 network 141.1.25.2 0.0.0.0 area 0
 network 141.1.123.2 0.0.0.0 area 0
 network 150.1.2.2 0.0.0.0 area 0
 neighbor 141.1.123.1
 neighbor 141.1.123.3
!
ip http server
ip forward-protocol nd
!
!
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 52
!
access-list 52 permit 255.0.0.0 0.255.255.255
access-list 52 permit 225.0.0.0 0.255.255.255
ipv6 router ospf 1
 log-adjacency-changes
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

Rack1R2#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR
Priority,
      S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address
Prio/Mode
141.1.0.5 FastEthernet0/0 00:53:30/00:01:26 v2 1 / S
141.1.0.8 FastEthernet0/0 00:53:31/00:01:27 v2 1 /
DR S
141.1.54.4 Serial1/0 00:51:50/00:01:41 v2 1 / S
141.1.54.5 Serial1/0 00:53:19/00:01:41 v2 1 / S
141.1.123.3 Serial1/0 00:54:31/00:01:16 v2 1 / S
141.1.123.1 Serial1/0 00:54:32/00:01:18 v2 1 / S
Rack1R2#sh ip pim rp map
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)

Group(s) 225.0.0.0/8
  RP 150.1.2.2 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:52:43, expires: 00:02:01
Group(s) 239.0.0.0/8
  RP 150.1.5.5 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:52:33, expires: 00:02:05

-------------------R3------------------------------------
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 141.1.37.3 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 225.25.25.25
 full-duplex
!
interface Ethernet0/1
 ip address 141.1.36.3 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 239.39.39.39
 full-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
 ip address 141.1.123.3 255.255.255.0
 ip pim sparse-mode
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay interface-dlci 302
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 redistribute rip subnets
 network 141.1.123.3 0.0.0.0 area 0
 network 150.1.3.3 0.0.0.0 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 1
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Ethernet0/1
 network 141.1.0.0
 no auto-summary
!
ip http server
ip forward-protocol nd
!
!
ip pim autorp listener
ip pim spt-threshold infinity
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

Rack1R3#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR
Priority,
      S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address
Prio/Mode
141.1.37.7 Ethernet0/0 00:55:31/00:01:26 v2 1 /
DR S
141.1.123.2 Serial1/0.1 00:55:23/00:01:24 v2 100/
S
Rack1R3#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s) 225.0.0.0/8
  RP 150.1.2.2 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:53:14, expires: 00:02:24
Group(s) 239.0.0.0/8
  RP 150.1.5.5 (?), v2v1
    Info source: 141.1.0.8 (?), elected via Auto-RP
         Uptime: 00:53:14, expires: 00:02:22

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
George Goglidze
Sent: Wednesday, December 26, 2007 1:17 PM
To: steveaggie@gmail.com
Cc: ccielab@groupstudy.com
Subject: Re: IEWB Lab 4 Task 5.3

Hi There,

Paste all the configs , it will be easier to diagnose the problem...

And along with the configs, paste me following command outputs from all
routers:
#sh ip pim neighbor
#sh ip pim rp map

Regards,

On Dec 26, 2007 8:10 PM, <steveaggie@gmail.com> wrote:

> Sorry, I forgot to say that I have "ip autorp listener" enabled on
all of
> the routers and R2 is the RP.
>
>
>
> *From:* George Goglidze [mailto:goglidze@gmail.com]
> *Sent:* Wednesday, December 26, 2007 1:08 PM
> *To:* steveaggie@gmail.com
> *Subject:* Re: IEWB Lab 4 Task 5.3
>
>
>
> Hi There,
>
> You've got sparse-mode PIM enabled, and I did not see any RP's.
> Sparse-mode does not work without RP.
>
> Regards,
>
> On Dec 26, 2007 7:18 PM, < steveaggie@gmail.com> wrote:
>
> Can someone help me understand why multicast is not working correctly
on
> the
> following network:
>
>
>
> R1------R2-----R3
>
>
>
> -Frame Relay hub and spoke. R2 is the hub.
>
> -R1 & R3 connect using P2P sub-interfaces (s1/0.1)
>
> -R2 uses the physical interface (s1/0)
>
> -R3 has a static IGMP join to 225.25.25.25 on its e0/0 interface
>
> -I try to ping 225.25.25.25 from the e0/0 interface on R1
>
> -A few replies are received and then nothing
>
> -From the debugs it appears R3 is trying to join the SPT to R1 and for
> some
> reason R2 sends R3 a Register-Stop message.
>
>
>
> R1:
>
> interface Serial1/0.1 point-to-point
>
> ip address 141.1.123.1 255.255.255.0
>
> ip pim sparse-mode
>
> ip ospf network non-broadcast
>
> ip ospf priority 0
>
> frame-relay interface-dlci 102
>
>
>
> R2:
>
> interface Serial1/0
>
> ip address 141.1.123.2 255.255.255.0
>
> ip pim dr-priority 100
>
> ip pim nbma-mode
>
> ip pim sparse-mode
>
> encapsulation frame-relay
>
> serial restart-delay 0
>
> frame-relay map ip 141.1.123.1 201 broadcast
>
> frame-relay map ip 141.1.123.3 203 broadcast
>
> no frame-relay inverse-arp
>
> frame-relay lmi-type ansi
>
>
>
> R3:
>
> interface Serial1/0.1 point-to-point
>
> ip address 141.1.123.3 255.255.255.0
>
> ip pim sparse-mode
>
> ip ospf network non-broadcast
>
> ip ospf priority 0
>
> frame-relay interface-dlci 302
>
>
>
> Debugs from R3:
>
> Rack1R3#
>
> *Mar 1 03:49:12.219: PIM(0): Insert (141.1.123.1, 225.25.25.25) sgr
prune
> in
> nbr 141.1.123.2's queue
>
> *Mar 1 03:49:12.223: PIM(0): Send v2 Register to 150.1.2.2 for
> 141.1.123.1,
> group 225.25.25.25
>
> *Mar 1 03:49:12.235: PIM(0): Insert ( 192.10.1.1,225.25.25.25) join
in
> nbr
> 141.1.123.2's queue
>
> *Mar 1 03:49:12.243: PIM(0): Building Join/Prune packet for nbr
> 141.1.123.2
>
> *Mar 1 03:49:12.247: PIM(0): Adding v2 (192.10.1.1/32, 225.25.25.25),
> S-bit
> Join
>
> *Mar 1 03:49:12.251: PIM(0): Adding v2 (141.1.123.1/32,
225.25.25.25),
> RPT-bit, S-bit Prune
>
> *Mar 1 03:49:12.255: PIM(0): Send v2 join/prune to 141.1.123.2
> (Serial1/0.1)
>
> Rack1R3#
>
> *Mar 1 03:49:12.271: PIM(0): Received v2 Register-Stop on Serial1/0.1
> from
> 150.1.2.2
>
> *Mar 1 03:49:12.271: PIM(0): for source 141.1.123.1, group
225.25.25.25
>
> *Mar 1 03:49:12.275: PIM(0): Clear Registering flag to 150.1.2.2 for
> (141.1.123.1/32, 225.25.25.25)
>
> Rack1R3#
>
> *Mar 1 03:49:15.639: PIM(0): Received v2 Join/Prune on Ethernet0/0
from
> 141.1.37.7, to us
>
> *Mar 1 03:49:15.643: PIM(0): Join-list: ( 141.1.123.1/32,
225.25.25.25),
> S-bit set
>
> *Mar 1 03:49:15.647: PIM(0): Update Ethernet0/0/141.1.37.7 to
(141.1.123.1
> ,
> 225.25.25.25), Forward state, by PIM SG Join
>
> *Mar 1 03:49:15.651: PIM(0): Join-list: (192.10.1.1/32 ,
225.25.25.25),
> S-bit set
>
> *Mar 1 03:49:15.655: PIM(0): Update Ethernet0/0/141.1.37.7 to
(192.10.1.1
> ,
> 225.25.25.25), Forward state, by PIM SG Join
>
> Rack1R3#
>
> *Mar 1 03:49:19.691: PIM(0): Building Periodic (*,G) Join /
(S,G,RP-bit)
> Prune message for 225.25.25.25
>
> *Mar 1 03:49:19.695: PIM(0): Insert (*,225.25.25.25) join in nbr
> 141.1.123.2's queue
>
> *Mar 1 03:49: 19.695: PIM(0): Insert (141.1.123.1,225.25.25.25) sgr
prune
> in
> nbr 141.1.123.2 's queue
>
> *Mar 1 03:49:19.703: PIM(0): Building Join/Prune packet for nbr
> 141.1.123.2
>
> *Mar 1 03:49:19.707: PIM(0): Adding v2 ( 150.1.2.2/32, 225.25.25.25),
> WC-bit, RPT-bit, S-bit Join
>
> *Mar 1 03:49:19.711: PIM(0): Adding v2 (141.1.123.1/32 ,
225.25.25.25),
> RPT-bit, S-bit Prune
>
> *Mar 1 03:49:19.715: PIM(0): Send v2 join/prune to 141.1.123.2
> (Serial1/0.1)
>
>



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:32 ARST