From: Scott Vermillion (scott_ccie_list@it-ag.com)
Date: Mon Dec 24 2007 - 16:40:08 ART
It's not intuitive that R1, R4, and R5 would originate summaries for routes
that don't even require summarization, but they do. See my response to Dane
with some packet capture included so you can see exactly what's happening
and why. The two choices (that I'm aware of) are to enable auto-summary
everywhere or turn split-horizon on at the spokes. With the latter
approach, you still have the hub originating summaries towards the spokes
and thus your hop count is not exactly correct at the spokes (1 instead of 2
because the hub re-originates the routes). So if that was an issue, I guess
you could turn auto-summary off at the hub and split horizon on at the
spokes. All depends on the restrictions of the lab, I guess. This one's
fun to play with. For you Dynamips-enabled folken, below is a very simply .
net file to lab this up. Just create loopbacks (or add in Ethernet ports)
and enable rip and you're off and running!
autostart = false
model = 3640
[localhost]
[[3640]]
image = C:\Program Files\Dynamips\images\c3640-js-mz.124-17.image
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
ram = 128
[[ROUTER R1]]
s1/0 = F1 1
[[ROUTER R2]]
s1/0 = F1 2
[[ROUTER R3]]
s1/0 = F1 3
[[FRSW F1]]
1:102 = 2:201
1:103 = 3:301
2:203 = 3:302
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Chan
Hong
Sent: Monday, December 24, 2007 12:12 PM
To: Dane Newman; ccielab@groupstudy.com
Subject: Re$B!'(B why is rip acting like this? am I going nuts?
I think "no auto-summary" is necessary(unless request not to) in the lab.
But
I don't understand why R1 have a load balancing route for 4.0.0.0/8 and
5.0.0.0/8 to R4/R5. These routes shouldn't be generated on R4/R5 even
auto-summary turn on.............
Regards,
Howard
----- 6l%s-l%s ----
1H%s$H!R Dane Newman <dnewman@datasc.com>
&,%s$H ccielab@groupstudy.com
6G0e$i4A!R 2007 &~ 12$k 23 $i ,P4A$i $U$H 11:22:03
%DCD!G Re: why is rip
acting like this? am I going nuts?
Ok yeah so playing around with it a bit
more I did no auto on all the
routers to not summarize and the redundant
routes go away and everything
works I guess this is an eye opener how rip
behaves. I didnt think we
needed no auto for this lab because all the routes
are in there classful
boundary's
On 12/23/07, Dane Newman
<dnewman@datasc.com> wrote:
>
> Hello Experts,
>
> I am doing an Internetwork
expert lab for rip in workbook 1 and rip is
> acting very odd
>
>
>
> I have a
hub and spoke topolgy with R1 being the hub and then R4 and R5
> being the
spokes.
>
> R1 has a network 1.0.0.1 advertised into rip
> R4 has network
4.0.0.4 advertised into rip
> R5 has network 5.0.0.5 advetised into rip
> The
10.0.0.0 network connects all the spokes to the hub via frame relay
>
> There
are two odd things that I feel are wrong that I cant explain
>
>
> 1. Below
is the output of show ip route on R1 and it is load balancing
> the traffic to
the spokes which it should NOT be. It should be saying to
> get to 4.0.0.0/8
via 10.0.0.4 only and NOT having load balancing with
> 10.0.0.5. I debugged
ip rip and found that R5 was advertising the
> 4.0.0.0/8 network with 1 hop
but I don't know why because it only has
> reachability to it via the hub.
>
>
2. when I ping one spoke from another spoke such as
>
>
> R5#ping 4.0.0.4
>
>
Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 4.0.0.4,
timeout is 2 seconds:
> .....
> Success rate is 0 percent (0/5)
>
>
>
> It
does not go through. Can anyone explain why this is happening even if
> its
load balancing half of them should go through correct?
>
>
> 1#show ip route
>
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D -
EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF
NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF
external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS
summary, L1 - IS-IS level-1, L2 - IS-IS
> level-2
> ia - IS-IS inter
area, * - candidate default, U - per-user static
> route
> o - ODR, P -
periodic downloaded static route
>
> Gateway of last resort is not set
>
> C
1.0.0.0/8 is directly connected, FastEthernet0/0
> R 4.0.0.0/8 [120/1] via
10.0.0.5, 00:00:00, Serial0/0.1
> [120/1] via 10.0.0.4,
00:00:00, Serial0/0.1
> R 5.0.0.0/8 [120/1] via 10.0.0.5, 00:00:00,
Serial0/0.1
> [120/1] via 10.0.0.4, 00:00:00, Serial0/0.1
> C
10.0.0.0/8 is directly connected, Serial0/0.1
>
>
> Here is my config
>
> R1:
>
> interface FastEthernet0/0
> ip address 1.0.0.1 255.0.0.0
> duplex auto
>
speed auto
> !
> interface Serial0/0
> no ip address
> encapsulation
frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/0.1
multipoint
> ip address 10.0.0.1 255.0.0.0
> no ip split-horizon
>
frame-relay map ip 10.0.0.4 104 broadcast
> frame-relay map ip 10.0.0.5 105
broadcast
> !
> interface Serial0/1
> no ip address
> shutdown
> !
> router
rip
> version 2
> network 1.0.0.0
> network 10.0.0.0
>
> R4:
>
> interface
Ethernet0/0
> ip address 4.0.0.4 255.0.0.0
> half-duplex
> !
> interface
Serial0/0
> ip address 10.0.0.4 255.0.0.0
> encapsulation frame-relay
>
frame-relay map ip 10.0.0.1 401 broadcast
> frame-relay map ip 10.0.0.5 401
>
no frame-relay inverse-arp
> !
> router rip
> version 2
> network 4.0.0.0
>
network 10.0.0
>
>
> R5:
> interface Ethernet0/0
> ip address 5.0.0.5
255.0.0.0
> half-duplex
> !
> interface Serial0/0
> ip address 10.0.0.5
255.0.0.0
> encapsulation frame-relay
> frame-relay map ip 10.0.0.1 501
broadcast
> frame-relay map ip 10.0.0.4 501
> no frame-relay inverse-arp
> !
> interface Ethernet0/1
> no ip address
> shutdown
> half-duplex
> !
>
interface Serial0/1
> no ip address
> shutdown
> !
> router rip
> version 2
> network 5.0.0.0
> network 10.0.0.0
>
>
>
> R1:
> R1#debug ip rip
> RIP
protocol debugging is on
> R1#
> *Oct 25 05:27:41.792: RIP: received v2 update
from 10.0.0.5 on Serial0/0.1
> *Oct 25 05:27:41.792: 1.0.0.0/8 via
0.0.0.0 in 1 hops
> *Oct 25 05:27:41.796: 4.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:27:41.796: 5.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25
05:27:41.796: 10.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:27:43.090:
RIP: sending v2 update to 224.0.0.9 via
> FastEthernet0/0 (1.0.0.1)
> *Oct 25
05:27:43.090: RIP: build update entries
> *Oct 25 05:27:43.090: 4.0.0.0/8 via
0.0.0.0, metric 1, tag 0
> *Oct 25 05:27:43.090: 5.0.0.0/8 via 0.0.0.0,
metric 1, tag 0
> *Oct 25 05:27:43.090: 10.0.0.0/8 via 0.0.0.0, metric 1, tag
0
> *Oct 25 05:27:45.386: RIP: sending v2 update to 224.0.0.9 via Serial0/0.1
> (10.0.0.1)
> *Oct 25 05:27:45.386: RIP: build update entries
> *Oct 25
05:27:45.386: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:27:45.386:
4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:27:45.386: 5.0.0.0/8 via
0.0.0.0, metric 1, tag 0
> *Oct 25 05:27:45.386 : 10.0.0.0/8 via 0.0.0.0,
metric 1, tag 0
> *Oct 25 05:27:59.125: RIP: ignored v2 update from bad source
5.0.0.5 on
> FastEthernet0/0
> *Oct 25 05:28:07.078: RIP: received v2 update
from 10.0.0.4 on Serial0/0.1
> *Oct 25 05:28:07.082: 1.0.0.0/8 via
0.0.0.0 in 1 hops
> *Oct 25 05:28:07.082: 4.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:28:07.082: 5.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25
05:28:07.082: 10.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:28:07.791:
RIP: received v2 update from 10.0.0.5 on Serial0/0.1
> *Oct 25 05:28:07.795:
1.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:28:07.795: 4.0.0.0/8 via
0.0.0.0 in 1 hops
> *Oct 25 05:28:07.795: 5.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25 05:28:07.795: 10.0.0.0/8 via 0.0.0.0 in 1 hops
> *Oct 25
05:28:09.942: RIP: sending v2 update to 224.0.0.9 via
> FastEthernet0/0
(1.0.0.1)
> *Oct 25 05:28: 09.942: RIP: build update entries
> *Oct 25
05:28:09.942: 4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:28:09.942:
5.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:28:09.942: 10.0.0.0/8 via
0.0.0.0, metric 1, tag 0
> *Oct 25 05:28:13.993: RIP: sending v2 update to
224.0.0.9 via Serial0/0.1
> (10.0.0.1)
> *Oct 25 05:28:13.993: RIP: build
update entries
> *Oct 25 05:28:13.993: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:28:13.993: 4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25
05:28:13.993: 5.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Oct 25 05:28:13.993:
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
>
>
> R4:
> R4#debug ip rip
> RIP
protocol debugging is on
> R4#
> *Mar 3 05:54:46.291: RIP: sending v2 update
to 224.0.0.9 via Ethernet0/0
> (4.0.0.4)
> *Mar 3 05:54: 46.291: RIP: build
update entries
> *Mar 3 05:54:46.291: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3 05:54:46.291: 5.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3
05:54:46.291: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3 05:55:08.907:
RIP: sending v2 update to 224.0.0.9 via Serial0/0 (
> 10.0.0.4)
> *Mar 3
05:55:08.907: RIP: build update entries
> *Mar 3 05:55:08.907: 1.0.0.0/8 via
0.0.0.0, metric 1, tag 0
> *Mar 3 05:55:08.907: 4.0.0.0/8 via 0.0.0.0,
metric 1, tag 0
> *Mar 3 05:55:08.907: 5.0.0.0/8 via 0.0.0.0, metric 1, tag
0
> *Mar 3 05:55:08.907: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3
05:55:10.131: RIP: received v2 update from 10.0.0.1 on Serial0/0
> *Mar 3
05:55:10.131: 1.0.0.0/8 via 0.0.0.0 in 1 hops
> *Mar 3 05:55:10.131:
4.0.0.0/8 via 0.0.0.0 in 1 hops
> *Mar 3 05:55:10.131: 5.0.0.0/8 via
0.0.0.0 in 1 hops
> *Mar 3 05:55:10.131: 10.0.0.0/8 via 0.0.0.0 in 1
hops
> *Mar 3 05:55:15.015: RIP: sending v2 update to 224.0.0.9 via
Ethernet0/0
> (4.0.0.4)
> *Mar 3 05:55: 15.015: RIP: build update entries
>
*Mar 3 05:55:15.015: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3
05:55:15.015: 5.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 3 05:55:15.015:
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
>
>
>
>
> R5:
> Output from debug ip
rip
> *Mar 1 05:34:06.947: RIP: sending v2 update to 224.0.0.9 via
Ethernet0/0
> (5.0.0.5)
> *Mar 1 05:34:06.947: RIP: build update entries
>
*Mar 1 05:34:06.947 : 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 1
05:34:06.947: 4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 1 05:34:06.947:
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> R5#
> *Mar 1 05:34:14.395: RIP:
ignored v2 update from bad source 1.0.0.1 on
> Ethernet0/0
> *Mar 1
05:34:14.727: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (
> 10.0.0.5)
> *Mar 1 05:34:14.727: RIP: build update entries
> *Mar 1 05:34:14.727:
1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 1 05:34:14.727: 4.0.0.0/8 via
0.0.0.0, metric 1, tag 0
> *Mar 1 05:34:14.727: 5.0.0.0/8 via 0.0.0.0,
metric 1, tag 0
> *Mar 1 05:34:14.727: 10.0.0.0/8 via 0.0.0.0, metric 1, tag
0
> *Mar 1 05:34:22.387: RIP: received v2 update from 10.0.0.1 on Serial0/0
>
*Mar 1 05:34:22.387: 1.0.0.0/8 via 0.0.0.0 in 1 hops
> *Mar 1
05:34:22.387: 4.0.0.0/8 via 0.0.0.0 in 1 hops
> *Mar 1 05:34:22.387:
5.0.0.0/8 via 0.0.0.0 in 1 hops
> *Mar 1 05:34:22.387: 10.0.0.0/8 via
0.0.0.0 in 1 hops
> R5#
> *Mar 1 05:34:35.079: RIP: sending v2 update to
224.0.0.9 via Ethernet0/0
> (5.0.0.5)
> *Mar 1 05:34:35.079: RIP: build
update entries
> *Mar 1 05:34:35.079: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 1 05:34:35.079: 4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> *Mar 1
05:34:35.079: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
>
>
>
>
>
> --
> Dane
Newman
> MCSE: Messaging, CCNP, CCEA
>
-- Dane Newman MCSE: Messaging, CCNP, CCEA
This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:32 ARST