NAT with 2 WAN links (Active & Backup)

From: iosluver@gmail.com
Date: Mon Dec 24 2007 - 15:21:02 ART


HiGS,

Can someone please shed some light on the following scenario & how it can be achieved with only the given topology. There 2 routers with a Frame-relay & PPP link between them. I want the PPP link to serve as a backup when the frame-relay link fails. I want R4 to perform NAT on its E1/0 so all packets destined to R5 are translated from the 10.10.4.0/24 subnet to an address R5 has a route for. I tried using a tunnel interface but it doesn't work. Are there restrictions with using NAT on logical interfaces (Loopback or tunnel)?

                       Frame-Relay
                      -----------
                      - -
       R4---------- - -------------R5
                      - -
                      -----------
                       PPP
    

R4
**********
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
end

interface Ethernet1/0
 ip address 10.10.4.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache cef
 no ip mroute-cache
 full-duplex
end
!

int s1/0
ip address 156.1.45.4 255.255.255.0
 encapsulation frame-relay
 no ip route-cache cef
 ip ospf hello-interval 3
 no ip mroute-cache
 frame-relay map ip 156.1.45.5 405 broadcast
 no frame-relay inverse-arp

interface Serial1/1
 ip address 156.1.0.4 255.255.255.0
 encapsulation ppp
 no ip route-cache cef
 ip ospf cost 1000
 no ip mroute-cache
 clock rate 128000

router ospf 1
 router-id 150.1.4.4
 log-adjacency-changes
 network 150.1.4.4 0.0.0.0 area 0
 network 156.1.0.0 0.0.255.255 area 0
 neighbor 156.1.45.5
!

ip nat inside source route-map TEST interface Tunnel45 overload

R5
*******

interface Loopback0
 ip address 150.1.5.5 255.255.255.0
end

interface Serial1/0
 ip address 156.1.45.5 255.255.255.0
 encapsulation frame-relay
 no ip route-cache cef
 ip ospf hello-interval 3
 ip ospf priority 0
 no ip mroute-cache
 frame-relay map ip 156.1.45.4 504 broadcast
 no frame-relay inverse-arp
end

interface Serial1/1
 ip address 156.1.0.5 255.255.255.0
 encapsulation ppp
 no ip route-cache cef
 ip ospf cost 1000
 no ip mroute-cache
end

router ospf 1
 router-id 150.1.5.5
 log-adjacency-changes
  network 150.1.5.5 0.0.0.0 area 0
 network 156.1.0.0 0.0.255.255 area 0
!

Thanks in advance.



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:32 ARST