Re: Is this a NAT and IP Accounting Question?

From: Mike Stout (michaelgstout@gmail.com)
Date: Sat Dec 15 2007 - 18:15:58 ART


Thank you for the nice lesson in ip accounting.
adding this translation over a frame-relay makes it very interesting.
!
R1#
interface Serial1/0
 ip address 163.1.12.1 255.255.255.0
 ip accounting precedence input
 rate-limit input access-group rate-limit 12 256000 32000 48000
conform-action transmit exceed-action drop
 rate-limit input access-group rate-limit 21 768000 96000 96000
conform-action transmit exceed-action drop
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 163.1.12.254 102
 frame-relay map ip 163.1.12.1 102
 frame-relay map ip 163.1.12.2 102 broadcast
 no frame-relay inverse-arp
!
access-list rate-limit 12 mask 16
access-list rate-limit 21 0

R2#
ip accounting-list 163.1.12.254 0.0.0.0
!
interface Serial1/0
 ip address 163.1.12.2 255.255.255.0
 ip accounting output-packets
 ip nat outside
 ip virtual-reassembly
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 163.1.12.1 201 broadcast
 frame-relay map ip 163.1.12.2 201
 no frame-relay inverse-arp
 service-policy output CBWFQ-P
!
ip nat inside source static tcp 204.12.1.3 23 163.1.12.254 23 extendable

On Dec 15, 2007 5:31 AM, Darren Johnson <dazza_johnson@yahoo.co.uk> wrote:

> Right, I got off my lazy ass and think I have cracked this one. Please see
> below:
>
> !
> hostname R2
> ip accounting-list 192.168.12.254 0.0.0.0
>
> !
> interface FastEthernet0/0
> ip address 192.168.12.2 255.255.255.0
> ip accounting output-packets
> ip nat outside
> speed auto
> !
> interface Serial1/0
> ip address 192.168.23.2 255.255.255.0
> ip accounting output-packets
> ip nat inside
> no fair-queue
> clock rate 128000
>
> !
> ip nat inside source static tcp 192.168.23.3 23 192.168.12.254 23
> extendable
>
>
> R2#sh ip accounting
> Source Destination Packets Bytes
> 192.168.12.254 192.168.12.1 199 50130
>
> Accounting data age is 1
> R2#sh ip nat tr
> R2#sh ip nat translations
> Pro Inside global Inside local Outside local Outside
> global
> tcp 192.168.12.254:23 192.168.23.3:23 192.168.12.1:11003
> 192.168.12.1:11003
> tcp 192.168.12.254:23 192.168.23.3:23 --- ---
> R2#
>
> As you can see, the accounting-list command is only concerned with ip
> address 192.168.12.254 with regards to accounting information. You can
> also
> see the PAT configuration which works a charm....
>
> Any comments?
>
> Dazzler
>
> -----Original Message-----
> From: Darren Johnson [mailto:dazza_johnson@yahoo.co.uk]
> Sent: 15 December 2007 10:43
> To: 'Mike Stout'; 'Phillip.McCollum@ins.com'
> Cc: 'felixnkansah@gmail.com'; 'ccielab@groupstudy.com'
> Subject: RE: Is this a NAT and IP Accounting Question?
>
> Do you have the answers to this one. I tried to configure NAT but couldn't
> get it working :-(
>
> Please put me out of my misery!
>
> Dazzler
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Mike
> Stout
> Sent: 15 December 2007 00:23
> To: Phillip.McCollum@ins.com
> Cc: felixnkansah@gmail.com; ccielab@groupstudy.com
> Subject: Re: Is this a NAT and IP Accounting Question?
>
> We should ask proctor what packets/bytes means.
>
> R1#s ip flow top
> SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP
> Bytes
> Se1/0 150.1.2.2 Local 163.1.13.1 01 0000 0800
> 300K
> 1 of 1 top talkers shown. 1 of 1 flows matched.
>
> R1#s run | b top-talker
> ip flow-top-talkers
> top 1
> sort-by bytes
> cache-timeout 120000
> match source address 150.1.2.2 255.255.255.255
> !
>
>
> On Dec 14, 2007 1:13 PM, <Phillip.McCollum@ins.com> wrote:
>
> > I would guess Q1 has to do with 'autocommand'. And agree that Q2 is IP
> > accounting.
> >
> > Phillip
> > http://blog.humanmodem.com
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Felix Nkansah
> > Sent: Friday, December 14, 2007 8:51 AM
> > To: groupstudy
> > Subject: Is this a NAT and IP Accounting Question?
> >
> > Hi,
> >
> > I need your opinion on these tasks.
> >
> > Three routers are connected in this way: R1 and R3 both connect to R2
> >
> >
> > R1 has IP address of 192.168.12.1 and connects to R2 of interface IP
> > 192.168.12.2
> >
> > R3 has IP address of 192.168.23.3 and connects to R2 of interface IP
> > 192.168.23.2
> >
> > R1 - 192.168.12.0/24 - R2 - 192.168.23.0/24 - R3
> >
> >
> > *Q1. The requirement is that, if R1 telnets to 192.168.12.254, it should
> > result in a telnet to R3.*
> > **
> > *Q2. R2 should account ONLY for the number of packets/bytes sent by host
> > 192.168.12.254.*
> >
> > What do you think? I suppose I should be able to use static NAT to solve
> > Q1
> > and IP accounting for Q2. But how do I use IP accounting to meet the
> > 'ONLY'
> > request.
> >
> > Regards,
> >
> > Felix
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
> ___________________________________________________________
> Does your mail provider give you FREE antivirus protection?
> Get Yahoo! Mail http://uk.mail.yahoo.com



This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:30 ARST