From: George Goglidze (goglidze@gmail.com)
Date: Wed Dec 12 2007 - 13:38:32 ART
Hello group,
I'm trying to resolve this problem for couple hours already,
and cannot find anything that could help.
let me describe my lab first:
I've got two 3550's which I've connected to my PC.
on ubuntu with br interfaces I bridge physical interface and tap interface.
now in dynamips I create another 2 switches(NM-16ESW), and I connect
switches all together.
(dynamips)SW1 F0/1 -> (dynamips) SW2 f0/1 <<<---trunk
(dynamips)SW1 F0/3 -> (REAL) SW3 f0/3 <<<---trunk
(dynamips)SW1 F0/15 -> (REAL) SW4 f0/21 <<<---trunk
(dynamips)SW2 F0/1 -> (dynamips) SW1 f0/1 <<<---trunk
(dynamips)SW2 F0/3 -> (REAL) SW4 f0/3 <<<---trunk
(dynamips)SW2 F0/15 -> (REAL) SW3 f0/21 <<<---trunk
(REAL)SW3 F0/3 -> (dynamips) SW1 F0/3
(REAL)SW3 (f0/11,f0/12,f0/13) Po1 -> (REAL) SW4 (f0/11,f0/12,f0/13) Po1
(REAL)SW3 F0/21 -> (dynamips) SW2 F0/15
(REAL)SW4 F0/3 -> (dynamips) SW2 F0/3
(REAL)SW4 (f0/11,f0/12,f0/13) Po1 -> (REAL) SW3 (f0/11,f0/12,f0/13) Po1
(REAL)SW4 F0/21 -> (dynamips) SW1 F0/15
---------------------------------
Ok, I hope the physical config is clear.
I've got many NIC's in computer and each of them bridged to particular TAP
interface which is linked to dynamips appropriate routers.
now the configs:
SW1:
spanning-tree vlan 10 priority 4096
spanning-tree vlan 20 priority 4096
spanning-tree vlan 30 priority 4096
spanning-tree vlan 40 priority 4096
spanning-tree vlan 55 priority 4096
spanning-tree vlan 60 priority 4096
spanning-tree vlan 100 priority 4096
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/3
switchport mode trunk
!
interface FastEthernet1/15
switchport mode trunk
!
SW2:
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/3
switchport mode trunk
!
interface FastEthernet1/15
switchport mode trunk
!
SW3:
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 4096
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
!
----------------
SW4:
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 70 priority 4096
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
!
-------------------------------------------------------------------------------------------------------
now the problem:
on sw4 I've got
debug spanning-tree events
and the output is:
02:35:58: STP: VLAN0040 new root port Po1, cost 28
02:35:58: STP: VLAN0040 Po1 -> listening
SW4#
02:36:02: STP: VLAN0040 new root port Fa0/21, cost 19
02:36:02: STP: VLAN0040 Po1 -> blocking
SW4#
02:36:15: STP: VLAN0055 new root port Po1, cost 28
02:36:15: STP: VLAN0055 Po1 -> listening
SW4#
02:36:18: STP: VLAN0055 new root port Fa0/21, cost 19
02:36:18: STP: VLAN0055 Po1 -> blocking
SW4#
02:36:22: STP: VLAN0020 new root port Po1, cost 28
02:36:22: STP: VLAN0020 Po1 -> listening
SW4#
02:36:23: STP: VLAN0040 new root port Po1, cost 28
02:36:23: STP: VLAN0040 Po1 -> listening
SW4#
02:36:25: STP: VLAN0020 new root port Fa0/21, cost 19
02:36:25: STP: VLAN0020 Po1 -> blocking
02:36:25: STP: VLAN0040 new root port Fa0/21, cost 19
02:36:25: STP: VLAN0040 Po1 -> blocking
SW4#
02:36:45: STP: VLAN0100 Po1 -> listening
02:36:46: STP: VLAN0100 new root port Fa0/3, cost 38
02:36:46: STP: VLAN0100 Fa0/3 -> listening
SW4#
02:36:46: STP: VLAN0100 new root port Po1, cost 28
02:36:46: STP: VLAN0100 Fa0/3 -> blocking
02:36:46: STP: VLAN0100 new root port Fa0/21, cost 19
02:36:46: STP: VLAN0100 Po1 -> blocking
SW4#
02:37:04: STP: VLAN0020 new root port Po1, cost 28
02:37:04: STP: VLAN0020 Po1 -> listening
SW4#
02:37:09: STP: VLAN0020 new root port Fa0/21, cost 19
02:37:09: STP: VLAN0020 Po1 -> blocking
SW4#
02:37:29: STP: VLAN0020 new root port Po1, cost 28
02:37:29: STP: VLAN0020 Po1 -> listening
on sw3 the same:
02:30:56: STP: VLAN0100 Fa0/21 -> blocking
02:31:02: STP: VLAN0030 we are the spanning tree root
02:31:02: STP: VLAN0030 heard root 4096-cc01.1abe.0003 on Fa0/3
02:31:02: supersedes 32798-0013.7ff5.f280
02:31:02: STP: VLAN0030 new root is 4096, cc01.1abe.0003 on port Fa0/3, cost
19
02:31:02: STP: VLAN0030 sent Topology Change Notice on Fa0/3
02:31:02: STP: VLAN0030 Fa0/21 -> blocking
02:31:11: STP: VLAN0055 new root port Fa0/21, cost 38
02:31:11: STP: VLAN0055 Fa0/21 -> listening
02:31:13: STP: VLAN0055 new root port Fa0/3, cost 19
02:31:13: STP: VLAN0055 Fa0/21 -> blocking
02:31:20: STP: VLAN0030 Fa0/21 -> listening
02:31:26: STP: VLAN0030 Fa0/21 -> blocking
02:31:27: STP: VLAN0020 new root port Fa0/21, cost 38
02:31:27: STP: VLAN0020 Fa0/21 -> listening
02:31:29: STP: VLAN0020 new root port Fa0/3, cost 19
02:31:29: STP: VLAN0020 Fa0/21 -> blocking
02:31:31: STP: VLAN0100 new root port Fa0/21, cost 38
02:31:31: STP: VLAN0100 Fa0/21 -> listening
02:31:32: STP: VLAN0100 new root port Fa0/3, cost 19
02:31:32: STP: VLAN0100 Fa0/21 -> blocking
02:32:09: STP: VLAN0055 new root port Fa0/21, cost 38
02:32:09: STP: VLAN0055 Fa0/21 -> listening
02:32:09: STP: VLAN0055 new root port Fa0/3, cost 19
02:32:09: STP: VLAN0055 Fa0/21 -> blocking
02:33:01: STP: VLAN0100 new root port Fa0/21, cost 38
02:33:01: STP: VLAN0100 Fa0/21 -> listening
02:33:01: STP: VLAN0100 new root port Fa0/3, cost 19
02:33:01: STP: VLAN0100 Fa0/21 -> blocking
----------------------------------------------------------------
I think for some reason real switches stop receiving BPDU's but why could
that be?
has anyone experienced that kind of behavior?
P.S. by the way the brctl is configured without STP it just forwards all
traffic.
This archive was generated by hypermail 2.1.4 : Tue Jan 01 2008 - 12:04:30 ARST