Re: OSPF Issue

From: Mounir Mohamed (mounir.ccieisa@gmail.com)
Date: Wed Nov 28 2007 - 16:28:21 ART


In such case i may use crazy solution :) i will use PPPoFR in the spokes
with one network command for OSPF, but on the hub i will use 2 different
Virtual-temple with the same IP address on, any by the default the PPP will
send you /32 address for each spoke, then i will send this address to the
sopkes, so no violation, just workaround.

Let's say R1---->R3(Hub)----->R2

------------------------R1-----------------------------------------------
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 103 ppp Virtual-Template1
 no frame-relay inverse-arp
interface Virtual-Template1
 ip address 1.1.13.1 255.255.255.0

router ospf 2
 log-adjacency-changes
 network 1.1.13.1 0.0.0.0 area 0
----------------------------R2----------------------------------
p1r2#show run int s0/0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 203 ppp Virtual-Template1
 no frame-relay inverse-arp

interface Virtual-Template1
 ip address 1.1.13.2 255.255.255.0

router ospf 2
 log-adjacency-changes
 network 1.1.13.2 0.0.0.0 area 0

---------------------R3 HUB---------------------------------
interface Serial1/0
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay interface-dlci 301 ppp Virtual-Template1
 frame-relay interface-dlci 302 ppp Virtual-Template2
 no frame-relay inverse-arp

interface Virtual-Template1
 ip address 1.1.13.3 255.255.255.0
end
!
interface Virtual-Template2
 ip address 1.1.13.3 255.255.255.0

!
router ospf 2
 log-adjacency-changes
 redistribute connected subnets ---> This is to redistribute /32 of
sopkes to be send to spokes for end to end reachability.
 network 1.1.13.3 0.0.0.0 area 0

*R3 PPP Conenctions*
p1r3#show users
    Line User Host(s) Idle Location
* 0 con 0 idle 00:00:00
  Interface User Mode Idle Peer Address
  Vi1 PPPoFR 00:00:02 1.1.13.1
  Vi2 PPPoFR 00:00:04 1.1.13.2

p1r1#show ip route os
     1.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O E2 1.1.3.0/24 [110/20] via 1.1.13.3, 00:09:13, Virtual-Access1
O E2 1.1.13.2/32 [110/20] via 1.1.13.3, 00:09:13, Virtual-Access1
O E2 1.1.37.0/24 [110/20] via 1.1.13.3, 00:09:13, Virtual-Access1
p1r1#ping 1.1.13.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.13.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/116/120

On Nov 28, 2007 5:21 PM, <iosluver@gmail.com> wrote:

> Hi GS,
>
> I wanted to get some opinions on a task I came across which behaved in a
> manner I didn't expect. Here are the details:
>
> R3 -----Frame-Relay------- R4 -----Frame-Relay-------R5
>
>
> Instructions:-
> **********************
> Use R4 as Hub.
> Use only physical interfaces on R4 & R3
> Use a sub-interface on R5
> Do not use FRAME-RELAY MAP command on R5
> Do not use any DYNAMIC layer 3 to 2 mappings on these connections
> DO not send redundant broadcast traffic to the spokes
> Configure OSPF Area 0 on the segment between R3,R4 & R5
> Do not use IP OSPF NETWORK command.
>
> Here is what I did:-
>
> R3
> ****
> interface Serial1/1
> encapsulation frame-relay
> frame-relay interface-dlci 314 ppp Virtual-Template1
>
> interface Virtual-Template1
> ip address 142.1.0.3 255.255.255.0
> ip ospf hello-interval 3
> !
> router ospf 1
> router-id 150.1.3.3
> log-adjacency-changes
> network 142.1.0.3 0.0.0.0 area 0
> network 150.1.3.3 0.0.0.0 area 0
> !
>
> R4
> ***
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> frame-relay interface-dlci 405 ppp Virtual-Template1
> frame-relay interface-dlci 413 ppp Virtual-Template1
>
> interface Virtual-Template1
> ip address 142.1.0.4 255.255.255.0
> ip ospf network point-to-multipoint
> ip ospf hello-interval 3
> !
> router ospf 1
> router-id 150.1.4.4
> log-adjacency-changes
> network 142.1.0.4 0.0.0.0 area 0
> network 150.1.4.4 0.0.0.0 area 0
>
> R5
> ***
> interface Serial1/0.504 multipoint
> frame-relay interface-dlci 504 ppp Virtual-Template1
>
> !
> interface Virtual-Template1
> ip address 142.1.0.5 255.255.255.0
> ip ospf hello-interval 3
> !
> router ospf 1
> router-id 150.1.5.5
> log-adjacency-changes
> network 142.1.0.5 0.0.0.0 area 0
> network 150.1.5.5 0.0.0.0 area 0
>
> The solution did not change the network type on R4 as its a violation of
> the one of instructions. Without that command, R4 does not ANY certain
> routes learnt from R3 to its routing table. It does however forward the LSAs
> to R3 which installs them as valid routes which can't be reached via R4. For
> obvious reasons I reduced the hello time. Some output(connected routes) were
> removed for brevity. All suggestions are welcome. I can send more debugs,
> log messages if required. Let me know what you think.
>
> R3 Routing Table
> ****************
> O 150.1.5.5/32 [110/3] via 142.1.0.4, 00:02:09, Virtual-Access2
> O 150.1.4.4/32 [110/2] via 142.1.0.4, 00:02:11, Virtual-Access2
>
> R4 Routing Table
> ****************
> Rack1R4#sh ip route
> C 150.1.4.0/24 is directly connected, Loopback0
> O 150.1.5.5/32 [110/2] via 142.1.0.5, 00:02:41, Virtual-Access3
>
>
> R5 Routing Table
> *****************
> 150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
> O 150.1.4.4/32 [110/2] via 142.1.0.4, 00:05:34, Virtual-Access2
> O IA 150.1.3.3/32 [110/3] via 142.1.0.4, 00:05:34, Virtual-Access2
>
> OSPF DATABASE - R4 - Without point-to-multipoint
> ************************************************
> Adv Router is not-reachable
> LS age: 491
> Options: (No TOS-capability, DC)
> LS Type: Router Links
> Link State ID: 150.1.3.3
> Advertising Router: 150.1.3.3
> LS Seq Number: 80000009
> Checksum: 0x63B9
> Length: 48
> Area Border Router
> Number of Links: 2
>
> OSPF DATABASE - R4 - with point-to-multipoint
> *********************************************
>
> Routing Bit Set on this LSA
> LS age: 264
> Options: (No TOS-capability, DC)
> LS Type: Router Links
> Link State ID: 150.1.3.3
> Advertising Router: 150.1.3.3
> LS Seq Number: 80000009
> Checksum: 0x63B9
> Length: 48
> Area Border Router
> Number of Links: 2
>
>
>
> Many Thanks in advance
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>

-- 
Best Regards,
Mounir Mohamed


This archive was generated by hypermail 2.1.4 : Sat Dec 01 2007 - 06:37:31 ART