From: Ernst Pelser (e.pelser@infosecureltd.com)
Date: Sun Nov 11 2007 - 16:39:47 ART
Hi Tarun
I'm glad you mentioned this. I did follow that path, well at least partially
so at least it proves my thinking methodology is okay.
Once again thanks for your response.
Regards, Ernst
_____
From: Tarun Pahuja [mailto:pahujat@gmail.com]
Sent: 11 November 2007 19:15
To: Ernst Pelser
Cc: ccielab@groupstudy.com
Subject: Re: Internetwork experts R&S Adv. Technology v4 - Router on a stick
and Native VLAN problem
In Future if you run into a problem like this where you have a switch or
switches inbetween routers and you are unable to communicate between the
routers. Try creating an temporary SVI interface on the switches on the same
vlan as the router interface to check if it is a local problem between the
switch and the router or something else.
R1-----SW1----SW2---R2
If you are unable to ping between R1 and R2 and lets say that both are in
vlan 10. I would create a temporary svi interface in vlan 10 on SW1 and SW2.
If i can not ping from SW1 svi interface to the router R1, that means the
problem is local(between SW1 and R1).
If i can not ping from SW1 svi interface to SW2 svi interface, the problem
is related to the trunk.
If I can not ping from SW2 svi to R2, the problem is local(between SW2 and
R2).
You can apply the same concept even if the routers were in different vlans,
where one of the problems could be intervlan routing if the ping did not go
through in addition to all the others I have listed in this thread.
HTH,
Tarun
On Nov 11, 2007 2:03 PM, Ernst Pelser <e.pelser@infosecureltd.com> wrote:
Tarun
AAArrrgghh! I knew this but kind of forgot. Well we learn don't we.
Thanks, I'll give that a go.
Regards, Ernst
_____
From: Tarun Pahuja [mailto:pahujat@gmail.com]
Sent: 11 November 2007 18:53
To: Ernst Pelser
Cc: ccielab@groupstudy.com
Subject: Re: Internetwork experts R&S Adv. Technology v4 - Router on a stick
and Native VLAN problem
On a standard Ethernet interfaces the native VLAN must be 1, it is a
limitation of Ethernet(10Meg) interface, do you have a router with a fast
Ethernet interface? try replicating the configuration of R4 on a router than
supports Fast Ethernet interfaces(100Meg).
On Nov 11, 2007 1:51 PM, Ernst Pelser <e.pelser@infosecureltd.com> wrote:
Hi Tarun
Thanks for your response. Please see below:
R1
Building configuration...
Current configuration : 710 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
interface Ethernet0/0
bandwidth 100000
ip address 16.0.0.1 <http://16.0.0.1/> 255.0.0.0 <http://255.0.0.0/>
full-duplex
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface Serial0/1
no ip address
shutdown
!
ip http server
ip classless
ip route 26.0.0.0 <http://26.0.0.0/> 255.0.0.0 <http://255.0.0.0/>
16.0.0.6 <http://16.0.0.6/>
!
!
alias exec c conf t
alias exec inb sho ip int brief
alias exec r show run
alias exec rb show run | beg
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
!
end
SW1
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1
!
!
ip subnet-zero
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport access vlan 16
switchport mode access
no ip address
duplex full
speed 10
!
interface FastEthernet0/2
switchport access vlan 26
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/4
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/5
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 16
switchport mode trunk
no ip address
shutdown
duplex full
speed 10
!
interface FastEthernet0/7
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/8
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/9
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/10
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/11
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/12
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport trunk native vlan 16
switchport mode trunk
no ip address
shutdown
!
interface FastEthernet0/14
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/15
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/16
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/17
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/18
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/19
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/20
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/21
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/22
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/23
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/24
switchport mode dynamic desirable
no ip address
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
no ip address
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan16
ip address 16.0.0.2 <http://16.0.0.2/> 255.0.0.0 <http://255.0.0.0/>
!
ip classless
ip http server
!
!
alias exec c conf t
alias exec inb show ip int brief
alias exec r show run
alias exec rb show run | begin
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
line vty 5 15
login
!
end
R4 (Using R4 only coz my R6 doesn't support trunking on the e0/0)
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
no ip address
full-duplex
!
interface Ethernet0/0.16
encapsulation dot1Q 16 native
ip address 16.0.0.6 <http://16.0.0.6/> 255.0.0.0 <http://255.0.0.0/>
no ip route-cache same-interface
no snmp trap link-status
!
interface Ethernet0/0.26
encapsulation dot1Q 26
ip address 26.0.0.6 <http://26.0.0.6/> 255.0.0.0 <http://255.0.0.0/>
no snmp trap link-status
!
interface Serial0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Serial0/1
no ip address
shutdown
!
ip http server
ip classless
!
!
!
!
!
!
!
alias exec c conf t
alias exec inb show ip int brief
alias exec rb show run | begin
alias exec r sh run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Regards, EP
_____
From: Tarun Pahuja [mailto:pahujat@gmail.com]
Sent: 11 November 2007 18:38
To: Ernst Pelser
Cc: ccielab@groupstudy.com
Subject: Re: Internetwork experts R&S Adv. Technology v4 - Router on a stick
and Native VLAN problem
Can you paste the config of the router and the switch please.
Tarun
On Nov 11, 2007 1:30 PM, Ernst Pelser <ernst.pelser@infosecureltd.com>
wrote:
Hi All
I'm doing the Internetnetwork experts R&S Adv. Technology v4 - Router on a
stick and Native VLAN lab (page 12). I know configuration is correct but I
can't seem to ping 16.0.0.6 <http://16.0.0.6/> from R1 (16.0.0.1
<http://16.0.0.1/> ).
When I do a debug ip packet on R1 I get the following:
*Mar 1 00:11: 31.353: IP: s=16.0.0.1 <http://16.0.0.1/> (local),
d=16.0.0.6 <http://16.0.0.6/> (Ethernet0/0), len
100, encapsulation failed.
Doing a debug arp on R4 I get:
*Mar 1 00:11:31.927: IP ARP req filtered src 16.0.0.1 <http://16.0.0.1/>
0004.c05f.9e00, dst
16.0.0.6 <http://16.0.0.6/> 0000.0000.0000 wrong cable, interface
Ethernet0/0.
I'm running the following devices:
R1 = 2611
R4 = 3620
Any suggestions in what can be causing the problem?
Thanks. EP
This archive was generated by hypermail 2.1.4 : Sat Dec 01 2007 - 06:37:29 ART