From: Con Spathas (con@spathas.net)
Date: Tue Oct 16 2007 - 01:28:19 ART
I've actually been playing with this as well over the last few days.
It's pretty cool once you get the hang of it - my only tip is if you're
spanning multiple hops - make sure you take into account the TTL remap
option. I missed it there for a bit and I lost some hair because of it!
Personally I've been using RIP v1 and v2 to do my testing. My IOS doesn't
support bcast addresses in SLA.
Ie I wanted a route from RipV1 R1 sent across to RipV1 R2 - not for
reachability - just to test that my broadcasts were making it across the
multicast cloud.
RIPv1 R1 <bcast> First hop Rtr <mcast> X number of transit rtrs <mcast>
Last hop Rtr <bcast> RIPv1 Rtr2
Then to test say Mcast->Bcast->Mcast I used
RIPv2 R1 <mcast> First hop Rtr <bcast> Last hop Rtr <mcast> RIPv2 R2
It works like a charm... just remember to tell rip to not validate the
update source!!!
gl...
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Joseph Brunner
Sent: Tuesday, 16 October 2007 00:47
To: 'Alex Steer'; ccielab@groupstudy.com
Subject: RE: ip multicast helper-map
Whoa, Nellie... this close to the lab... and thinking of running tcp with
multicast... slow down...
Lets take this one together.
Multicast traffic requires UDP, it's just impossible to syn/ack potentially
thousands of sessions from the GDA (group destination address) initial
syn...
Imagine that you send a SYN, and say, 3,900 people send back a SYN/ACK. Holy
Drunk hipster chick on your couch while your wife's a on a business trip
batman!
Now, that we agree that its going to be UDP, so no one has to send back
anything, good, lets continue.
Multicast is mostly one way traffic. The sources register with the RP, and
then they start down the source tree after spt switchover. Many many packets
flow from the source towards the destination GDA with only a few PIM packets
back. So as long as PIM keeps telling the source it wants traffic the S,G
tree will keep flowing... I am at an office where the feed has been going
for 13 Months, non-stop! Cool huh...
So lets talk about this command. In the days of wall street (I mean 1987
like the movie) these bad boy tandem computers like to send out stock quotes
on a 255.255.255.255 udp broadcast to a developer determined port #. Now a
few years later Cisco and their engineers came along and have to route this
local broadcast traffic towards other parts of the network over t-1 lines
and such, where udp broadcast is not allowed. So the command does two
things-
Convert a broadcast to a multicast (usually facing the lan where the
broadcast is going on)
Then... at the end...
Convert a multicast to a broadcast (usually facing the lan where we want to
send the broadcast back as a directed broadcast)
VPN_1(config-if)#ip multicast helper-map ?
A.B.C.D IP multicast address
broadcast Broadcast address
I have seen this used to convert a multicast to a directed broadcast and
then back to a multicast...
Its used with UDP traffic and the "ip forward-protocol udp XXXX" is used to
make sure the traffic is processed switched, a requirement for conversion...
Another cool trick is to convert unicast to a multicast... for this I run
"Ip nat outside", where we nat destination udp unicast address to a
multicast GDA, and dump it on the lan... cool huh?
Check out the doc cd very very carefully on how to implement this bad boy...
http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cr/himc_r
/mlt_i1h.htm#wp1134745
If you get this on a lab, you should know all intricacies of this, including
remembering that you MUST configure ip directed-broadcast to allow the
conversion to finish back to broadcast at the receiving end.
So print it out, love it, learn it, take it with you in your dreams... (I
had a rip v2 dream the other night... scary huh?)
-Joe
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Alex
Steer
Sent: Monday, October 15, 2007 3:13 PM
To: ccielab@groupstudy.com
Subject: ip multicast helper-map
Hi,
I'm having trouble with this, can anyone help me please.
I have 2 routers separated by a ppp link, I'm not saying it definitely
doesn't work but to be honest I just don't know. Can any suggest a good way
to troubleshoot this? Is it worth adding TCP to the access-lists and
telnetting to port 5575?
Here are the configs...
I've added show ip mroute output at the bottom though again is this even any
use in this scenario (Incoming interface: Null)?
As always, thank you in advance
Alex
================First hop router====================
ip multicast-routing
ip forward-protocol udp 5575
ip access-list extended helper-map
permit udp any host 255.255.255.255 eq 5575
interface Ethernet1/0
ip address 129.1.3.133 255.255.255.128
ip pim dense-mode
ip multicast helper-map broadcast 233.33.33.33 helper-map
interface Serial1/1
ip address 129.1.23.3 255.255.255.0
ip pim neighbor-filter pimfilter
ip pim dense-mode
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.1.0.1), 00:37:52/00:02:02, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/1, Forward/Dense, 00:37:52/00:00:00
Serial1/0, Forward/Dense, 00:37:52/00:00:00
(*, 224.0.1.40), 01:54:10/00:02:44, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/1, Forward/Dense, 00:39:53/00:00:00
Ethernet0/0, Forward/Dense, 01:54:11/00:00:00
Serial1/0, Forward/Dense, 01:53:39/00:00:00
Last hop router.
ip multicast-routing
ip forward-protocol udp 5575
ip access-list extended source
permit udp 129.1.3.128 0.0.0.127 any eq 5575
interface FastEthernet0
ip address 129.1.17.1 255.255.255.0
ip directed-broadcast
ip pim dense-mode
interface Serial1
ip address 129.1.13.1 255.255.255.0
ip pim dense-mode
ip multicast helper-map 233.33.33.33 129.1.17.255 source
encapsulation ppp
(*, 233.33.33.33), 00:30:05/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1, Forward/Dense, 00:30:05/00:00:00
(*, 224.0.1.40), 01:54:17/00:02:32, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0, Forward/Dense, 01:54:17/00:00:00
Serial1, Forward/Dense, 01:54:12/00:00:00
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:15 ART