From: shiran guez (shiranp3@gmail.com)
Date: Mon Oct 15 2007 - 04:42:46 ART
Hi
this is a task taken from IEWB
R4
|
\
/
|
R5
R4 connected via Serial link to R5
R4#sh run int ser1/1
Building configuration...
Current configuration : 121 bytes
!
interface Serial1/1
ip address negotiated
encapsulation ppp
no peer default ip address
serial restart-delay 0
end
R5#
ip dhcp-server 132.20.53.3
!
interface Serial1/1
ip address 132.20.54.5 255.255.255.0
encapsulation ppp
peer default ip address dhcp
serial restart-delay 0
end
R5#ping 132.20.53.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.20.53.3, timeout is 2 seconds:
!!!!!
R3 is the DHCP Server as you can see the above ping there is no reachablilty
problem
ip dhcp excluded-address 132.20.54.1 132.20.54.3
ip dhcp excluded-address 132.20.54.5 132.20.54.254
!
ip dhcp pool R4
network 132.20.54.0 255.255.255.0
R3#
*Mar 1 12:24:31.108: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:31.112: DHCPD: Allocate an address without class information (
132.20.54.0)
R3#
*Mar 1 12:24:33.116: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:33.120: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
*Mar 1 12:24:33.656: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:33.660: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:33.664: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#
*Mar 1 12:24:34.540: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:34.540: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:34.540: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#
*Mar 1 12:24:37.700: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:37.700: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:37.700: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
*Mar 1 12:24:38.624: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
R3#
*Mar 1 12:24:38.628: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:38.632: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#
*Mar 1 12:24:41.672: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:41.676: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:41.680: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#
*Mar 1 12:24:42.740: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:42.744: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:42.748: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#
*Mar 1 12:24:46.660: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
*Mar 1 12:24:46.664: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:46.668: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
*Mar 1 12:24:46.876: DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31through
relay
132.20.54.5.
R3#
*Mar 1 12:24:46.880: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d31.3332.2e32.302e.3534.2e35.2d53.6572.6961.6c31.2f31 (
132.20.54.4).
*Mar 1 12:24:46.884: DHCPD: unicasting BOOTREPLY for client
cc04.11a1.0000to relay
132.20.54.5.
R3#un all
R4 as you can see is not reciving that address:
*Mar 1 12:34:24.264: Se1/1 IPCP: Timeout: State ACKsent
*Mar 1 12:34:24.268: Se1/1 IPCP: O CONFREQ [ACKsent] id 9 len 10
*Mar 1 12:34:24.268: Se1/1 IPCP: *Address 0.0.0.0* (0x030600000000)
*Mar 1 12:34:24.344: Se1/1 IPCP: I CONFREQ [ACKsent] id 9 len 10
*Mar 1 12:34:24.348: Se1/1 IPCP: Address 132.20.54.5 (0x030684143605)
*Mar 1 12:34:24.352: Se1/1 IPCP: O CONFACK [ACKsent] id 9 len 10
*Mar 1 12:34:24.352: Se1/1 IPCP: Address 132.20.54.5 (0x030684143605)
*Mar 1 12:34:24.648: Se1/1 IPCP: I CONFREJ [ACKsent] id 7 len 10
*Mar 1 12:34:24.652: Se1/1 IPCP: *Address 0.0.0.0* (0x030600000000)
*Mar 1 12:34:24.652: Se1/1 IPCP: ID 7 didn't match 9, discarding packet
R4(config)#
*Mar 1 12:34:26.252: Se1/1 IPCP: I CONFREQ [ACKsent] id 10 len 10
*Mar 1 12:34:26.252: Se1/1 IPCP: Address 132.20.54.5 (0x030684143605)
*Mar 1 12:34:26.256: Se1/1 IPCP: O CONFACK [ACKsent] id 10 len 10
*Mar 1 12:34:26.260: Se1/1 IPCP: Address 132.20.54.5 (0x030684143605)
*Mar 1 12:34:26.280: Se1/1 IPCP: Timeout: State ACKsent
*Mar 1 12:34:26.284: Se1/1 IPCP: O CONFREQ [ACKsent] id 10 len 10
*Mar 1 12:34:26.284: Se1/1 IPCP: *Address 0.0.0.0* (0x030600000000)
R4(config)#
*Mar 1 12:34:28.296: Se1/1 IPCP: Timeout: State ACKsent
*Mar 1 12:34:28.300: Se1/1 IPCP: State is ACKsent
*Mar 1 12:34:28.784: Se1/1 IPCP: I CONFREJ [ACKsent] id 9 len 10
*Mar 1 12:34:28.788: Se1/1 IPCP: *Address 0.0.0.0* (0x030600000000)
*Mar 1 12:34:28.788: Se1/1 IPCP: ID 9 didn't match 10, discarding packe
R3 allocated the correct address:
R3#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
132.20.54.4 0063.6973.636f.2d31. Mar 01 2002 12:31 PM
Automatic
3332.2e32.302e.3534.
2e35.2d53.6572.6961.
6c31.2f31
-- Shiran Guez MCSE CCNP NCE1 http://cciep3.blogspot.com http://www.linkedin.com/in/cciep3
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:14 ART