From: shiran guez (shiranp3@gmail.com)
Date: Thu Oct 04 2007 - 07:02:49 ART
Hi
I have tried to work with the following guid to create a basic IP Mobile
Network
am I doing somthing wrong as it is not working
HA R4
========
!
interface Ethernet0/1
ip address 130.1.146.4 255.255.255.0
ip irdp
ip mobile arp
half-duplex
router mobile
!
router eigrp 100
redistribute mobile metric 1 1 1 1 1
network 130.1.146.4 0.0.0.0
no auto-summary
!
no ip http server
no ip http secure-server
!
!
ip mobile home-agent broadcast
ip mobile virtual-network 130.1.20.0 255.255.255.0
FA R6
=======
interface Loopback20 < that interface I have set to be as a visitor
ip address 130.1.20.6 255.255.255.255
!
interface FastEthernet0/0
ip address 130.1.146.6 255.255.255.0
ip irdp
ip mobile arp
ip mobile foreign-service
duplex auto
speed auto
!
router mobile
!
router eigrp 100
network 130.1.146.6 0.0.0.0
no auto-summary
!
!
!
ip mobile foreign-agent care-of FastEthernet0/0
!
#sh ip route eigrp
130.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
D EX 130.1.1.0/24 [170/28160] via 130.1.146.1, 00:10:47, FastEthernet0/0
D EX 130.1.0.0/24 [170/2172416] via 130.1.146.1, 00:10:47,
FastEthernet0/0
D EX 130.1.20.0/24
[170/2560002816] via 130.1.146.4, 00:10:47, FastEthernet0/0
150.1.0.0/24 is subnetted, 2 subnets
D EX 150.1.1.0 [170/156160] via 130.1.146.1, 00:10:47, FastEthernet0/0
!
R6#debug ip packet detail
IP packet debugging is on (detailed)
R6#ping 146.1.146.4 source 130.1.20.6 repeat 1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 146.1.146.4, timeout is 2 seconds:
Packet sent with a source address of 130.1.20.6
*Mar 1 01:35:25.347: IP: s=130.1.146.6 (local),
d=224.0.0.10(FastEthernet0/0), len 60, sending broad/multicast,
proto=88
*Mar 1 01:35:26.267: IP: s=130.1.146.1 (FastEthernet0/0), d=224.0.0.10, len
60, rcvd 2, proto=88
*Mar 1 01:35:26.331: IP: s=130.1.20.6 (local), d=146.1.146.4, len
100, *unroutable
<<WHY?*
*Mar 1 01:35:26.331: ICMP type=8, code=0
*Mar 1 01:35:26.335: IP: s=130.1.146.4 (FastEthernet0/0), d=224.0.0.10, len
60, rcvd 2, proto=88.
R6#sh ip mobile visitor
*Mobile Visitor List:
Total 0 << WHY?*
you can see that I do see the HA router R4 on the arp and I do have
connectivety to him it is just the IP Mobile not working as it should or I
am doing something wrong here (more likely)
R6#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 130.1.146.1 13 cc00.102c.0000 ARPA FastEthernet0/0
Internet 130.1.146.4 13 cc03.1031.0001 ARPA FastEthernet0/0
Internet 130.1.146.6 - cc05.1034.0000 ARPA FastEthernet0/0
R6#ping 130.1.146.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 130.1.146.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/49/68 ms
R6#
-- Shiran Guez MCSE CCNP NCE1 http://cciep3.blogspot.com http://www.linkedin.com/in/cciep3
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:12 ART