From: Ronnie Angello (ronnie.angello@gmail.com)
Date: Mon Oct 01 2007 - 12:37:41 ART
I actually made a note to myself on this as I was preparing for the lab back
in March...
-Looks for routes injected into bgp by the **redistribute** and **network**
commands on that router.
-When redistribution would normally inject subnets of a classful network,
inject only the summary.
-When the network command lists a classful network number **with no mask**
inject the classful network if at least one subnet of the classful network
is in the routing table.
##redistribution example##
interface Loopback91
ip address 9.9.1.1 255.255.255.0
!
interface Loopback92
ip address 9.9.2.1 255.255.255.0
!
interface Loopback93
ip address 9.9.3.1 255.255.255.0
!
interface Loopback94
ip address 9.9.4.1 255.255.255.0
!
interface Loopback95
ip address 9.9.5.1 255.255.255.0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
redistribute connected route-map connected->bgp
auto-summary
!
route-map connected->bgp permit 10
match interface Loopback91 Loopback92 Loopback93 Loopback94 Loopback95
CAT2#s ip bgp
BGP table version is 2, local router ID is 112.10.112.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 9.0.0.0 0.0.0.0 0 32768 ?
CAT2#
##network command example##
router bgp 100
no synchronization
bgp log-neighbor-changes
network 9.0.0.0
network 9.9.1.0 mask 255.255.255.0
network 9.9.2.0 mask 255.255.255.0
network 9.9.3.0 mask 255.255.255.0
network 9.9.4.0 mask 255.255.255.0
network 9.9.5.0 mask 255.255.255.0
auto-summary
CAT2#s ip bgp
BGP table version is 8, local router ID is 112.10.112.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 9.0.0.0 0.0.0.0 0 32768 i
*> 9.9.1.0/24 0.0.0.0 0 32768 i
*> 9.9.2.0/24 0.0.0.0 0 32768 i
*> 9.9.3.0/24 0.0.0.0 0 32768 i
*> 9.9.4.0/24 0.0.0.0 0 32768 i
*> 9.9.5.0/24 0.0.0.0 0 32768 i
CAT2#
On 9/30/07, Julio Carrasco <julio.carrasco@ya.com> wrote:
>
> Hi all,
>
> Hi been reading about auto-summarization in BGP, trying to figure out how
> exactly works the auto summarization, what I found out is that it works
> like
> any other auto.summarization, but only on the networks that we
> redistribute or
> announce by a network command in the router where we activate the
> auto-summarization.
>
> Could please anyone say me if I am right or not ??
>
> Best regards,
> Julio.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
-- Ronald Angello CCIE #17846
This archive was generated by hypermail 2.1.4 : Fri Nov 16 2007 - 13:11:11 ART