Re: GTS : Can be enabled only at the first level

From: Ben (bmunyao@gmail.com)
Date: Fri Sep 28 2007 - 13:19:13 ART


Hi,

Here is one way of doing it that I can think of:

Rack1R1#sh access-l
Extended IP access list TO_R4
    10 permit ip any host 192.168.2.4
Rack1R1#

Rack1R1#sh run class
Building configuration...

Current configuration : 147 bytes
!
class-map match-all VOICE
 match protocol rtp audio
class-map match-all TO_R4
 match access-group name TO_R4
 match not class-map VOICE

Rack1R1#sh run policy
Building configuration...

Current configuration : 138 bytes
!
policy-map SHAPE
 class TO_R4
  shape average 7000000 700000
!
end

Rack1R1#sh run int s1/0.1
Building configuration...

Current configuration : 144 bytes
!
interface Serial1/0.1 point-to-point
 ip address 10.1.13.1 255.255.255.0
 frame-relay interface-dlci 103
 service-policy output SHAPE
end

Rack1R1#sh policy-map int s1/0.1

 Serial1/0.1

  Service-policy output: SHAPE

    Class-map: TO_R4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name TO_R4
      Match: not class-map match-all VOICE
        Match: protocol rtp audio
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
          7000000/7000000 175000 700000 700000 100 87500

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no

    Class-map: class-default (match-any)
      3 packets, 963 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
Rack1R1#

Perhaps someone else has an alternative solution. Lets hope others will also
provide input.

Sincerely

Ben

On 9/28/07, ISolveSystems <support@isolvesystems.com> wrote:
>
> Question asks to configure Genric Traffic Shaping for all traffic other
> than
> the voice traffic destined for 200.0.0.4. The bit-rate that's allowed for
> this traff is 7mbps with a sustained and excess burst size of 700kbps.
>
> Below is my config. Any idea why "GTS : Can be enabled only at the first
> level"?
>
> Router(config-if)#service-policy output GTS
> GTS : Can be enabled only at the first level
>
> ip access-list extended TO_R4
> permit ip any host 200.0.0.4
>
> class-map match-all TO_R4
> match access-group name TO_R4
> class-map match-all VOICE
> match protocol rtp
>
> policy-map TO_R4
> class TO_R4
> shape average 7000000
> policy-map GTS
> class VOICE
> class class-default
> service-policy TO_R4
>
> Thanks.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:16 ART