RE: QOS WRED DSCP-BASED CONFIGURATION

From: Joseph Brunner (joe@affirmedsystems.com)
Date: Thu Sep 27 2007 - 00:01:12 ART


Actually voip payload is udp (RTP), so we don't use wred with udp.

That would PHUCK up phone calls for all your phreakerz out there...

For voip we llq "priority percent xx" or "priority xxx" and at the same time
we use a parent policy to ensure ALL traffic is subject to "backpressure"
meaning the qos child policy LEAKS out what it wants from the "backpressure"
created by the parent policy"

Check out this config...

This gives voip 360kbps on a T-1 line... it's my standard client t-1 office
router qos config...

!
class-map match-any scavenger_mark
 match protocol fasttrack
 match protocol edonkey
 match protocol bitttorrent
 match protocol gnutella
 match protocol nutellaudp
 match access-group name junktraffic
!
class-map match-all scavenger
match dscp cs1
!

class-map match-any bulk_mark
 match protocol exchange
 match protocol ftp
 match protocol pop3
 match protocol smtp
!
class-map match-all bulk
match dscp af11
!
!
class-map match-any manage_mark
 match protocol dhcp
 match protocol dns
 match protocol kerberos
 match protocol snmp
 match protocol syslog
!
class-map match-all manage
match dscp af21
!
!
class-map match-any voicesignal_mark
 match protocol h323
 match protocol rtcp
 match protocol sip
!
!
class-map match-all voicesignal
match dscp cs3
!
class-map match-any transactional_mark
 match protocol citrix
 match protocol pcanywhere
 match protocol secure-telnet
 match protocol sqlnet
 match protocol sqlserver
 match protocol ssh
 match protocol telnet
 match protocol tsrvrdp
!
!
class-map match-all transactional
match dscp af41
!
!
class-map match-any video_mark
 match protocol rtp video
 match protocol cuseeme
 match protocol netshow
 match protocol rtsp
 match protocol streamwork
 match protocol vdolive
!
!
class-map match-all video
match dscp af43
!
!
class-map match-any voicebearer_mark
 match protocol rtp audio
 match access-group 118
!
!
class-map match-all voicebearer
match dscp ef
!
!
policy-map qos_marking_policy
!
class voicebearer_mark
  set dscp ef
!
class voicesignal_mark
set dscp cs3
!
class video_mark
set dscp af43
!
class transactional_mark
set dscp af41
!
class manage_mark
set dscp af21
!
class bulk_mark
set dscp af11
!
!
!
!
policy-map Pol-F0/0-out-child
 class voicebearer
  priority 360
!
 class voicesignal
  bandwidth 72
!
class video
bandwidth 128
!
 class transactional
  bandwidth 360

 class manage
 bandwidth 72
!
class bulk
bandwidth 72
!
 class scavenger
   drop
!
 class class-default
  fair-queue
!
!
policy-map Pol-F0/0-out-parent
 class class-default
  shape average 1400000
service-policy Pol-F0/0-out-child
!
!
!
policy-map Pol-F0/1-out-child
 class voicebearer
  priority 360
!
 class voicesignal
  bandwidth 72
!
class video
bandwidth 128
!
 class transactional
  bandwidth 360

 class manage
 bandwidth 72
!
class bulk
bandwidth 72
!
 class scavenger
   drop
!
 class class-default
  fair-queue
!
!
policy-map Pol-F0/1-out-parent
 class class-default
  shape average 1400000
  service-policy Pol-F0/1-out-child

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Carlos Trujillo Jimenez
Sent: Wednesday, September 26, 2007 10:26 PM
To: ccielab@groupstudy.com
Subject: QOS WRED DSCP-BASED CONFIGURATION

Please, If someone please can help me confirming if this configuration will
or will not work according to the specifications:

I want so that voip traffic is less likely to be dropped than http traffic
if the output interface becomes congested.

So I perform first classification and marking at the ingress interface.

and the random detect based in the classified packets at the egress
interface.

class-map match-all VOIP
  match ip rtp 16384 16383
class-map match-all MORE-LIKELY-DROP
  match ip dscp af13
class-map match-all HTTP
  match protocol http
class-map match-all LESS-LIKELY-DROP
  match ip dscp ef
!
!
policy-map DROP-IF-CONGESTED
  class LESS-LIKELY-DROP
   bandwidth percent 50
   random-detect dscp-based
  class MORE-LIKELY-DROP
   bandwidth percent 25
   random-detect dscp-based
policy-map CLASSIFICATION-MARKING
  class VOIP
   set ip dscp ef
  class HTTP
   set ip dscp af13

interface FastEthernet0/0
ip address 128.1.5.5 255.255.255.0
service-policy input CLASSIFICATION-MARKING

interface Serial0/0
ip address 128.1.125.5 255.255.255.0
service-policy output DROP-IF-CONGESTED

verifrication:

p4r5#show policy-map interface
FastEthernet0/0

  Service-policy input: CLASSIFICATION-MARKING

    Class-map: VOIP (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip rtp 16384 16383
      QoS Set
        dscp ef
          Packets marked 0

    Class-map: HTTP (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol http
      QoS Set
        dscp af13
          Packets marked 0

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
Serial0/0

  Service-policy output: DROP-IF-CONGESTED

    Class-map: LESS-LIKELY-DROP (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef
      Queueing
        Output Queue: Conversation 265
        Bandwidth 50 (%)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
         exponential weight: 9
         mean queue depth: 0

dscp Transmitted Random drop Tail drop Minimum Maximum
Mark
          pkts/bytes pkts/bytes pkts/bytes thresh thresh
prob
af11 0/0 0/0 0/0 32 40
1/10
af12 0/0 0/0 0/0 28 40
1/10
af13 0/0 0/0 0/0 24 40
1/10
af21 0/0 0/0 0/0 32 40
1/10
af22 0/0 0/0 0/0 28 40
1/10
af23 0/0 0/0 0/0 24 40
1/10
af31 0/0 0/0 0/0 32 40
1/10
af32 0/0 0/0 0/0 28 40
1/10
af33 0/0 0/0 0/0 24 40
1/10
af41 0/0 0/0 0/0 32 40
1/10
af42 0/0 0/0 0/0 28 40
1/10
af43 0/0 0/0 0/0 24 40
1/10
cs1 0/0 0/0 0/0 22 40
1/10
cs2 0/0 0/0 0/0 24 40
1/10
cs3 0/0 0/0 0/0 26 40
1/10
cs4 0/0 0/0 0/0 28 40
1/10
cs5 0/0 0/0 0/0 30 40
1/10
cs6 0/0 0/0 0/0 32 40
1/10
cs7 0/0 0/0 0/0 34 40
1/10
ef 0/0 0/0 0/0 36 40
1/10
rsvp 0/0 0/0 0/0 36 40
1/10
default 0/0 0/0 0/0 20 40
1/10

    Class-map: MORE-LIKELY-DROP (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp af13
      Queueing
        Output Queue: Conversation 266
        Bandwidth 25 (%)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
         exponential weight: 9
         mean queue depth: 0

p4r5#



This archive was generated by hypermail 2.1.4 : Sat Oct 06 2007 - 12:01:16 ART