Re: Metric to redistribute in EIGRP ....

From: Toh Soon, Lim (tohsoon28@gmail.com)
Date: Thu Aug 30 2007 - 05:49:11 ART


Hi Herbert,

I have labbed it to verify the following points:

(1) Redistributing a connected network (non-EIGRP) into EIGRP without
setting seed metric.
(2) Redistributing a static route (pointing to a next-hop out a non-EIGRP
interface) into EIGRP without setting seed metric.
(3) Redistributing a static route (pointing to a non-EIGRP interface) into
EIGRP without setting seed metric.

Below is my scenario:

R6 (s0/1/0)----------------(s0/0/0) R9 (s0/1/0)

R6 config
---------
!
interface Serial0/1/0
 description *** Connection to R9 s0/0/0 ***
 bandwidth 128
 ip address 172.31.69.1 255.255.255.252
!
router eigrp 100
 network 172.31.69.1 0.0.0.0
 no auto-summary
!

R9 config
---------
!
interface Serial0/0/0
 description *** Connection to R6 s0/1/0 ***
 bandwidth 128
 ip address 172.31.69.2 255.255.255.252
!
interface Serial0/1/0
 description *** Non-EIGRP interface ***
 bandwidth 64
 ip address 172.31.69.5 255.255.255.252
!
router eigrp 100
 redistribute connected route-map TEST
 redistribute static
 network 172.31.69.2 0.0.0.0
 no auto-summary
!
ip route 100.100.100.0 255.255.255.0 172.31.69.6
ip route 101.101.101.0 255.255.255.0 Serial0/1/0
!
route-map TEST permit 10
 match interface Serial0/1/0
!

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Verifications
-------------
R6#sh int s 0/1/0
Serial0/1/0 is up, line protocol is up
  Internet address is 172.31.69.1/30
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

R9#sh int s 0/0/0
Serial0/0/0 is up, line protocol is up
  Internet address is 172.31.69.2/30
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
R9#sh int s 0/1/0
Serial0/1/0 is up, line protocol is up
  Internet address is 172.31.69.5/30
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

R6#sh ip ro ei
     100.0.0.0/24 is subnetted, 1 subnets
D EX 100.100.100.0 [170/41024000] via 172.31.69.2, 00:09:07, Serial0/1/0
     101.0.0.0/24 is subnetted, 1 subnets
D EX 101.101.101.0 [170/41024000] via 172.31.69.2, 00:09:07, Serial0/1/0
     172.31.0.0/16 is variably subnetted, 10 subnets, 5 masks
D EX 172.31.69.4/30 [170/41024000] via 172.31.69.2, 00:11:20, Serial0/1/0

Note: Successful redistributions without specifying default metrics. The
composite metrics are all the same, i.e. 41024000

R6#sh ip ei to 100.100.100.0 255.255.255.0
IP-EIGRP (AS 100): Topology entry for 100.100.100.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 41024000
  Routing Descriptor Blocks:
  172.31.69.2 (Serial0/1/0), from 172.31.69.2, Send flag is 0x0
      Composite metric is (41024000/40512000), Route is External
      Vector metric:
        Minimum bandwidth is 64 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 210.9.9.9
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)

R6#sh ip ei to 101.101.101.0 255.255.255.0
IP-EIGRP (AS 100): Topology entry for 101.101.101.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 41024000
  Routing Descriptor Blocks:
  172.31.69.2 (Serial0/1/0), from 172.31.69.2, Send flag is 0x0
      Composite metric is (41024000/40512000), Route is External
      Vector metric:
        Minimum bandwidth is 64 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 210.9.9.9
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)

R6#sh ip ei to 172.31.69.4 255.255.255.252
IP-EIGRP (AS 100): Topology entry for 172.31.69.4/30
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 41024000
  Routing Descriptor Blocks:
  172.31.69.2 (Serial0/1/0), from 172.31.69.2, Send flag is 0x0
      Composite metric is (41024000/40512000), Route is External
      Vector metric:
        Minimum bandwidth is 64 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 210.9.9.9
        AS number of route is 0
        External protocol is Connected, external metric is 0
        Administrator tag is 0 (0x00000000)

Notice that all 3 redistributed routes have the same min. bandwidth (64K)
and cumulative delay (40000 microsec) from the perspective of R6. Their
Advertised Distance is 40512000.

The bandwidth value of 64K and delay value of 20000 usec of interface s0/1/0
are used to derive the AD value, as follows:

AD = 256 * [ [10power7 / 64] + [20000 / 10] ] = 40512000

If you see it differently, let me know. I may have overlooked something too
:-)

Thank you.

B.Rgds,
Lim TS

On 8/29/07, Herbert Maosa <asawilunda@googlemail.com> wrote:
>
> This may be worth confirming in a lab. From my understanding, this is only
> true if the static route is pointing to an interface, and the network of
> that interface is enabled for EIGRP. Otherwise if the static route is
> pointing to an IP next hop, I believe we need to set the metric for
> redistribution.
>
> Will need to re-confirm, so I wont bet.
>
> Herbert.
>
>
> On 8/29/07, Toh Soon, Lim <tohsoon28@gmail.com > wrote:
> >
> > Hi All,
> >
> > Just to add on, redistributing static routes into EIGRP also does not
> > require setting the seed metric. If I remember it correctly, the bandwidth &
> > delay values of the egress interface of the static route is considered in
> > the metric calculation, just like connected routes being redistributed into
> > EIGRP.
> >
> > I typically set the values for Reliability, Load, and MTU in the seed
> > metric to 1 1 1 respectively because they are not used in the metric
> > calculation by default anyway. Anyone can comment on this?
> >
> >
> > Thank you.
> >
> > B.Rgds,
> > Lim TS
> >
> >
> > On 8/7/07, Antonio Soares <amsoares@netcabo.pt > wrote:
> > >
> > > When redistributing connected interfaces into EIGRP, you don't need to
> > >
> > > specify the metric.
> > >
> > >
> > > Regards,
> > >
> > > Antonio Soares
> > > CCIE #18473, CCNP, CCIP
> > >
> > >
> > >
> > >
> > > _____
> > >
> > > From: Herbert Maosa [mailto: asawilunda@googlemail.com]
> > > Sent: terga-feira, 7 de Agosto de 2007 14:25
> > > To: Antonio Soares
> > > Cc: ccie1101; Cisco certification
> > > Subject: Re: Metric to redistribute in EIGRP ....
> > >
> > >
> > > Antonio,
> > >
> > > I believe with EIGRP redistribution we can not do away with NOT
> > > setting the
> > > metric ? I believe redistribution fails complete;ly if no metrics are
> > > not
> > > set for EIGRP ( as well as RIP ) unlike OSPF,IS-IS and BGP that have
> > > default
> > > seed metrics ?
> > >
> > > One common practice is to do a " show interface " on outgoing
> > > interface, and
> > > use the values you get on that interface for BW,DLY,MTU etc.
> > >
> > >
> > >
> > > Herbert.
> > >
> > >
> > > On 8/7/07, Antonio Soares <amsoares@netcabo.pt> wrote:
> > >
> > > In the particular case you are redistruting connected interfaces to
> > > eigrp,
> > > and imo, the best is not to choose any metrics. This way eigrp will
> > > use the
> > > interface original settings (bw, dly,...) to calculate the metric.
> > >
> > > Regarding your question, you can use either option depending if you
> > > have/have not some conditions and/or restrictions. But be carefull
> > > when you
> > > are using method #2. Since the resulting metric is very high
> > > (2560025856),
> > > it's easy to create a routing loop if additional redistributions are
> > > made
> > > inside your IGP domain.
> > >
> > >
> > > Regards,
> > >
> > > Antonio Soares
> > > CCIE #18473, CCNP, CCIP
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto: nobody@groupstudy.com] On Behalf
> > > Of
> > > ccie1101
> > > Sent: terga-feira, 7 de Agosto de 2007 11:26
> > > To: Cisco certification
> > > Subject: Re : Metric to redistribute in EIGRP ....
> > >
> > > Hi,
> > > I have some doubt abt. the metric used when we redistribute
> > > protocols
> > > into EIGRP. I come across materials that says
> > >
> > > ie)
> > > 1) router eigrp 100
> > > redistribute connected metric *10000 100 255 1 1500 *route-map
> > > CONNECTED-EIGRP
> > >
> > > and also
> > >
> > > 2) router eigrp 100 redistribute connected metric *1 1 1 1 1
> > > *route-map
> > >
> > > CONNECTED-EIGRP
> > >
> > > Does this mean if the questions do not specify the* preferred metrics*
> > > we
> > > can just do like in *2) *above and use any arbitrary values ?
> > >
> > > Pls advice,
> > >
> > > - ccie1101 -
> > >
> > > _______________________________________________________________________
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > > _______________________________________________________________________
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > >
> > >
> > >
> > > --
> > > Kindest regards,
> > > hm
> > >
> > > _______________________________________________________________________
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> >
> >
>
>
> --
> Kindest regards,
> hm



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:13 ART