Issue with BGP "neighbor default-originate route-map" command

From: Toh Soon, Lim (tohsoon28@gmail.com)
Date: Sun Aug 19 2007 - 22:30:12 ART


Hi All,

I'm trying the BGP "neighbor default-originate route-map" command. R7 will
inject route 0.0.0.0 to R8 only if there is a route to 140.10.76.0/24. The
140.10.76.0/24 happens to be R7's connected Fa0/0 interface.
!
router bgp 700
 neighbor 140.10.78.8 remote-as 800
 neighbor 140.10.78.8 description *** R8 in AS 800 ***
 neighbor 140.10.78.8 default-originate route-map DEFtoR8
!

Method 1
--------
route-map DEFtoR8 permit 10
 match ip address 1
!
access-list 1 permit 140.10.76.0

Method 2
--------
route-map DEFtoR8 permit 10
 match ip address 10
!
access-list 10 permit 140.10.76.0 0.0.0.255

Method 3
--------
route-map DEFtoR8 permit 10
 match ip address 100
!
access-list 100 permit ip host 140.10.76.0 host 255.255.255.0

Method 4
--------
route-map DEFtoR8 permit 10
 match ip address prefix-list TEST
!
ip prefix-list TEST seq 5 permit 140.10.76.0/24

Only Methods 2 & 4 successfully source a BGP 0.0.0.0 route to R8 when Fa0/0
is up on R7. Can anyone explain why Methods 1 & 3 do not work? The ACL1 in
Method 1 is the usual way I use to match prefixes and I expect it to work in
this scenario.

Also, can you enlighten me the difference between ACL1 and ACL10 above in
terms of matching prefix 140.10.76.0/24? I was under the impression that
ACL1 matches the prefix address 140.10.76.0 exactly because the wildcard
mask is 0.0.0.0. I guess I'm wrong here.

Thank you.

B.Rgds,
Lim TS



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:12 ART