Redistribute connected network

From: Sergey (public@svlp.net)
Date: Fri Aug 17 2007 - 08:34:34 ART


Hello

suppose we have task

3.4 Advertise the Loopback0 networks of R5 into OSPF and use route-map for it
and also we have task
7.8 Redistribute EIGRP into OSPF at R5

my config is

interface Loopback0
 ip address 55.55.55.55 255.255.255.0

interface Serial1/0.100 point-to-point
 ip address 192.168.100.4 255.255.255.0

interface Serial1/0.200 point-to-point
 ip address 192.168.200.4 255.255.255.0
 ip ospf 10 area 10

router eigrp 10
 network 192.168.100.0
 no auto-summary
!
router ospf 10
 log-adjacency-changes
 redistribute connected subnets route-map CONN->OSPF
 redistribute eigrp 10 subnets

route-map CONN->OSPF permit 10
 match interface Loopback0

But Eigrp interface s1/0.100 is not redistributed in OSPF, because it connected against R5 and not permitted in CONN->OSPF route-map.

Am I allowed in lab to modify route-map? for example something like

route-map CONN->OSPF permit 10
 match interface Loopback0
route-map CONN->OSPF permit 20
 match interface s1/0.100



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:11 ART