RE: OSPF default route

From: Brian McGahan (bmcgahan@internetworkexpert.com)
Date: Sat Aug 04 2007 - 10:06:19 ART


Hi Prasad,

        Yes that is correct, with this configuration the router can only
detect a failure of its directly connected interface. A workaround for
this would be to use the IP SLA feature and a static route that uses
Enhanced Object Tracking. The configuration would look like this:

R4 and R6 share an Ethernet segment, while R4 has another Ethernet
connecting to BB3.

Rack13R4:
!
ip sla monitor 10
 type pathEcho protocol ipIcmpEcho 204.12.13.254
 timeout 2000
 frequency 5
ip sla monitor schedule 10 start-time now
!
track 20 rtr 10
!
interface Ethernet0/0
 ip address 204.12.13.4 255.255.255.0
!
interface Ethernet0/1
 ip address 155.1.146.4 255.255.255.0
!
router ospf 1
 network 155.1.0.0 0.0.255.255 area 0
 default-information originate route-map DEFAULT
!
ip route 204.12.13.254 255.255.255.255 Ethernet0/0 track 20
!
ip prefix-list BB3 seq 5 permit 204.12.13.254/32
!
route-map DEFAULT permit 10
 match ip address prefix-list BB3

Rack13R6:
interface GigabitEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
!
router ospf 1
 network 155.1.0.0 0.0.255.255 area 0

While R4 has reachability the static route is installed and the default
route is originated:

Rack13R4#show ip sla monitor statistics 10
Round trip time (RTT) Index 10
        Latest RTT: 4 ms
Latest operation start time: *17:28:00.531 UTC Sat Mar 16 2002
Latest operation return code: OK
Operation time to live: 3217 sec

Rack13R4#show track 20
Track 20
  Response Time Reporter 10 state
  State is Up
    3 changes, last change 00:03:00
  Latest operation return code: OK
  Latest RTT (millisecs) 4
  Tracked by:
    STATIC-IP-ROUTING 0

Rack13R4#show ip route static
     204.12.13.0/24 is variably subnetted, 2 subnets, 2 masks
S 204.12.13.254/32 is directly connected, Ethernet0/0

Rack1R6#show ip route ospf
     155.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 155.1.0.0/24
           [110/65] via 155.1.146.4, 00:04:04, GigabitEthernet0/0.146
O 155.1.45.0/24
           [110/65] via 155.1.146.4, 00:04:04, GigabitEthernet0/0.146
O*E2 0.0.0.0/0 [110/1] via 155.1.146.4, 00:02:21, GigabitEthernet0/0.146

Indirect failure occurs:

Rack13SW3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Rack13SW3(config)#int fa0/24
Rack13SW3(config-if)#shut

R4's local interface is still up but the tracked object is down:

Rack13R4#show ip int brief | in Status|Ethernet
Interface IP-Address OK? Method Status
Protocol
Ethernet0/0 204.12.13.4 YES manual up
up
Ethernet0/1 155.1.146.4 YES manual up
up

Rack13R4#show ip sla monitor statistics 10
Round trip time (RTT) Index 10
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *17:28:35.531 UTC Sat Mar 16 2002
Latest operation return code: Timeout
Operation time to live: 3133 sec

Rack13R4#show track 20
Track 20
  Response Time Reporter 10 state
  State is Down
    4 changes, last change 00:00:05
  Latest operation return code: Timeout
  Tracked by:
    STATIC-IP-ROUTING 0

Static route is withdrawn hence default route is withdrawn:

Rack13R4#show ip route static

Rack13R6#show ip route ospf
     155.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 155.1.0.0/24
           [110/65] via 155.1.146.4, 00:06:32, GigabitEthernet0/0.146
O 155.1.45.0/24
           [110/65] via 155.1.146.4, 00:06:32, GigabitEthernet0/0.146

HTH,

Brian McGahan, CCIE #8593 (R&S/SP/Security)
bmcgahan@internetworkexpert.com
 
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/
 

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Prasad Shemrudkar (pshemrud)
> Sent: Saturday, August 04, 2007 7:38 AM
> To: Cisco certification
> Subject: OSPF default route
>
> Hi,
>
> I have a situation wherein there are 2 routers say R1 and BB1
connected
> to a switch. The subnet is 204.12.1.0/24. R1 needs to conditionally
> advertise a default route in ospf domain if it is CONNECTED to BB1.
Now
> I have used the following configuration on R1 but do not think its
> correct (for the reason explained below the configuration).
>
> router ospf 1
> router-id 150.1.3.3
> log-adjacency-changes
> area 0 authentication message-digest
> area 23 virtual-link 150.1.2.2
> area 34 authentication
> area 34 virtual-link 150.1.4.4
> redistribute connected subnets route-map CONNECTED
> redistribute rip subnets route-map RIP-->OSPF
> network 191.1.13.3 0.0.0.0 area 13
> network 191.1.23.3 0.0.0.0 area 23
> network 191.1.34.3 0.0.0.0 area 34
> default-information originate route-map DEFAULT
> !
> route-map DEFAULT permit 10
> match ip address prefix-list BB1
> !
> ip prefix-list BB1 seq 10 permit 204.12.1.0/24
>
> My point is, that since both router connect on Ethernet (via switch),
> even if BB1 looses connectivity to the switch, the directly connected
> route "C 204.12.1.0/24 is directly connected, Ethernet1/0" will
still
> be shown in R1's routing table (as that one is still connected) and
> hence R1 will continue advertising the default route in OSPF even
though
> there is no connectivity between R1 and BB1.
>
> I dunno but got a feeling, have a wrong logic as the solution has
> configured it the same way too!!
>
> Thanks in Advance,
>
> Prasad
>
>



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:09 ART