Re: VLAN based QOS

From: Marc La Porte (marc.a.laporte@gmail.com)
Date: Fri Aug 03 2007 - 03:21:16 ART


Hi Mike,

WIth the 3560 you can do VLAN-based QoS. I've implemented the below solution
successfully for classifying/remarking voice and data traffic on the access
layer.

Hope this helps...

mls qos
!
ip access-list extended DATA_DEFAULT
 permit ip any any
!
ip access-list extended BEARER
 permit udp any range 2048 65535 any
 permit udp any any range 2048 65535
!
ip access-list extended SIGNALING
 permit udp any eq 1719 any
 permit udp any any eq 1719
 permit tcp any eq 1720 any
 permit tcp any any eq 1720
 permit tcp any eq 2945 any
 permit tcp any any eq 2945
 permit tcp any eq 1039 any
 permit tcp any any eq 1039
!
class-map match-all VOICE_BEARER
 match access-group name BEARER
!
class-map match-all VOICE_SIGNALING
 match access-group name SIGNALING
!
class-map match-all BE
 match access-group name DATA_DEFAULT
!
policy-map MARK_VOICE
 class VOICE_BEARER
  set ip dscp 46
 class VOICE_SIGNALING
  set ip dscp 26
!
policy-map MARK_OTHER
 class BE
  set ip dscp default
!
interface range FastEthernet 1/0/1 - 24
 mls qos vlan-based
!
interface Vlan125
 description *** DATA VLAN ***
 service-policy input MARK_OTHER
!
interface Vlan225
 description *** VOICE VLAN ***
 service-policy input MARK_VOICE
!

Marc

On 8/3/07, Mike M <mike_malan@yahoo.co.uk> wrote:
>
> Hello,
>
> I am configuring a 3560 with a WS-C3560G-24PS and
> 12.2(35)SE C3560-ADVIPSERVICESK IOS version and the
> suggested vlan match is not available as a match
> option.
>
> See below.
>
> Rack1SW1(config)#class-map match-all TEST
> Rack1SW1(config-cmap)#mat
> Rack1SW1(config-cmap)#match ?
> access-group Access group
> input-interface Select one or more input
> interfaces to match
> ip IP specific values
>
> --- ISolveSystems <support@isolvesystems.com> wrote:
>
> > You can actually match vlan.
> >
> > class-map match-all TEST
> > match vlan 123
> >
> >
> > On 8/2/07, Gregory Gombas <ggombas@gmail.com> wrote:
> > >
> > > Is there a way to configure a QOS policy on a
> > catalyst 3560 to match
> > > all ports in the vlan without having to use the
> > match input-interface
> > > command?
> > >
> > > I want to be able to match all ports in the vlan
> > without having to
> > > manually specify them.
> > >
> > > This would also be useful if you wanted to apply a
> > policy to a vlan
> > > and have it automatically take effect as you add
> > users to the vlan
> > > without having to modify the class maps each time.
> > >
> > > Thanks
> > >
> > >
> >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
>
>
>
>
> ___________________________________________________________
> Yahoo! Mail is the world's favourite email. Don't settle for less, sign up
> for
> your free account today
> http://uk.rd.yahoo.com/evt=44106/*http://uk.docs.yahoo.com/mail/winter07.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:09 ART