From: Theo M (theorack@gmail.com)
Date: Thu Aug 02 2007 - 12:02:23 ART
Hello,
Just wanted to point something out: when using "no ip route-cache" for
debugging purposes,
in fact it configures TWO commands on the interface ( IOS is 12.4(10a) ).
When doing a "ip route-cache", it puts just one of them in the previous
state, so CEF remains disabled.
So trying to debug something could break some configurations that need CEF
on that interface, e.g. NBAR.
Here is an example, unedited:
>>>
Rack1R1(config-if)#do sh run int s0/2/0
Building configuration...
Current configuration : 228 bytes
!
interface Serial0/2/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
ip ospf network broadcast
frame-relay map ip 10.0.0.4 104 broadcast
frame-relay map ip 10.0.0.5 105 broadcast
no frame-relay inverse-arp
end
Rack1R1(config-if)#no ip route-cache
Rack1R1(config-if)#
Rack1R1(config-if)#do sh run int s0/2/0
Building configuration...
Current configuration : 270 bytes
!
interface Serial0/2/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
ip ospf network broadcast
frame-relay map ip 10.0.0.4 104 broadcast
frame-relay map ip 10.0.0.5 105 broadcast
no frame-relay inverse-arp
end
Rack1R1(config-if)#ip route-cache
Rack1R1(config-if)#
Rack1R1(config-if)#do sh run int s0/2/0
Building configuration...
Current configuration : 251 bytes
!
interface Serial0/2/0
ip address 10.0.0.1 255.0.0.0
encapsulation frame-relay
no ip route-cache cef
ip ospf network broadcast
frame-relay map ip 10.0.0.4 104 broadcast
frame-relay map ip 10.0.0.5 105 broadcast
no frame-relay inverse-arp
end
Rack1R1(config-if)#
<<<
--
This archive was generated by hypermail 2.1.4 : Sat Sep 01 2007 - 11:32:09 ART