From: Bit Gossip (bit.gossip@chello.nl)
Date: Fri Jul 27 2007 - 17:26:10 ART
Hi Nitin,
as R3 has equal cost path to both loopback of r1 and r2, it load-balance
between r1 and r2; so one reason why you have alternate ping could be that
there is no ip connectivity between r1 bvi1 and r2 bvi1.
Anyway I have labbed it and don't have this problem
Bit.
+++++++++++++++++++++++
r3#ping 150.1.1.1 repeat 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 150.1.1.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 44/47/48 ms
r3#ping 150.1.2.2 repeat 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 150.1.2.2, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 1/2/4 ms
r3#trace
r3#traceroute 150.1.1.1
Type escape sequence to abort.
Tracing the route to 150.1.1.1
1 154.1.13.1 28 msec
154.1.23.2 0 msec 4 msec
r3#traceroute 150.1.2.2
Type escape sequence to abort.
Tracing the route to 150.1.2.2
1 154.1.23.2 4 msec
154.1.13.1 28 msec *
r3#show ip route ospf
O IA 192.10.1.0/24 [110/845] via 154.1.23.2, 00:18:49, Serial4/1
[110/845] via 154.1.13.1, 00:18:49, Async1
150.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
O IA 150.1.0.0/22 [110/65] via 154.1.23.2, 00:14:15, Serial4/1
[110/65] via 154.1.13.1, 00:14:15, Async1
~~~~~~~~~~~~~~~~~~~~~~~R1
bridge irb
!
interface Loopback0
ip address 150.1.1.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
no fair-queue
clock rate 128000
frame-relay map bridge 102 broadcast
no frame-relay inverse-arp
bridge-group 1
!
interface Async65
ip address 154.1.13.1 255.255.255.0
encapsulation ppp
ip ospf cost 64
async dynamic routing
async mode dedicated
routing dynamic
!
interface BVI1
ip address 192.10.1.1 255.255.255.0
!
router ospf 1
router-id 150.1.1.1
log-adjacency-changes
area 51 range 150.1.0.0 255.255.252.0
network 150.1.1.1 0.0.0.0 area 51
network 154.1.13.1 0.0.0.0 area 0
network 192.10.1.1 0.0.0.0 area 51
!
~~~~~~~~~~~~~~~~~~~~~~~R2
bridge irb
!
interface Loopback0
ip address 150.1.2.2 255.255.255.0
!
interface Serial4/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay map bridge 201 broadcast
no frame-relay inverse-arp
bridge-group 1
!
interface Serial4/1
ip address 154.1.23.2 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
interface BVI1
bandwidth 128
ip address 192.10.1.2 255.255.255.0
!
router ospf 1
router-id 150.1.2.2
log-adjacency-changes
area 51 range 150.1.0.0 255.255.252.0
network 150.1.2.2 0.0.0.0 area 51
network 154.1.23.2 0.0.0.0 area 0
network 192.10.1.2 0.0.0.0 area 51
!
~~~~~~~~~~~~~~~~~~~~~~~R3
interface Loopback0
ip address 150.1.3.3 255.255.255.0
!
interface Serial4/1
ip address 154.1.23.3 255.255.255.0
encapsulation ppp
serial restart-delay 0
!
interface Async1
ip address 154.1.13.3 255.255.255.0
encapsulation ppp
ip ospf cost 64
async dynamic routing
async mode dedicated
routing dynamic
!
router ospf 1
router-id 150.1.3.3
log-adjacency-changes
network 154.1.13.3 0.0.0.0 area 0
network 154.1.23.3 0.0.0.0 area 0
++++++++++++++++++++++++
----- Original Message -----
From: "NITIN NITIN" <ccie_study_123@yahoo.com>
To: <ccielab@groupstudy.com>
Sent: Friday, July 27, 2007 2:48 PM
Subject: TRANSAPRENT BRIDGING
> Hi Experts ,
>
>
> I'm facing some problem
> There is IRB bridging running on the frame-relay interface of R1 and R2.
> And there is OSPF area 0 adjency between R3 and R2 , R3 and R1. And there
> is
> OSPF area 51 adjacency between R1 and R2.
>
> There is BVI 1 on both R1 and R2 having ip address 192.10.1.1/24 and
> 192.10.1.2/24 respectively.
>
> R1 and R2 have loopbacks 150.1.1.1 and 150.1.2.2respectively.
> R1 and R2 loopbacks are in area 51.
>
> Now we need to summarised these loopback in area 0
> So we configure "area 51 range 150.1.0.0 255.255.252.0" on ABR R1 and R2.
>
> Now R3 has a route for 150.1.0.0/22
>
> O IA 150.1.0.0/22 [110/65] via 154.1.13.1, 00:00:00, Serial2/2
> [110/65] via 154.1.23.2, 00:00:00, Serial2/3
>
> But when we ping the loopback on R1 and R2 we get alternet PING response.
>
> Rack1R3# ping 150.1.1.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 150.1.1.1, timeout is 2 seconds:
> !.!.!
> Success rate is 60 percent (3/5), round-trip min/avg/max = 4/22/60 ms
> Rack1R3# ping 150.1.1.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 150.1.1.1, timeout is 2 seconds:
> .!.!.
> Success rate is 40 percent (2/5), round-trip min/avg/max = 28/46/64 ms
> Rack1R3#
> Rack1R3#
>
>
>
> Now if we shutdown serial between R3 and R1 we get 100% loss in ping
> response.
>
> Note this is configured on Dynamips.<<<<<<<<<<<<<<<<<<<
>
> CONFIGURATIONS ------
>
> R3 ---
>
> no ip cef
> !
> interface Loopback0
> ip address 150.1.3.3 255.255.255.0
> !
> interface FastEthernet0/0
> ip address 154.1.38.3 255.255.255.0
> duplex full
> !
> interface FastEthernet1/0
> ip address 154.1.3.3 255.255.255.0
> duplex auto
> speed auto
> !
> interface FastEthernet1/1
> no ip address
> shutdown
> duplex auto
> speed auto
> !
> interface Serial2/0
> ip address 154.1.0.3 255.255.255.0
> encapsulation frame-relay
> ip ospf network point-to-multipoint non-broadcast
> serial restart-delay 0
> frame-relay map ip 154.1.0.4 304
> frame-relay map ip 154.1.0.5 305
> no frame-relay inverse-arp
> !
> interface Serial2/2
> ip address 154.1.13.3 255.255.255.0
> serial restart-delay 0
> !
> interface Serial2/3
> ip address 154.1.23.3 255.255.255.0
> serial restart-delay 0
> !
> router ospf 1
> router-id 150.1.3.3
> log-adjacency-changes
> network 7.7.7.7 0.0.0.0 area 51
> network 150.1.3.3 0.0.0.0 area 3457
> network 154.1.0.3 0.0.0.0 area 3457
> network 154.1.3.3 0.0.0.0 area 0
> network 154.1.13.3 0.0.0.0 area 0
> network 154.1.23.3 0.0.0.0 area 0
> neighbor 154.1.0.4 cost 97
> neighbor 154.1.0.5 cost 195
>
>
>
>
>
> R2 config ----------------
>
>
>
> ip cef
> bridge irb
> !
> interface Loopback0
> ip address 150.1.2.2 255.255.255.0
> !
> interface FastEthernet0/0
> no ip address
> duplex full
> bridge-group 1
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay map bridge 201 broadcast
> no frame-relay inverse-arp
> bridge-group 1
> !
> interface Serial2/1
> ip address 154.1.23.2 255.255.255.0
> serial restart-delay 0
> !
> interface BVI1
> ip address 192.10.1.2 255.255.255.0
> !
> router ospf 1
> router-id 150.1.2.2
> log-adjacency-changes
> area 51 range 150.1.0.0 255.255.252.0
> network 150.1.2.2 0.0.0.0 area 51
> network 154.1.23.2 0.0.0.0 area 0
> network 192.10.1.2 0.0.0.0 area 51
> !
> ip classless
> no ip http server
> !
> !
> access-list 11 deny 154.1.13.0 0.0.0.255
> access-list 11 permit any
> !
> !
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
>
>
> R1 CONFig -----------------------
>
> ip cef
> !
> bridge irb
> !
> interface Loopback0
> ip address 150.1.1.1 255.255.255.0
> !
> interface FastEthernet0/0
> no ip address
> duplex full
> bridge-group 1
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay map bridge 102 broadcast
> no frame-relay inverse-arp
> bridge-group 1
> !
> interface Serial2/1
> ip address 154.1.13.1 255.255.255.0
> serial restart-delay 0
> !
> interface BVI1
> ip address 192.10.1.1 255.255.255.0
> !
> router ospf 1
> router-id 150.1.1.1
> log-adjacency-changes
> area 51 range 150.1.0.0 255.255.252.0
> network 150.1.1.1 0.0.0.0 area 51
> network 154.1.13.1 0.0.0.0 area 0
> network 192.10.1.1 0.0.0.0 area 51
> !
> ip classless
> no ip http server
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
>
>
>
> ---------------------------------
> Building a website is a piece of cake.
> Yahoo! Small Business gives you all the tools to get online.
>
> ---------------------------------
> Get the free Yahoo! toolbar and rest assured with the added security of
> spyware protection.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sat Aug 18 2007 - 08:17:42 ART